Bug 250538 - Ark doesn't handle password-protected 7zip files with encrypted header properly
Summary: Ark doesn't handle password-protected 7zip files with encrypted header properly
Status: RESOLVED DUPLICATE of bug 35371
Alias: None
Product: ark
Classification: Applications
Component: general (show other bugs)
Version: 2.14
Platform: openSUSE Linux
: NOR wishlist with 40 votes (vote)
Target Milestone: ---
Assignee: Harald Hvaal
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-08 11:10 UTC by Joël Schaerer
Modified: 2010-09-08 15:38 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joël Schaerer 2010-09-08 11:10:33 UTC
Version:           2.14 (using KDE 4.4.4) 
OS:                Linux

7zip offers two ways to encrypt files: encrypt file contents only, or encrypt the header, making it impossible to see the list of files without the password.

Ark supports the first type properly, by prompting for a password when the user tries to extract a file.

However it fails with the second type, trying for a while (~1 min) to read the archive, then failing with a "Reading the archive xxx. failed with the error 'Incorrect password'.

Reproducible: Always

Steps to Reproduce:
1. Create archive with 7zip: 7z -ptoto -mhe=on a somefile.txt
2. Try to open it with ark.


Expected Results:  
It would be nice to have ark fully support these files, however, it should at least fail immediately with a "Ark doesn't support encrypted-header 7z files at the moment" type of error message.
Comment 1 Raphael Kubo da Costa 2010-09-08 14:32:17 UTC

*** This bug has been marked as a duplicate of bug 35371 ***
Comment 2 Joël Schaerer 2010-09-08 15:22:31 UTC
Note that 7z and zip are entirely different formats, which is why I created a new bug for this.
Comment 3 Raphael Kubo da Costa 2010-09-08 15:38:07 UTC
I'm actually concentrating all the password-related bugs there -- many of the other duplicates are related to Ark failing with RAR files as well.