Bug 250508 - Wrong design of settings
Summary: Wrong design of settings
Status: RESOLVED FIXED
Alias: None
Product: konsole
Classification: Unclassified
Component: general (show other bugs)
Version: 2.5
Platform: Slackware Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-08 01:57 UTC by Andrzej
Modified: 2012-01-22 04:50 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.9.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andrzej 2010-09-08 01:57:37 UTC
Version:           2.5 (using KDE 4.5.0) 
OS:                Linux

To be honest I do not understand the logic behind putting tab or windows related options into profiles.
These options are application specific e.g. so what that I have tab behaviour defined in a profile if changing profile doesn't change tab.
It is a design flaw and should be fixed.
Please take these options into separate menu e.g. Settings -> Configure Konsole


Reproducible: Always




OS: Linux (i686) release 2.6.35.4
Compiler: gcc
Comment 1 Jekyll Wu 2012-01-22 04:50:24 UTC
I have just pushed some commits onto the master branch. Options for menubar and tabbar have been moved out of profiles and now live in the newly added "Configure Konsole" dialog. You can check the latest code from https://projects.kde.org/projects/kde/kde-baseapps/konsole and get a general feeling about it.

There might be other options which are more logical to be global than per-profile. If so, please open one report for each of them respectively so that it is easier to track them in a clear way.  I'll close this report since it is a little too generic and all mentioned options have been migrated.