Bug 250483 - Current Track, Albums, CoverBling are not updated on playback during startup.
Summary: Current Track, Albums, CoverBling are not updated on playback during startup.
Status: RESOLVED DUPLICATE of bug 241641
Alias: None
Product: amarok
Classification: Applications
Component: Context View (show other bugs)
Version: 2.4-GIT
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: 2.3.2
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-07 20:13 UTC by conrad-huebler
Modified: 2010-09-21 10:51 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description conrad-huebler 2010-09-07 20:13:34 UTC
Version:           2.3.2-GIT (using KDE 4.5.0) 
OS:                Linux

The Applets Current Track, Albums and CoverBling are not up to date when resuming a playback after startup of Amarok or after opening a music file with 'amarok file'.

- The Current Track Info displays that no track is being played and shows instead a couple of other tracks. 
- The Album Applet does only show the last added albums as it does when no track is playing but opens the album of current track if it is one of the last added.
- CoverBling does not show the current album.

After changing the track manually oder by playlist als applets behave as the should.


Reproducible: Always

Steps to Reproduce:
1. Play a track, quit amarok and restart, resume playback on startup must be enabled
2. or: type 'amarok musicfile'

Actual Results:  
Current Track Applet, Albums applet and CoverBling pretend that no track is being played.

Expected Results:  
The Applet should show the current track and the albums as they do on normal change of track.
Comment 1 Myriam Schweingruber 2010-09-07 21:42:07 UTC
JFYI: You are using 2.3.1-git, 2.3.2-git branch doesn't exist yet

*** This bug has been marked as a duplicate of bug 241641 ***