Bug 250204 - Make opening recent files on startup optional
Summary: Make opening recent files on startup optional
Status: RESOLVED FIXED
Alias: None
Product: lokalize
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Simon Depiets
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-04 22:03 UTC by OsamaK
Modified: 2018-09-26 07:57 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description OsamaK 2010-09-04 22:03:39 UTC
Version:           unspecified
OS:                Linux

I don't find the 'open recent files on startup' helpful to me. I suggest adding an option to disable this feature.

Reproducible: Always

Steps to Reproduce:
1. Open Lokalize
2. Open a few gettext files.
3. Close Lokalize.
4. Reopen it.

Actual Results:  
The recent files are opened and there is no option to disable this feautre

Expected Results:  
An option that allows to disable this feature.
Comment 1 Nick Shaforostoff 2010-11-26 17:38:48 UTC
what's your use case?

my guess is that you start lokalize not directly, but clickng on a .po or .xliff file in dolphin?
Comment 2 OsamaK 2010-11-26 17:42:03 UTC
Right. In my actual case I used Nautilus on GNOME, but there shouldn't be any difference on Dolphin.
Comment 3 Kai Uwe Broulik 2011-02-21 22:02:37 UTC
When I open a .po file from dolphin, I just want this file opened in Lokalize and that‘s it. It wasn‘t so bad having recent files open if Lokalize
1. didn‘t open another window anyway, so you have like 10 windows opened and each with the history of the previous one
2. and the most annoying thing: it doesn‘t reliably focus the file opened, for example I have bluedevil.po open and then I open knetworkmanager.po, the file gets opened but is the first item in the tab list (rather than the last one) and doesn‘t get focus, there‘s some flickering and then I am back at the bluedevil.po
Comment 4 rgpublic 2014-07-28 10:14:09 UTC
3 years after the last comment... I'd still like to note that this "feature" is extremely annoying. My "use case" is also opening files from Dolphin. This is especially necessary because Lokalize doesn't have proper KIO support. And the only way to reupload the file to the server is: 1) Open the file 2) Edit 3) Close Lokalize.
Comment 5 Simon Depiets 2018-09-26 07:57:46 UTC
Git commit 7ac63b015e77717cc75c02ae804779887084b231 by Simon Depiets.
Committed on 26/09/2018 at 07:57.
Pushed by sdepiets into branch 'master'.

Make opening recent files on startup optional

Created a new category General in Lokalize Settings and added an option to not open the recent files on startup.

M  +1    -0    src/CMakeLists.txt
M  +2    -1    src/lokalizemainwindow.cpp
M  +8    -3    src/prefs/lokalize.kcfg
M  +7    -0    src/prefs/prefs.cpp
M  +0    -34   src/prefs/prefs_editor.ui
A  +78   -0    src/prefs/prefs_general.ui

https://commits.kde.org/lokalize/7ac63b015e77717cc75c02ae804779887084b231
Comment 6 Simon Depiets 2018-09-26 07:57:46 UTC
Git commit 7ac63b015e77717cc75c02ae804779887084b231 by Simon Depiets.
Committed on 26/09/2018 at 07:57.
Pushed by sdepiets into branch 'master'.

Make opening recent files on startup optional

Created a new category General in Lokalize Settings and added an option to not open the recent files on startup.

M  +1    -0    src/CMakeLists.txt
M  +2    -1    src/lokalizemainwindow.cpp
M  +8    -3    src/prefs/lokalize.kcfg
M  +7    -0    src/prefs/prefs.cpp
M  +0    -34   src/prefs/prefs_editor.ui
A  +78   -0    src/prefs/prefs_general.ui

https://commits.kde.org/lokalize/7ac63b015e77717cc75c02ae804779887084b231