Bug 249830 - All but one module fails to display any information and 'export' menu item is disabled
Summary: All but one module fails to display any information and 'export' menu item is...
Status: RESOLVED FIXED
Alias: None
Product: kinfocenter
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: David Hubner
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-09-02 06:54 UTC by Terry
Modified: 2010-12-29 15:40 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Terry 2010-09-02 06:54:20 UTC
Version:           unspecified (using KDE 4.5.0) 
OS:                Linux

The only module which displays information is 'Summary'.  The others show nothing.  There is a menu 'Export' which is disabled.

Reproducible: Always

Steps to Reproduce:
Open kinfocenter and select modules in the left panel.

Actual Results:  
The only information displayed in the right panel is for 'Summary'.

Expected Results:  
The right panel would show details of the module selected in the left panel.

OS: Linux (i686) release 2.6.32.11-pclos2.bfs
Compiler: gcc
KDE Info Centre
Version 4.5.00 (KDE 4.5.0)
Comment 1 David Hubner 2010-09-02 18:15:59 UTC
Now this is odd! Can you give me your QT Version?
Comment 2 Terry 2010-09-03 03:16:03 UTC
Thanks.  I don't know how to find out the qt version.  These files are installed:
libqt3 3.3.8b-1pclos2010
qt3-common 3.3.8b-1pclos2010
qt4-common 4.7.0-0.3pclos2010
task-qt4 4.5.2-1pclos2009

In the light of your reply, I am filing a topic on the PCLinuxOS forum.

Regards,

T. North

--- On Fri, 3/9/10, David Hubner <hubnerd@ntlworld.com> wrote:

From: David Hubner <hubnerd@ntlworld.com>
Subject: [Bug 249830] All but one module fails to display any information and 'export' menu item is disabled
To: terauck-kde@yahoo.com.au
Received: Friday, 3 September, 2010, 2:16 AM

https://bugs.kde.org/show_bug.cgi?id=249830


David Hubner <hubnerd@ntlworld.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|UNCONFIRMED                 |ASSIGNED
     Ever Confirmed|0                           |1




--- Comment #1 from David Hubner <hubnerd ntlworld com>  2010-09-02 18:15:59 ---
Now this is odd! Can you give me your QT Version?
Comment 3 Terry 2010-09-03 08:06:53 UTC
QT version is 4.7.0

--- On Fri, 3/9/10, David Hubner <hubnerd@ntlworld.com> wrote:

From: David Hubner <hubnerd@ntlworld.com>
Subject: [Bug 249830] All but one module fails to display any information and 'export' menu item is disabled
To: terauck-kde@yahoo.com.au
Received: Friday, 3 September, 2010, 2:16 AM

https://bugs.kde.org/show_bug.cgi?id=249830


David Hubner <hubnerd@ntlworld.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|UNCONFIRMED                 |ASSIGNED
     Ever Confirmed|0                           |1




--- Comment #1 from David Hubner <hubnerd ntlworld com>  2010-09-02 18:15:59 ---
Now this is odd! Can you give me your QT Version?
Comment 4 David 2010-09-04 01:27:39 UTC
Hello,
I am having the same bug on both my Kubuntu computers (laptop and PC), they use
the Kubuntu/KDE backports (KDE 4.5) and different kernels, so Qt 4.7.0 is installed. If you need any more information on the system write me a mail.
Comment 5 Terry 2010-09-04 06:57:49 UTC
I have updated my system:
$ kde4-config --version
Qt: 4.7.0
KDE Development Platform: 4.5.1 (KDE 4.5.1)
kde4-config: 1.0

I am now able to get other items to display.  That happened only when I double-clicked an item in the left panel.  The previous version of kinfocenter merely required selection.  That may have been the problem all along.  I apologise for possibly misreporting a bug, although I see someone else has also reported it.
Comment 6 David Hubner 2010-09-04 15:01:38 UTC
It still should be single click so I still need to look at it. Never be afraid to report a bug, even if its intended behaviour, its better to be sure :)
Comment 7 David 2010-09-05 12:11:44 UTC
Fixed in KDE 4.5.1? 
Here it didn't work at all, but in KDE 4.5.1 it works with double clicks on the modules. in KDE 4.5 I could click on it twice or hundred times but only the summaries got displayed ...
Comment 8 David Hubner 2010-12-29 15:40:23 UTC
I have made the kinfocenter consistant with the double click, single click format of KDE4. Fixed in commit 1210100