Bug 249701 - Rekonq does not open distrowatch.com
Summary: Rekonq does not open distrowatch.com
Status: RESOLVED FIXED
Alias: None
Product: rekonq
Classification: Unclassified
Component: general (show other bugs)
Version: 0.5.80
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Andrea Diamantini
URL:
Keywords:
: 250077 250614 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-09-01 04:24 UTC by claydoh
Modified: 2010-11-30 17:11 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description claydoh 2010-09-01 04:24:15 UTC
Version:           unspecified (using KDE 4.5.0) 
OS:                Linux

Using Rekonq as my main browser.

I cannot get it to open http://distrowatch.com. It doesn't leave the current page I am on at the time, and if I try to open it in a new tab/window, it just has a blank page, This happens for any subpage as well.

This is the only page I have come across that does this.

Reproducible: Always

Steps to Reproduce:
Open rekonq, and try typing in the url for Distrowatch, or click a link dfrom another page to it, or open a bookmark to it. 

Actual Results:  
Either it doesn't seem to even try to go to the url in an existing window, or opens a blank tab/window

Expected Results:  
the url should open to the desired page

OS: Linux (i686) release 2.6.35-19-generic
Compiler: cc
Comment 1 claydoh 2010-09-01 04:32:10 UTC
Using version 0.5.83
Comment 2 Panagiotis Papadopoulos 2010-09-01 12:05:16 UTC
It’s an adblock issue:
If you disable adblocking the page loads fine…

@Andrea:
I don’t know what to do with this bug… Set it to invalid or let it opened?
Comment 3 claydoh 2010-09-01 15:52:35 UTC
I should also note that it did work correctly in 0.5x up until 0.5.83 as far as I remember. So what in the adblock could have changed?
Comment 4 Panagiotis Papadopoulos 2010-09-02 13:18:27 UTC
there are several other sites that do not load at all when adblocking is enabled…
I’ll try to compile a list and then post it here.
I guess we should leave this bugreport open, since it is kind of a weird behavior not loading a site at all.
Comment 5 Panagiotis Papadopoulos 2010-09-08 13:14:56 UTC
the commit http://gitorious.org/rekonq/mainline/commit/4b26856731110c0bc4123e1874c6726ffbeb797d seems to be fixing this issue. I’ll leave this report open, until the commit lands in the mainline branch :-)
Comment 6 Panagiotis Papadopoulos 2010-09-09 03:41:04 UTC
*** Bug 250614 has been marked as a duplicate of this bug. ***
Comment 7 Panagiotis Papadopoulos 2010-09-09 03:45:33 UTC
*** Bug 250077 has been marked as a duplicate of this bug. ***
Comment 8 Panagiotis Papadopoulos 2010-09-11 02:37:33 UTC
fixed by commit 225c2618a66b48e415a20580a12bf4e01ab29ca5
Comment 9 Ivan D Vasin 2010-11-30 17:11:20 UTC
(In reply to comment #8)
> fixed by commit 225c2618a66b48e415a20580a12bf4e01ab29ca5

did this make it into rekonq 0.6.1?  <http://distrowatch.com> renders fine for me with 0.6.1, but the pages mentioned in bug #253329 do not.