Bug 249316 - highlighting engine ignores fallthrough="true"
Summary: highlighting engine ignores fallthrough="true"
Status: RESOLVED FIXED
Alias: None
Product: kate
Classification: Unclassified
Component: syntax (show other bugs)
Version: 0.2
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-28 13:05 UTC by Lukas Sommer
Modified: 2012-11-07 23:00 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
bug.xml (811 bytes, text/xml)
2010-08-28 13:06 UTC, Lukas Sommer
Details
syntaxbug (35 bytes, application/octet-stream)
2010-08-28 13:07 UTC, Lukas Sommer
Details
snapshot.png (24.37 KB, image/png)
2010-08-28 13:07 UTC, Lukas Sommer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Sommer 2010-08-28 13:05:41 UTC
Version:           0.2 (using KDE 4.3.5) 
OS:                Linux

The highlighting engine of Kate ignores the attribute fallthrough="true" in a Context tag if this Context tag is the first one in the highlighting XML file.

Reproducible: Didn't try

Steps to Reproduce:
Install the attached bug.xml.

Open the attached file "syntaxbug"

Actual Results:  
In line 2 and 3, the letters 'd' are displayed as dsNormal and abc as 'dsDataType'.

Expected Results:  
In line 2, the whole line falls through the context "default" because no rule matches. It should therefore be displayed entirely as dsError (red). In line 3, starting with the first 'd', everything (also 'abc') should be displayed as dsError.

OS: Linux (i686) release 2.6.31.12-0.2-default
Compiler: gcc
Comment 1 Lukas Sommer 2010-08-28 13:06:47 UTC
Created attachment 51047 [details]
bug.xml
Comment 2 Lukas Sommer 2010-08-28 13:07:33 UTC
Created attachment 51048 [details]
syntaxbug
Comment 3 Lukas Sommer 2010-08-28 13:07:52 UTC
Created attachment 51049 [details]
snapshot.png
Comment 4 Christoph Cullmann 2012-11-07 23:00:28 UTC
Git commit decfe63b0911a58263fc7e20c448468ea3efe0d9 by Christoph Cullmann.
Committed on 07/11/2012 at 23:59.
Pushed by cullmann into branch 'master'.

allow fall-through for initial context if user really wants it ;)

M  +9    -12   part/syntax/katehighlight.cpp

http://commits.kde.org/kate/decfe63b0911a58263fc7e20c448468ea3efe0d9