Bug 249061 - (text?)-Layer drag & drop
Summary: (text?)-Layer drag & drop
Status: RESOLVED WORKSFORME
Alias: None
Product: karbon
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Jan Hambrecht
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-26 02:43 UTC by Fabian B.
Modified: 2021-01-16 04:33 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (5.55 KB, text/plain)
2010-12-10 13:00 UTC, Alessandro Alemanno
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian B. 2010-08-26 02:43:34 UTC
Application: karbon (2.2.2)
KDE Platform Version: 4.5.00 (KDE 4.5.0)
Qt Version: 4.7.0
Operating System: Linux 2.6.35-18-generic i686
Distribution: Ubuntu maverick (development branch)

-- Information about the crash:
i have made some textboxes. then draw a smileys. next create a new layer and drag+drop the textboxes to this new layer. now sometimes karbon crash

The crash can be reproduced some of the time.

-- Backtrace:
Application: Karbon14 (karbon), signal: Segmentation fault
[Current thread is 1 (Thread 0xb7740720 (LWP 25851))]

Thread 2 (Thread 0xb4204b70 (LWP 25856)):
#0  0x004d6f76 in pthread_mutex_lock (mutex=0xacaa354) at forward.c:182
#1  0x04905003 in g_main_context_prepare () from /lib/libglib-2.0.so.0
#2  0x049053d9 in ?? () from /lib/libglib-2.0.so.0
#3  0x049059a8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#4  0x00ba2ecf in QEventDispatcherGlib::processEvents (this=0xa2ae9b8, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#5  0x00b72f19 in QEventLoop::processEvents (this=0xb4204280, flags=) at kernel/qeventloop.cpp:149
#6  0x00b7339a in QEventLoop::exec (this=0xb4204280, flags=...) at kernel/qeventloop.cpp:201
#7  0x00a6fa9e in QThread::exec (this=0xac3e8d8) at thread/qthread.cpp:490
#8  0x00b51e9b in QInotifyFileSystemWatcherEngine::run (this=0xac3e8d8) at io/qfilesystemwatcher_inotify.cpp:248
#9  0x00a72d19 in QThreadPrivate::start (arg=0xac3e8d8) at thread/qthread_unix.cpp:266
#10 0x003d6cc9 in start_thread (arg=0xb4204b70) at pthread_create.c:304
#11 0x004c96ae in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb7740720 (LWP 25851)):
[KCrash Handler]
#7  QSortFilterProxyModelPrivate::proxy_to_source (this=0xcb3a418, proxy_index=...) at itemviews/qsortfilterproxymodel.cpp:368
#8  0x0143cca3 in QSortFilterProxyModel::mapToSource (this=0xcb2ad78, proxyIndex=...) at itemviews/qsortfilterproxymodel.cpp:2491
#9  0x01435f67 in QSortFilterProxyModelPrivate::store_persistent_indexes (this=0xcb3a418) at itemviews/qsortfilterproxymodel.cpp:994
#10 0x0143ac6f in QSortFilterProxyModelPrivate::_q_sourceDataChanged (this=0xcb3a418, source_top_left=..., source_bottom_right=...) at itemviews/qsortfilterproxymodel.cpp:1158
#11 0x0143c784 in QSortFilterProxyModel::qt_metacall (this=0xcb2ad78, _c=QMetaObject::InvokeMetaMethod, _id=5, _a=0xbf84f0a4) at .moc/release-shared/moc_qsortfilterproxymodel.cpp:128
#12 0x0014d5c2 in ?? () from /usr/lib/libkarbonui.so.7
#13 0x00b7a1da in QMetaObject::metacall (object=0xcb2ad78, cl=QMetaObject::InvokeMetaMethod, idx=30, argv=0xbf84f0a4) at kernel/qmetaobject.cpp:237
#14 0x00b8cfdd in QMetaObject::activate (sender=0xcd50238, m=0xca6198, local_signal_index=0, argv=0x2) at kernel/qobject.cpp:3280
#15 0x00bdde79 in QAbstractItemModel::dataChanged (this=0xcd50238, _t1=..., _t2=...) at .moc/release-shared/moc_qabstractitemmodel.cpp:148
#16 0x0014b718 in ?? () from /usr/lib/libkarbonui.so.7
#17 0x01432e08 in QSortFilterProxyModel::setData (this=0xcb2ad78, index=..., value=..., role=33) at itemviews/qsortfilterproxymodel.cpp:1727
#18 0x002d23db in KoDocumentSectionView::currentChanged(QModelIndex const&, QModelIndex const&) () from /usr/lib/libkomain.so.7
#19 0x002d3942 in KoDocumentSectionView::qt_metacall(QMetaObject::Call, int, void**) () from /usr/lib/libkomain.so.7
#20 0x00b7a1da in QMetaObject::metacall (object=0xcc569b0, cl=QMetaObject::InvokeMetaMethod, idx=240096608, argv=0xbf84f184) at kernel/qmetaobject.cpp:237
#21 0x00b8cfdd in QMetaObject::activate (sender=0xcc53d60, m=0x175aa70, local_signal_index=1, argv=0x2) at kernel/qobject.cpp:3280
#22 0x013fa539 in QItemSelectionModel::currentChanged (this=0xcc53d60, _t1=..., _t2=...) at .moc/release-shared/moc_qitemselectionmodel.cpp:159
#23 0x013fa6d2 in QItemSelectionModel::setCurrentIndex (this=0xcc53d60, index=..., command=...) at itemviews/qitemselectionmodel.cpp:1156
#24 0x013a4c4c in QAbstractItemView::mousePressEvent (this=0xcc569b0, event=0xbf850000) at itemviews/qabstractitemview.cpp:1657
#25 0x013f0377 in QTreeView::mousePressEvent (this=0xcc569b0, event=0xbf850000) at itemviews/qtreeview.cpp:1818
#26 0x00e304bc in QWidget::event (this=0xcc569b0, event=0xbf850000) at kernel/qwidget.cpp:8153
#27 0x0124f943 in QFrame::event (this=0xcc569b0, e=0xbf850000) at widgets/qframe.cpp:557
#28 0x012ecce2 in QAbstractScrollArea::viewportEvent (this=0x0, e=0xcb3a418) at widgets/qabstractscrollarea.cpp:1043
#29 0x013a9377 in QAbstractItemView::viewportEvent (this=0xcc569b0, event=0xbf850000) at itemviews/qabstractitemview.cpp:1619
#30 0x013ebaa3 in QTreeView::viewportEvent (this=0xcc569b0, event=0xbf850000) at itemviews/qtreeview.cpp:1256
#31 0x002d2f14 in KoDocumentSectionView::viewportEvent(QEvent*) () from /usr/lib/libkomain.so.7
#32 0x012ef735 in QAbstractScrollAreaPrivate::viewportEvent (this=0xcb81870, o=0xcd9d778, e=0xbf850000) at widgets/qabstractscrollarea_p.h:100
#33 QAbstractScrollAreaFilter::eventFilter (this=0xcb81870, o=0xcd9d778, e=0xbf850000) at widgets/qabstractscrollarea_p.h:116
#34 0x00b73baa in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0xa01af88, receiver=0xcd9d778, event=0xbf850000) at kernel/qcoreapplication.cpp:847
#35 0x00dd2a09 in QApplicationPrivate::notify_helper (this=0xa01af88, receiver=0xcd9d778, e=0xbf850000) at kernel/qapplication.cpp:4385
#36 0x00dd967e in QApplication::notify (this=0xbf850880, receiver=0xcd9d778, e=0xbf850000) at kernel/qapplication.cpp:3952
#37 0x01cd11da in KApplication::notify (this=0xbf850880, receiver=0xcd9d778, event=0xbf850000) at ../../kdeui/kernel/kapplication.cpp:310
#38 0x00b7444b in QCoreApplication::notifyInternal (this=0xbf850880, receiver=0xcd9d778, event=0xbf850000) at kernel/qcoreapplication.cpp:732
#39 0x00dd7ae4 in QCoreApplication::sendEvent (receiver=0xcd9d778, event=0xbf850000, alienWidget=0xcd9d778, nativeWidget=0xcb84b70, buttonDown=0x1769300, lastMouseReceiver=..., spontaneous=true)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#40 QApplicationPrivate::sendMouseEvent (receiver=0xcd9d778, event=0xbf850000, alienWidget=0xcd9d778, nativeWidget=0xcb84b70, buttonDown=0x1769300, lastMouseReceiver=..., spontaneous=true)
    at kernel/qapplication.cpp:3051
#41 0x00e661d0 in QETWidget::translateMouseEvent (this=0xcb84b70, event=0xbf85051c) at kernel/qapplication_x11.cpp:4403
#42 0x00e65611 in QApplication::x11ProcessEvent (this=0xbf850880, event=0xbf85051c) at kernel/qapplication_x11.cpp:3414
#43 0x00e9482a in x11EventSourceDispatch (s=0xa01e140, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#44 0x049019b5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#45 0x049057c8 in ?? () from /lib/libglib-2.0.so.0
#46 0x049059a8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#47 0x00ba2e95 in QEventDispatcherGlib::processEvents (this=0x9fff7b8, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#48 0x00e940a5 in QGuiEventDispatcherGlib::processEvents (this=0x9fff7b8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#49 0x00b72f19 in QEventLoop::processEvents (this=0xbf850814, flags=) at kernel/qeventloop.cpp:149
#50 0x00b7339a in QEventLoop::exec (this=0xbf850814, flags=...) at kernel/qeventloop.cpp:201
#51 0x00b7791f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#52 0x00dd1857 in QApplication::exec () at kernel/qapplication.cpp:3665
#53 0x00207a83 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_karbon.so
#54 0x080485ab in _start ()

Reported using DrKonqi
Comment 1 Cyrille Berger 2010-10-03 12:07:53 UTC
I can't reproduce, do you edit the text ? Are you using the text shape or the artistic text shape ?
Comment 2 Fabian B. 2010-10-03 15:38:53 UTC
i used the normal Textshape with my own text in it. at the Moment i cant force a crash too (: maybe it was fixed by some update? i will try it the next days again
Comment 3 Alessandro Alemanno 2010-12-10 13:00:35 UTC
Created attachment 54387 [details]
New crash information added by DrKonqi

karbon (2.2.2) on KDE Platform 4.5.4 (KDE 4.5.4) using Qt 4.7.0

- What I was doing when the application crashed:

drag and drop object from a layer to another

-- Backtrace (Reduced):
#6  QSortFilterProxyModelPrivate::proxy_to_source (this=0x52ce9e0, proxy_index=...) at itemviews/qsortfilterproxymodel.cpp:368
#7  0x00007f02e921761d in QSortFilterProxyModel::mapToSource (this=<value optimized out>, proxyIndex=...) at itemviews/qsortfilterproxymodel.cpp:2491
#8  0x00007f02e92108a6 in QSortFilterProxyModelPrivate::store_persistent_indexes (this=<value optimized out>) at itemviews/qsortfilterproxymodel.cpp:994
#9  0x00007f02e9210a83 in QSortFilterProxyModelPrivate::_q_sourceLayoutAboutToBeChanged (this=0x52ce9e0) at itemviews/qsortfilterproxymodel.cpp:1242
#10 0x00007f02e9217209 in QSortFilterProxyModel::qt_metacall (this=0x52c76d0, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff5e1b61d0) at .moc/release-shared/moc_qsortfilterproxymodel.cpp:132
Comment 4 Denis Kurz 2018-01-31 16:15:06 UTC
You might want to consider if this was caused by a Qt bug that was resolved fixed in 5.8, as described in Bug 361895, Comment 1.You might want to consider if this was caused by a Qt bug that was resolved fixed in 5.8, as described in Bug 361895, Comment 1.
Comment 5 Justin Zobel 2020-12-17 05:33:50 UTC
Thank you for the crash report.

As it has been a while since this was reported, can you please test and confirm if this issue is still occurring or if this bug report can be marked as resolved.

I have set the bug status to "needsinfo" pending your response, please change back to "reported" or "resolved/worksforme" when you respond, thank you.
Comment 6 Bug Janitor Service 2021-01-01 04:34:22 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 7 Bug Janitor Service 2021-01-16 04:33:55 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!