Bug 249016 - Not possible to add additional addresses with DHCP enabled
Summary: Not possible to add additional addresses with DHCP enabled
Status: RESOLVED FIXED
Alias: None
Product: Network Management
Classification: Unclassified
Component: Plasma Widget (show other bugs)
Version: 0.9
Platform: Ubuntu Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Sebastian Kügler
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-25 17:44 UTC by Henri Valta
Modified: 2011-04-21 01:08 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Enables additional routes also for DHCP in the UI (607 bytes, patch)
2010-11-25 13:40 UTC, Sebastian Kügler
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Henri Valta 2010-08-25 17:44:16 UTC
Version:           0.9 (using KDE 4.5.0) 
OS:                Linux

It would be useful to be able to configure additional (local) network addresses/aliases with DHCP configured interface, for example in home networks.

Reproducible: Always




Requested also in Ubuntu bug 554590
https://bugs.launchpad.net/ubuntu/+source/plasma-widget-networkmanagement/+bug/554590
Comment 1 Aliaksandr Stelmachonak 2010-11-24 23:08:24 UTC
Looks like this is limitation of KDE UI (Gnome network manager applet supports this feature) and making using of VPN connections quite limited. Please fix
Comment 2 Sebastian Kügler 2010-11-25 12:35:53 UTC
Do you mean just like you'd do with the /etc/hosts file?
Comment 3 Aliaksandr Stelmachonak 2010-11-25 12:42:25 UTC
(In reply to comment #2)
> Do you mean just like you'd do with the /etc/hosts file?

No, I mean additional routes command. Currently I can only add additional routes to be set after VPN connection if my VPN doesn't use DHCP. If it does, than I need to setup required routes manually using route add ... command. 
Gnome Network Manager Applet allows you to setup routes non depending of DHCP is used, but KDE plasmoid dialog simply locks routes screen if DHCP is used. 

I can provide you screenshots if required.
Comment 4 Sebastian Kügler 2010-11-25 13:40:19 UTC
Created attachment 53724 [details]
Enables additional routes also for DHCP in the UI

Enables additional routes also for DHCP in the UI
Comment 5 Sebastian Kügler 2010-11-25 13:41:22 UTC
Can you try the above patch and see if it works for you? I don't have the setup to test, but the patch is easy enough that it might 'just work'.
Comment 6 Aliaksandr Stelmachonak 2010-11-25 14:29:13 UTC
(In reply to comment #5)
> Can you try the above patch and see if it works for you? I don't have the setup
> to test, but the patch is easy enough that it might 'just work'.

Now routes section is enabled, I can add them and they will be created after vpn connection established. But there are two issues still exists:
1. List of added routes is empty after you save it and reopen vpn setup. But they are saved somewhere, because they are in place when you establish vpn connection (route command shows them).
2. Looks like some of added routes are not deleted after vpn disconnect. - I can verify this more thoroughly at home, where I have correct network setup.
Comment 7 Aliaksandr Stelmachonak 2010-11-25 21:40:20 UTC
OK, I rechecked this patch at home and looks like only issue number 1 is reproducible - list of added routes is not saved correctly.
Please fix this and I will continue testing.
What about routes deletion after disconnect - everything works as expected.
Comment 8 Lamarque V. Souza 2011-04-21 01:07:59 UTC
Git commit 4a9703177ff67d5c531551a9dca467dce2621818 by Lamarque V. Souza.
Committed on 21/04/2011 at 01:15.
Pushed by lvsouza into branch 'master'.

Enable additional addresses even on DHCP.
Thanks Ilia Kats for this patch.

BUG: 249016
REVIEW: 101165

M  +28   -8    libs/ui/802_11_wirelesswidget.cpp     
M  +28   -19   libs/ui/ipv4widget.cpp     

http://commits.kde.org/networkmanagement/4a9703177ff67d5c531551a9dca467dce2621818
Comment 9 Lamarque V. Souza 2011-04-21 01:08:00 UTC
Git commit ab05f9a030eab2f19af25ea7a535c56d14ce66e6 by Lamarque V. Souza.
Committed on 21/04/2011 at 01:15.
Pushed by lvsouza into branch 'nm09'.

Enable additional addresses even on DHCP.
Thanks Ilia Kats for this patch.

BUG: 249016
REVIEW: 101165
(cherry picked from commit 4a9703177ff67d5c531551a9dca467dce2621818)

M  +28   -8    libs/ui/802_11_wirelesswidget.cpp     
M  +28   -19   libs/ui/ipv4widget.cpp     

http://commits.kde.org/networkmanagement/ab05f9a030eab2f19af25ea7a535c56d14ce66e6