Bug 248902 - k3b crashes when trying to open the config window
Summary: k3b crashes when trying to open the config window
Status: RESOLVED DUPLICATE of bug 238819
Alias: None
Product: k3b
Classification: Unclassified
Component: general (show other bugs)
Version: 1.91.0
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Michał Małek
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-24 15:05 UTC by Miguel Tadeu
Modified: 2010-08-25 12:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Miguel Tadeu 2010-08-24 15:05:41 UTC
Version:           1.91.0
OS:                Linux

When I go to Settings->Configure k3b, it crashes...the odd thing is, there is no crash report. Running from the command line, this is what I get:

k3b(13247) K3b::PluginManager::loadAll:
k3b(13247) K3b::PluginManager::Private::loadPlugin: "K3b Musepack Decoder" "k3bmpcdecoder"
k3b(13247) K3b::PluginManager::Private::loadPlugin: Loaded plugin "K3b Musepack Decoder"
k3b(13247) K3b::PluginManager::Private::loadPlugin: "K3b FFMpeg Decoder" "k3bffmpegdecoder"
k3b(13247) K3b::PluginManager::Private::loadPlugin: Loaded plugin "K3b FFMpeg Decoder"
k3b(13247) K3b::PluginManager::Private::loadPlugin: "K3b Libsndfile Decoder" "k3blibsndfiledecoder"
k3b(13247) K3b::PluginManager::Private::loadPlugin: Loaded plugin "K3b Libsndfile Decoder"
k3b(13247) K3b::PluginManager::Private::loadPlugin: "K3b FLAC Decoder" "k3bflacdecoder"
k3b(13247) K3b::PluginManager::Private::loadPlugin: Loaded plugin "K3b FLAC Decoder"
k3b(13247) K3b::PluginManager::Private::loadPlugin: "K3b MAD Decoder" "k3bmaddecoder"
k3b(13247) K3b::PluginManager::Private::loadPlugin: Loaded plugin "K3b MAD Decoder"
k3b(13247) K3b::PluginManager::Private::loadPlugin: "K3b Wave Decoder" "k3bwavedecoder"
k3b(13247) K3b::PluginManager::Private::loadPlugin: Loaded plugin "K3b Wave Decoder"
k3b(13247) K3b::PluginManager::Private::loadPlugin: "K3b SoX Audio Encoder" "k3bsoxencoder"
k3b(13247) K3b::PluginManager::Private::loadPlugin: Loaded plugin "K3b SoX Audio Encoder"
k3b(13247) K3b::PluginManager::Private::loadPlugin: "K3b External Audio Encoder" "k3bexternalencoder"
k3b(13247) K3b::PluginManager::Private::loadPlugin: Loaded plugin "K3b External Audio Encoder"
k3b(13247) K3b::PluginManager::Private::loadPlugin: "K3b Ogg Vorbis Decoder" "k3boggvorbisdecoder"
k3b(13247) K3b::PluginManager::Private::loadPlugin: Loaded plugin "K3b Ogg Vorbis Decoder"
k3b(13247) K3b::PluginManager::Private::loadPlugin: "K3b Cddb Audio Plugin" "k3baudioprojectcddbplugin"
k3b(13247) K3b::PluginManager::Private::loadPlugin: Loaded plugin "K3b Cddb Audio Plugin"
k3b(13247) K3b::PluginManager::Private::loadPlugin: "K3b Ogg Vorbis Encoder" "k3boggvorbisencoder"
k3b(13247) K3b::PluginManager::Private::loadPlugin: Loaded plugin "K3b Ogg Vorbis Encoder"
k3b(13247) K3b::PluginManager::Private::loadPlugin: "K3b Audio Metainfo Renamer" "k3baudiometainforenamerplugin"
k3b(13247) K3b::PluginManager::Private::loadPlugin: Loaded plugin "K3b Audio Metainfo Renamer"
k3b(13247) K3b::Device::Device::init: (K3b::Device::Device)  "/dev/sr0" : init()
k3b(13247) K3b::Device::Device::checkFeatures: (K3b::Device::Device)  "/dev/sr0"  feature:  CD Mastering
k3b(13247) K3b::Device::Device::checkFeatures: (K3b::Device::Device)  "/dev/sr0"  feature:  CD Track At Once
k3b(13247) K3b::Device::Device::checkFeatures: (K3b::Device::Device)  "/dev/sr0"  feature:  CD-RW Media Write Support
k3b(13247) K3b::Device::Device::checkFeatures: (K3b::Device::Device)  "/dev/sr0"  feature:  DVD Read (MMC5)
k3b(13247) K3b::Device::Device::checkFeatures: (K3b::Device::Device)  "/dev/sr0"  feature:  DVD+R
k3b(13247) K3b::Device::Device::checkFeatures: (K3b::Device::Device)  "/dev/sr0"  feature:  DVD+RW
k3b(13247) K3b::Device::Device::checkFeatures: (K3b::Device::Device)  "/dev/sr0"  feature:  DVD+R Double Layer
k3b(13247) K3b::Device::Device::checkFeatures: (K3b::Device::Device)  "/dev/sr0"  feature:  DVD-R/-RW Write
k3b(13247) K3b::Device::Device::checkFeatures: (K3b::Device::Device)  "/dev/sr0"  feature:  Rigid Restricted Overwrite
k3b(13247) K3b::Device::Device::checkFeatures: (K3b::Device::Device)  "/dev/sr0"  feature:  Layer Jump Recording
k3b(13247) K3b::Device::Device::checkFeatures: (K3b::Device::Device)  "/dev/sr0"  unknown profile:  2
k3b(13247) K3b::Device::Device::checkWritingModes: (K3b::Device::Device)  "/dev/sr0" : dataLen:  60
k3b(13247) K3b::Device::Device::checkWritingModes: (K3b::Device::Device)  "/dev/sr0" : checking for TAO
k3b(13247) K3b::Device::Device::checkWritingModes: (K3b::Device::Device)  "/dev/sr0" : checking for SAO
k3b(13247) K3b::Device::Device::checkWritingModes: (K3b::Device::Device)  "/dev/sr0" : checking for SAO_R96P
k3b(13247) K3b::Device::Device::checkWritingModes: (K3b::Device::Device)  "/dev/sr0" : checking for SAO_R96R
k3b(13247) K3b::Device::Device::checkWritingModes: (K3b::Device::Device)  "/dev/sr0" : checking for RAW_R16
k3b(13247) K3b::Device::Device::checkWritingModes: (K3b::Device::Device)  "/dev/sr0" : checking for RAW_R96P
k3b(13247) K3b::Device::Device::checkWritingModes: (K3b::Device::Device)  "/dev/sr0" : checking for RAW_R96R
k3b(13247) K3b::Device::Device::getSupportedWriteSpeedsViaGP: (K3b::Device::Device)  "/dev/sr0" :  Number of supported write speeds via GET PERFORMANCE:  4
k3b(13247) K3b::Device::Device::getSupportedWriteSpeedsViaGP: (K3b::Device::Device)  "/dev/sr0"  :  4234  KB/s
k3b(13247) K3b::Device::Device::getSupportedWriteSpeedsViaGP: (K3b::Device::Device)  "/dev/sr0"  :  2822  KB/s
k3b(13247) K3b::Device::Device::getSupportedWriteSpeedsViaGP: (K3b::Device::Device)  "/dev/sr0"  :  1764  KB/s
k3b(13247) K3b::Device::Device::getSupportedWriteSpeedsViaGP: (K3b::Device::Device)  "/dev/sr0"  Invalid DVD speed:  706  KB/s
k3b(13247) K3b::Device::DeviceManager::addDevice: (K3b::Device::DeviceManager) setting current write speed of device  "/dev/sr0"  to  3324
k3b(13247) K3b::MediaCache::clearDeviceList:
k3b(13247) K3b::Device::DeviceManager::readConfig: (K3b::Device::DeviceManager) found config entry for devicetype:  "HL-DT-ST DVDRAM GSA-T40N"
k3b(13247) K3b::Device::DeviceManager::printDevices: Devices:
------------------------------
k3b(13247) K3b::Device::DeviceManager::printDevices: Blockdevice:     "/dev/sr0"
Vendor:          "HL-DT-ST"
Description:     "DVDRAM GSA-T40N"
Version:         "JR03"
Write speed:     11080
Profiles:        "DVD-ROM, DVD-R Sequential, DVD-R Dual Layer Sequential, DVD-R Dual Layer Jump, DVD-RAM, DVD-RW Restricted Overwrite, DVD-RW Sequential, DVD+RW, DVD+R, DVD+R Dual Layer, CD-ROM, CD-R, CD-RW"
Read Cap:        "DVD-ROM, DVD-R, DVD-R Sequential, DVD-R Dual Layer, DVD-R Dual Layer Sequential, DVD-R Dual Layer Jump, DVD-RW, DVD-RW Restricted Overwrite, DVD-RW Sequential, DVD+RW, DVD+R, DVD+RW Dual Layer, DVD+R Dual Layer, CD-ROM, CD-R, CD-RW"
Write Cap:       "DVD-R, DVD-R Sequential, DVD-R Dual Layer, DVD-R Dual Layer Sequential, DVD-R Dual Layer Jump, DVD-RW, DVD-RW Restricted Overwrite, DVD-RW Sequential, DVD+RW, DVD+R, DVD+R Dual Layer, CD-R, CD-RW"
Writing modes:   "SAO, TAO, RAW, SAO/R96P, SAO/R96R, RAW/R16, RAW/R96P, RAW/R96R, Restricted Overwrite, Layer Jump"
------------------------------
k3b(13247) K3b::Device::Device::diskInfo: First sec data area:  "43:41:33"  (LBA  "196608" ) ( "402653184"
k3b(13247) K3b::Device::Device::diskInfo: Last sec data area:  "3684:24:22"  (LBA  "16579822" ) ( "33955475456"  Bytes)
k3b(13247) K3b::Device::Device::diskInfo: Last sec layer 1:  "506:00:23"  (LBA  "2277023" ) ( "4663343104"  Bytes)
k3b(13247) K3b::Device::Device::diskInfo: Layer 1 length:  "462:18:66"  (LBA  "2080416" ) ( "4260691968"  Bytes)
k3b(13247) K3b::Device::Device::diskInfo: Layer 2 length:  "3178:23:74"  (LBA  "14302799" ) ( "29292132352"  Bytes)
k3b(13247) K3b::TitleLabel::updatePositioning: 21 21
k3b(13247) K3b::Device::Device::diskInfo: (K3b::Device::Device) READ CAPACITY:  "924:27:21"  other capacity:  "00:00:00"
k3b(13247) K3b::Medium::update: found medium: ( "/dev/sr0" )
=====================================================
k3b(13247) K3b::Device::DiskInfo::debug: DiskInfo:
Mediatype:        "DVD-ROM"
Current Profile:  "DVD-ROM"
Disk state:       complete
Empty:            false
Rewritable:       false
Appendable:       false
Sessions:         1
Tracks:           1
Layers:           2
Capacity:         "924:27:22"  (LBA  4160047 ) ( 8519776256  Bytes)
Remaining size:   "00:00:00"  (LBA  0 ) ( 0  Bytes)
Used Size:        "924:27:22"  (LBA  4160047 ) ( 8519776256  Bytes)
k3b(13247) K3b::Medium::update: =====================================================
k3b(13247) K3b::Medium::analyseContent: (K3b::Medium) found volume id from start sector  0 : ' "CRZLP2W1" '
k3b(13247) K3b::PlacesModel::slotDevicesChanged:
registerWindow Invalid WindowMenu.Registrar! 
k3b(13247)/kdeui (kdelibs): Attempt to use QAction "view_projects" with KXMLGUIFactory! 
k3b(13247)/kdeui (kdelibs): Attempt to use QAction "view_dir_tree" with KXMLGUIFactory! 
k3b(13247)/kdeui (kdelibs): Attempt to use QAction "view_contents" with KXMLGUIFactory! 
k3b(13247)/kdeui (kdelibs): Attempt to use QAction "location_bar" with KXMLGUIFactory! 
k3b(13247) K3b::FileTreeView::setSelectedUrl:
k3b(13247) K3b::PlacesModel::expandToUrl: KUrl("file:///home/miguel/Documents/")
k3b(13247) K3b::PlacesModel::expandToUrl: KUrl("file:///home/miguel")  will be expanded.
k3b(13247) K3b::DirView::showUrl: KUrl("file:///home/miguel/Documents/")
k3b(13247) K3b::DirView::slotDirActivated: KUrl("file:///home/miguel/Documents/")
k3b(13247) K3b::FileView::setUrl: KUrl("file:///home/miguel/Documents/")
k3b(13247) K3b::FileTreeView::setSelectedUrl:
k3b(13247) K3b::PlacesModel::expandToUrl: KUrl("file:///home/miguel/Documents/")
k3b(13247) K3b::PlacesModel::expandToUrl: KUrl("file:///home/miguel")  will be expanded.
k3b(13247) K3b::SystemProblemDialog::checkSystem: (K3b::Core) System problems:
k3b(13247) K3b::SystemProblemDialog::checkSystem:           - none -
k3b(13247) K3b::TitleLabel::updatePositioning: 14 14
k3b(13247) K3b::TitleLabel::updatePositioning: 16 16
k3b(13247) K3b::TitleLabel::updatePositioning: 8 8
k3b(13247) K3b::TitleLabel::updatePositioning: 8 8
k3b(13247) K3b::ViewColumnAdjuster::adjustColumns: 0 1
k3b(13247) K3b::ViewColumnAdjuster::adjustColumns: 1 2
QMetaObject::invokeMethod: No such method K3b::Application::loadCommandLineOptionsForNewInstance()
laptop:~$ k3b(13247) K3b::PlacesModel::slotExpand: QModelIndex(3,0,0x8a20e20,KDirModel(0x87536a0) )
k3b(13247) K3b::FileTreeView::slotExpandUrl:
k3b(13247) K3b::PlacesModel::slotExpand: QModelIndex(3,0,0x8a20e20,KDirModel(0x87536a0) )
k3b(13247) K3b::FileTreeView::slotExpandUrl:
k3b(13247)/kdecore (services) KMimeTypeFactory::parseMagic: Now parsing  "/usr/share/mime/magic"
k3b(13247)/kdecore (services) KMimeTypeFactory::parseMagic: Now parsing  "/home/miguel/.local/share/mime/magic"
k3b(13247) K3b::PluginOptionTab::PluginOptionTab: Adding plugin "K3b Musepack Decoder"
k3b(13247)/kdecore (KPluginInfo) KPluginInfo::kcmServices: found  0  offers for  "k3bmpcdecoder"
k3b(13247) K3b::PluginOptionTab::PluginOptionTab: Adding plugin "K3b FFMpeg Decoder"
k3b(13247)/kdecore (KPluginInfo) KPluginInfo::kcmServices: found  0  offers for  "k3bffmpegdecoder"
k3b(13247) K3b::PluginOptionTab::PluginOptionTab: Adding plugin "K3b Libsndfile Decoder"
k3b(13247)/kdecore (KPluginInfo) KPluginInfo::kcmServices: found  0  offers for  "k3blibsndfiledecoder"
k3b(13247) K3b::PluginOptionTab::PluginOptionTab: Adding plugin "K3b FLAC Decoder"
k3b(13247)/kdecore (KPluginInfo) KPluginInfo::kcmServices: found  0  offers for  "k3bflacdecoder"
k3b(13247) K3b::PluginOptionTab::PluginOptionTab: Adding plugin "K3b MAD Decoder"
k3b(13247)/kdecore (KPluginInfo) KPluginInfo::kcmServices: found  0  offers for  "k3bmaddecoder"
k3b(13247) K3b::PluginOptionTab::PluginOptionTab: Adding plugin "K3b Wave Decoder"
k3b(13247)/kdecore (KPluginInfo) KPluginInfo::kcmServices: found  0  offers for  "k3bwavedecoder"
k3b(13247) K3b::PluginOptionTab::PluginOptionTab: Adding plugin "K3b SoX Audio Encoder"
k3b(13247)/kdecore (KPluginInfo) KPluginInfo::kcmServices: found  1  offers for  "k3bsoxencoder"
k3b(13247) K3b::PluginOptionTab::PluginOptionTab: Adding plugin "K3b External Audio Encoder"
k3b(13247)/kdecore (KPluginInfo) KPluginInfo::kcmServices: found  1  offers for  "k3bexternalencoder"
k3b(13247) K3b::PluginOptionTab::PluginOptionTab: Adding plugin "K3b Ogg Vorbis Decoder"
k3b(13247) K3b::PluginOptionTab::PluginOptionTab: Adding plugin "K3b Cddb Audio Plugin"



Hope it helps

Reproducible: Didn't try

Steps to Reproduce:
Go to menu Settings->Configure k3b

Actual Results:  
Crashes with no crash report


OS: Linux (i686) release 2.6.32-24-generic
Compiler: cc
Comment 1 Christoph Feck 2010-08-25 12:18:46 UTC
Please see bug 238819, which has a patch and indicates that it only happens with Qt 4.7 (which is not released yet).

*** This bug has been marked as a duplicate of bug 238819 ***