Bug 248842 - shortcut for Enlarge Font (control+shift++) doesn't work
Summary: shortcut for Enlarge Font (control+shift++) doesn't work
Status: RESOLVED FIXED
Alias: None
Product: konsole
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-23 21:37 UTC by Jon Nelson
Modified: 2011-01-24 02:22 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jon Nelson 2010-08-23 21:37:44 UTC
Version:           unspecified (using KDE 4.5.0) 
OS:                Linux

The shortcut for Enlarge Font (control+shift++) doesn't work - no idea why.

If you go into the shortcuts menu, and manually choose control (plus) shift (plus) plus, *then* it works, but shows up as Ctrl++.




Reproducible: Always
Comment 1 info 2010-09-29 14:50:05 UTC
I would like to confirm, that the new default shortcuts for increasing and decreasing font size make no sense on an US notebook keyboard.
As described above pressing Ctrl+Shift++ does not work, since you need to press Shift+= to get a plus symbol which then is Ctrl++ (and not Ctrl+Shift++).

Also I would love to see that these shortcuts will be implemented into the kpart of konsole, so that the changed shortcuts get updated in programs like yakauke.

The problem with the current configuration is, that decreasing size works (but can be hit my mistake, since it is the same shortcut in emacs for undoing) but then there is no way do increase the fontsize again, if you have no numpad with + key, which is the case on (almost) all notebooks.
Comment 2 Kurt Hindenburg 2011-01-24 00:10:27 UTC
I agree, CTRL+SHIFT++ really only works if you have a number pad on your keyboard.
Comment 3 Kurt Hindenburg 2011-01-24 02:22:29 UTC
SVN commit 1216565 by hindenburg:

Correct Enlarge Font shortcut such that it actually works.

BUG: 248842


 M  +2 -2      SessionController.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1216565