Bug 248576 - empty entity &David.Sweet.mail; (sonnet handbook)
Summary: empty entity &David.Sweet.mail; (sonnet handbook)
Status: RESOLVED FIXED
Alias: None
Product: docs
Classification: Unclassified
Component: Missing Content (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Documentation Editorial Team
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-21 09:32 UTC by Ludovic Grossard
Modified: 2011-08-03 15:00 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ludovic Grossard 2010-08-21 09:32:56 UTC
Version:           unspecified (using Devel) 
OS:                Linux

It looks like the entity &David.Sweet.mail; is empty because &David.Sweet; &David.Sweet.mail; appears as David Sweet in the manual.

Reproducible: Always
Comment 1 Albert Astals Cid 2010-08-21 14:11:17 UTC
It's not empty
kdelibs/kdoctools/customization/entities/contributor.entities:443:<!ENTITY David.Sweet.mail '<email>dsweet@kde.org</email>'>
Comment 2 Burkhard Lück 2010-08-24 08:39:58 UTC
The entity &David.Sweet.mail; is defined properly in contributors.entities, but nevertheless it does not appear in the generated html.

Looking at kdelibs/kdoctools/docbook/xsl/html/titlepage.xsl only an email in this form is processed to html:
<author>
<firstname>Fred</firstname>
<surname>Flintstone</surname>
<affiliation>
<address>
<email>fred@bedrock.org</email>
</address>
</affiliation>
</author>

But according to http://lists.kde.org/?l=kde-docbook&m=122556813815680&w=2 this form is obsolete and should be replaced by:
<author>
<personname>
<firstname>Fred</firstname>
<surname>Flintstone</surname>
</personname>
<email>fred@stoneage.org</email>
</author>

CC'ing Luigi Toscano, he is working on the XSL stuff afaik.
Comment 3 Burkhard Lück 2011-07-16 12:04:26 UTC
Git commit 89e56764c4e6e619218f65c4a7f999e538d02368 by Burkhard L�ck.
Committed on 16/07/2011 at 14:01.
Pushed by lueck into branch 'KDE/4.7'.

Generate email for docbook authors

Preferred form for authors in kde docbooks is <author> &author.name;
author.name.mail; </author>, where the entifies are defined in
kdelibs/kdoctools/customization/entities/contributor.entities.
But using this form does not generate the email in the html output without this patch
it is missing apparently since several years (around 2004)

REVIEW:101921
BUG:248576
(cherry picked from commit 9c48f7234c42c69909a4a12f013c72ffde77b1c9)

M  +1    -1    kdoctools/customization/kde-ttlpg.xsl
M  +1    -1    kdoctools/customization/kde-ttlpg-online.xsl

http://commits.kde.org/kdelibs/89e56764c4e6e619218f65c4a7f999e538d02368
Comment 4 Burkhard Lück 2011-07-16 12:04:27 UTC
Git commit 9c48f7234c42c69909a4a12f013c72ffde77b1c9 by Burkhard L�ck.
Committed on 16/07/2011 at 14:01.
Pushed by lueck into branch 'master'.

Generate email for docbook authors

Preferred form for authors in kde docbooks is <author> &author.name;
author.name.mail; </author>, where the entifies are defined in
kdelibs/kdoctools/customization/entities/contributor.entities.
But using this form does not generate the email in the html output without this patch
it is missing apparently since several years (around 2004)

REVIEW:101921
CCBUG:248576

M  +1    -1    kdoctools/customization/kde-ttlpg.xsl
M  +1    -1    kdoctools/customization/kde-ttlpg-online.xsl

http://commits.kde.org/kdelibs/9c48f7234c42c69909a4a12f013c72ffde77b1c9
Comment 5 Burkhard Lück 2011-08-03 15:00:49 UTC
Git commit 2534d85a86546fa210d32888f49defb95675a14e by Burkhard Lück.
Committed on 16/07/2011 at 14:01.
Pushed by lueck into branch 'KDE/4.7'.

Generate email for docbook authors

Preferred form for authors in kde docbooks is <author> &author.name;
author.name.mail; </author>, where the entifies are defined in
kdelibs/kdoctools/customization/entities/contributor.entities.
But using this form does not generate the email in the html output without this patch
it is missing apparently since several years (around 2004)

REVIEW:101921
BUG:248576
(cherry picked from commit 9c48f7234c42c69909a4a12f013c72ffde77b1c9)

M  +1    -1    kdoctools/customization/kde-ttlpg.xsl
M  +1    -1    kdoctools/customization/kde-ttlpg-online.xsl

http://commits.kde.org/kdelibs/2534d85a86546fa210d32888f49defb95675a14e
Comment 6 Burkhard Lück 2011-08-03 15:00:56 UTC
Git commit 6fe439999f5c89e9d9cbb7dabc0b33b42b7c5c1e by Burkhard Lück.
Committed on 16/07/2011 at 14:01.
Pushed by lueck into branch 'master'.

Generate email for docbook authors

Preferred form for authors in kde docbooks is <author> &author.name;
author.name.mail; </author>, where the entifies are defined in
kdelibs/kdoctools/customization/entities/contributor.entities.
But using this form does not generate the email in the html output without this patch
it is missing apparently since several years (around 2004)

REVIEW:101921
CCBUG:248576

M  +1    -1    kdoctools/customization/kde-ttlpg.xsl
M  +1    -1    kdoctools/customization/kde-ttlpg-online.xsl

http://commits.kde.org/kdelibs/6fe439999f5c89e9d9cbb7dabc0b33b42b7c5c1e