Bug 248422 - Customizable kmix tray window/plasmoid: Show/Hide Playback streams sliders
Summary: Customizable kmix tray window/plasmoid: Show/Hide Playback streams sliders
Status: RESOLVED FIXED
Alias: None
Product: kmix
Classification: Unclassified
Component: KMix Panel Docking (show other bugs)
Version: 3.7
Platform: Gentoo Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Christian Esken
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-19 20:11 UTC by Fest
Modified: 2012-11-14 23:26 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 4.10


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fest 2010-08-19 20:11:09 UTC
Version:           3.7 (using KDE 4.5.0) 
OS:                Linux

I use pulse-audio in KDE. To change volume via kmix i need to:
1. Click on kmix icon in tray.
2. Click on mixer button under volume slider.
3. Click on playback streams in opened window.
4. Change volume.

So what i propose, is to make window opened in step 1 customizable. For example in my case to be able to put playback streams sliders there. 
IMHO it's much nicer to change volume in 2 steps instead of 4.

Reproducible: Always
Comment 1 Christian Esken 2010-08-20 17:27:16 UTC
This is already possible. Either by disabling the tray volume control window in the KMix config dialog, or by using the context menu on the tray.
Comment 2 Fest 2010-08-20 18:17:04 UTC
I mean something else. Not only to change "channel representing master volume" or to see the whole main window with all options. But to customize dock volume control.

For example to show "playback streams" and "capture devices" on tray icon click. To choose exactly what you want to see there.
Comment 3 Christian Esken 2010-08-21 00:12:24 UTC
Well, I thought your request was about "2 steps", which already works. But actually the title says "Customizable kmix plasmoid.". OK, so we can keep this open.

But all I can tell you for now is that I personally won't do it due to lack of time and interest. Probably someone else will step up, but I don't think so.
There is a SLIGHT chance that I will do something, if I would apply GUIProfile's also on the Popup window. But it requires the "virtual control" thing to be done before, so we are still able to place a virtual "Virtual::GlobalMaster" control there by default.
Comment 4 Fest 2010-08-21 05:23:40 UTC
Sorry for speaking thickly. The idea is customize plasmoid, to place controls what you personally use most. Reduce amount of steps is a benefit.
Cause non of 2 existing variant, not helping to put all needed controls together. Even without systray plasmoid - you need to switch tabs in main window. 
In my case, with pulse audio, i'd like to put all controls in one list: Main volume/aplications volume/devices. To change volume of anything in one click.
Comment 5 Christian Esken 2010-08-23 00:50:59 UTC
The latter request ("all controls in one list: Main volume/aplications volume/devices") is something that I will definitely not do.

Its not personal,  I just want to make it abundantly clear that the chances on that are less then non-existing. I simply don't want to make you take hopes on something that will never be there.

The reasons are various: Practical reasons (too much space needed), technical reasons, no interest.
Comment 6 Fest 2010-08-23 08:52:28 UTC
Sorry to hear that.
But to be sure - little awful sketch to determine what exactly i wish to customize to.
http://img28.imageshack.us/img28/8229/42885635.png

It's what i mean. Kmix plasmoid in tray with global volume slider at the top, applications volume at the bottom. Mute buttons at right side. And numbers on the left side is devices (in form of icons) where pulse is playing this stream. For example 1 - headphones, 2 -stereo, 3 -all outputs, with options to change stream destination.

IMHO it's not taking much space and should be pretty comfortable. All what you need from sound mixer in one plasmoid. 
And this is close to Ubuntu SoundMenu concept. Except of music player controls and with additional (hopefully some day in future) stream device controls at left.
Comment 7 Fest 2010-08-23 09:02:47 UTC
Right now kmix plasmoid is like shortcut to open kmix main window or show one mixer in tray "popup". It's not enough.
With this wish-request, and one i submitted in Bug 248423 (and added pulse stream output chooser), it's gonna be ideal sound control plasmoid. All you need in one place.
Comment 8 Christian Esken 2010-08-23 17:49:07 UTC
Oh, there is currrently no such thing as a kmix Plasmoid. I believe you can't have a Popup being a Plsamoid because Plasmoids live in a container like the plasma-desktop.

Oh, someone offered to do such a beast in bug 171287.
Comment 9 Christian Esken 2010-08-23 17:51:54 UTC
OK, I'll join this bug report with Bug 171287.

*** This bug has been marked as a duplicate of bug 171287 ***
Comment 10 Fest 2010-08-28 13:35:19 UTC
Sorry, but this wish-request isn't duplicate of Bug 171287. 
I'm not asking about turning kmix tray to plasmoid (sincerely, i didn't know it's not). And as user, i'm not sure i know the difference.
I'm asking about option to set what exactly will be there (in tray popup window shown on click).
To not mislead, i rename wish-request title.
Comment 11 Christian Esken 2012-11-10 15:41:54 UTC
This bug report title is not very specific. Also the description states only "For example [...] ". Thus I took the liberty to change the bug report title to the only hardcore fact noted down, namely "to be able to put playback streams sliders there".

This has been implemented for KDE4.10. See http://kmix5.wordpress.com/2012/10/17/what-you-set-is-what-you-get-sound-menu-setup/ and some other blog posts there reference it. Marking as fixed. If you see open issues, please open a new bug report.