Bug 248391 - Sometimes autocompletion changes letters (e.g. t->5)
Summary: Sometimes autocompletion changes letters (e.g. t->5)
Alias: None
Product: KDE PIM Mobile
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Maemo 5 Linux
: VHI major
Target Milestone: ---
Assignee: kdepim bugs
: 252903 (view as bug list)
Depends on:
Reported: 2010-08-19 15:46 UTC by Ludwig Reiter
Modified: 2010-12-02 15:24 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Note You need to log in before you can comment on or make changes to this bug.
Description Ludwig Reiter 2010-08-19 15:46:27 UTC
Version: e5 n900 4.5~20100813.1163254-1maemo1.1164259

In some textfiles I tried to enter a word and the autocompletion appeared, disappeared and the letter had changed. e.g. (t->5, or v->/)
This is a major letter entering problem.
Comment 1 Ludwig Reiter 2010-08-20 11:10:53 UTC
same happens at adding recipients to an event.
Comment 2 Bjoern Ricks 2010-09-15 15:23:25 UTC
confirmed with 4:4.5~20100910.1175286-1maemo5.1174786

can't insert a correct participant for invitations
Comment 3 Bjoern Ricks 2010-09-16 09:05:14 UTC
happens also in the create task dialog (e.g. in Title and Location fields)
Comment 4 Felix Wolfsteller 2010-09-17 19:08:38 UTC
Usually I find that it behaves as if the "modifier" key (blue arrow) was pressed. E.g. q->1 w->2 e->3 etc...

Also, I have the impression that this happens more often when typing fast.
Comment 5 Bernhard E. Reiter 2010-09-20 09:17:50 UTC
I also believe it is a speed and therefore a qt4 issue.
And it might go away, if we solve other speed problems.
Also there should be an umstream problem report with qt
as qt even under stress should not obstruct the typing input
like it does right now.

I agree that it is major, because is really obstructs a major use case.
I am adjusting setting priority to "high".
Comment 6 Bjoern Ricks 2010-09-20 10:31:43 UTC
This issue is already reported to Qt. For me it's a very high prio issue because it prevents me to create e.g. useful event names.
Comment 7 Bernhard E. Reiter 2010-09-20 17:36:51 UTC
Björn can you link the qt problem report for reference, please?

Just deleting and typing slower is a workaround that works for me,
given that this cannot be solved quickly, I do not believe it should be VHI.
Comment 8 Felix Wolfsteller 2010-09-30 08:09:09 UTC
Maybe we have two issues, because sometimes typing fast is a solution.

Seems as if you have 0.x seconds to type a new character, otherwise the last typed in one is modified as if you had pressed the modifier button.
Comment 9 Volker Krause 2010-10-01 08:58:15 UTC
*** Bug 252903 has been marked as a duplicate of this bug. ***
Comment 10 Volker Krause 2010-10-08 12:26:35 UTC
SVN commit 1183756 by vkrause:

Disable OpenGL rendering by default, it causes various bizare
side-effects on the N900.

BUG: 248391

 M  +1 -0      kdeclarativeapplication.cpp  
 M  +7 -1      kdeclarativefullscreenview.cpp  

WebSVN link: http://websvn.kde.org/?view=rev&revision=1183756
Comment 11 Ludwig Reiter 2010-12-02 15:24:14 UTC
version: 20101202-1202744-1maemo1

cannt reproduce anymore.