Bug 248320 - Custom icon for shelf plasmoid.
Summary: Custom icon for shelf plasmoid.
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-lancelot (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Ivan Čukić
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-19 04:16 UTC by Fest
Modified: 2010-10-22 10:47 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fest 2010-08-19 04:16:20 UTC
Version:           unspecified (using KDE 4.5.0) 
OS:                Linux

I'd like to ask about option to change icon for every shelf plasmoid.
For example i have 2 such plasmoids on my panel. One favorite applications and second with movie list (folder view). Problem that both plasmoids looks the same and choosing custom icons can help to separate them.

Reproducible: Didn't try
Comment 1 Tanja Schulte 2010-09-13 05:27:36 UTC
I'd also would like to change the panel icons of the shelf widget to my liking. They don't look the same here, they automatically adjust to the content (favorites shelf has star icon, office menu has office category icon). But I prefer to have icons that represent that they are menus, drawers, folders, shelves or whatever, so I prefer to choose the icon on my own.
Comment 2 Ivan Čukić 2010-09-13 09:10:37 UTC
This is on my TODO already. Since it is a feature request, it will have to wait until 4.6.
Comment 3 Ivan Čukić 2010-10-22 10:47:33 UTC
SVN commit 1188380 by ivan:

The shelf applet can again show on hover, and can have a custom icon

BUG:248319
BUG:248320



 M  +1 -6      LancelotPart.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1188380