Bug 248164 - K3b 2.0.1 exits when opening Settings -> Configure K3b
Summary: K3b 2.0.1 exits when opening Settings -> Configure K3b
Status: RESOLVED DUPLICATE of bug 238819
Alias: None
Product: k3b
Classification: Unclassified
Component: GUI/Usability (show other bugs)
Version: Git
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Michał Małek
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-17 17:49 UTC by Daniel Eklöf
Modified: 2011-01-03 13:16 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Eklöf 2010-08-17 17:49:06 UTC
Version:           2.0-SVN (using KDE 4.5.0) 
OS:                Linux

When opening the configuration dialog (Settings -> Configure K3b), k3b simply exits with the following message on the console:

k3b(7981)/kdeui (kdelibs): Attempt to use QAction "view_projects" with KXMLGUIFactory! 
k3b(7981)/kdeui (kdelibs): Attempt to use QAction "view_dir_tree" with KXMLGUIFactory! 
k3b(7981)/kdeui (kdelibs): Attempt to use QAction "view_contents" with KXMLGUIFactory! 
k3b(7981)/kdeui (kdelibs): Attempt to use QAction "location_bar" with KXMLGUIFactory! 
QMetaObject::invokeMethod: No such method K3b::Application::loadCommandLineOptionsForNewInstance()

This did not happen in 2.0.0.

Reproducible: Always
Comment 1 Daniel Eklöf 2010-08-17 17:55:36 UTC
Btw, this is with QT 4.7 beta 2 (but again, I have had no issues with k3b 2.0.0).

FYI, I also tried going back to 2.0.0 to see if there was any differences in the console output. It wasn't. So, the:

QMetaObject::invokeMethod: No such method
K3b::Application::loadCommandLineOptionsForNewInstance()

message that I thought may be related probably isn't.
Comment 2 Christoph Feck 2010-08-18 03:09:07 UTC

*** This bug has been marked as a duplicate of bug 238819 ***