Bug 248040 - Link handling option for finding new images
Summary: Link handling option for finding new images
Status: RESOLVED FIXED
Alias: None
Product: kphotoalbum
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KPhotoAlbum Bugs
URL:
Keywords: junior-jobs
Depends on:
Blocks:
 
Reported: 2010-08-16 11:03 UTC by Miika Turkia
Modified: 2012-02-02 05:56 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Miika Turkia 2010-08-16 11:03:24 UTC
Version:           unspecified
OS:                Linux

Currently symbolic links are treated the same as image files. However, an option should be added to KPA configuration to allow user to select if he wishes to skip symbolic links.

GUI change should be in General configuration under New Images (Settings/GeneralPage.cpp and the header file)
The actual new image finder code is NewImageFinder::searchForNewFile (DB/NewImageFinder.cpp) where the test for config option and isSymLink should be added.

The configuration should also be stored permanently on KPA configuration and selection should be loaded upon start-up. Default setting should be not to skip symlinks as this is the current behaviour.

Reproducible: Didn't try
Comment 1 Jan Kundrát 2010-09-03 15:45:50 UTC
Why would anyone want to skip symlinks? If there are present in the image directory, it's probably because there's a reason for that.
Comment 2 Miika Turkia 2010-09-03 21:26:50 UTC
This kind of a feature has been asked on KPA mailing list and IRC channel a few times. Thus it seems that there are a few people who prefer ignoring symlinks (at least one has been managing images with directory structure and done groupings with symlinks and in KPA this means many duplicate images in thumbnail view). I think this feature would allow some new users to adopt KPA more easily as it would allow them keeping the old directory based groupings.
Comment 3 Miika Turkia 2012-02-02 05:56:19 UTC
Git commit 451bb315ab3af6f57d386c40be97cd249d9ee68a by Miika Turkia.
Committed on 02/02/2012 at 06:55.
Pushed by mturkia into branch 'master'.

Option to skip symbolic links

Option to ignore symbolic links is added. Thanks to Rik for the patch.
Related: bug 223065

M  +5    -0    DB/NewImageFinder.cpp
M  +8    -0    Settings/FileVersionDetectionPage.cpp
M  +1    -0    Settings/FileVersionDetectionPage.h
M  +1    -0    Settings/SettingsData.cpp
M  +1    -0    Settings/SettingsData.h

http://commits.kde.org/kphotoalbum/451bb315ab3af6f57d386c40be97cd249d9ee68a