Bug 247829 - Akregator crash when idle in system tray
Summary: Akregator crash when idle in system tray
Status: RESOLVED DUPLICATE of bug 116482
Alias: None
Product: akregator
Classification: Applications
Component: general (show other bugs)
Version: 1.6.5
Platform: Debian testing Linux
: NOR crash
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-14 10:01 UTC by Nick Leverton
Modified: 2010-09-14 22:37 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Leverton 2010-08-14 10:01:34 UTC
Application: akregator (1.6.5)
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.6.3
Operating System: Linux 2.6.32-5-amd64 x86_64
Distribution: Debian GNU/Linux testing (squeeze)

-- Information about the crash:
First run of KDE4 after upgrade from KDE3.5.10.  Left Akregator idle in system tray overnight, in the morning it had crashed.

 -- Backtrace:
Application: Akregator (akregator), signal: Segmentation fault
The current source language is "auto; currently asm".
[KCrash Handler]
#5  __strlen_sse2 () at ../sysdeps/x86_64/multiarch/../strlen.S:31
#6  0x00007f1cf81c0d73 in c4_String (this=0x7fff7702db30, p=0x40 <Address 0x40 out of bounds>) at ../../../../akregator/plugins/mk4storage/metakit/src/string.cpp:129
#7  0x00007f1cf81c2737 in c4_Property (this=0x7fff7702db60, type_=<value optimized out>, name_=0x40 <Address 0x40 out of bounds>) at ../../../../akregator/plugins/mk4storage/metakit/src/view.cpp:1100
#8  0x00007f1cf81b65dc in c4_IntProp (prop_=..., seq_=...) at ../../../../akregator/plugins/mk4storage/metakit/include/mk4.inl:524
#9  f4_CreateFormat (prop_=..., seq_=...) at ../../../../akregator/plugins/mk4storage/metakit/src/format.cpp:1228
#10 0x00007f1cf81c550c in c4_Sequence::PropIndex (this=0x1f46520, prop_=...) at ../../../../akregator/plugins/mk4storage/metakit/src/viewx.cpp:292
#11 0x00007f1cf81c55d9 in c4_Sequence::Set (this=0x40, index_=953, prop_=..., buf_=...) at ../../../../akregator/plugins/mk4storage/metakit/src/viewx.cpp:325
#12 0x00007f1cf81be700 in c4_HashViewer::SetItem (this=0x1f46cb0, row_=953, col_=21, buf_=...) at ../../../../akregator/plugins/mk4storage/metakit/src/remap.cpp:366
#13 0x00007f1cf81c5b05 in c4_Sequence::SetAt (this=0x1f45920, index_=953, newElem_=...) at ../../../../akregator/plugins/mk4storage/metakit/src/viewx.cpp:104
#14 0x00007f1cf81c6d23 in c4_View::SetAt (this=0x1f45100, guid=<value optimized out>, status=0) at ../../../../akregator/plugins/mk4storage/metakit/include/mk4.inl:89
#15 Akregator::Backend::FeedStorageMK4Impl::setStatus (this=0x1f45100, guid=<value optimized out>, status=0) at ../../../../akregator/plugins/mk4storage/feedstoragemk4impl.cpp:396
#16 0x00007f1cf9c61981 in Akregator::Article::setStatus (this=0x1abc340, stat=0) at ../../../akregator/src/article.cpp:367
#17 0x00007f1cf9c6fa28 in Akregator::Feed::fetch (this=0x1f44990, followDiscovery=<value optimized out>) at ../../../akregator/src/feed.cpp:586
#18 0x00007f1cf9c8245b in Akregator::FetchQueue::fetchNextFeed (this=0x16171e0) at ../../../akregator/src/fetchqueue.cpp:91
#19 0x00007f1cf9c82640 in Akregator::FetchQueue::addFeed (this=0x16171e0, f=0x1f44990) at ../../../akregator/src/fetchqueue.cpp:78
#20 0x00007f1cf9c6fc25 in Akregator::Feed::slotAddToFetchQueue (this=0x1f44990, queue=0x16171e0, intervalFetchOnly=false) at ../../../akregator/src/feed.cpp:453
#21 0x00007f1cf9c79cba in Akregator::Folder::slotAddToFetchQueue (this=<value optimized out>, queue=0x16171e0, intervalFetchOnly=true) at ../../../akregator/src/folder.cpp:353
#22 0x00007f1cf9cd7946 in Akregator::MainWidget::qt_metacall (this=0x15acc30, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fff7702e040) at ./mainwidget.moc:197
#23 0x00007f1d0e74d346 in QMetaObject::activate (sender=0x1829100, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x40) at kernel/qobject.cpp:3295
#24 0x00007f1d0e749ba3 in QObject::event (this=0x1829100, e=0x7fff7702e790) at kernel/qobject.cpp:1212
#25 0x00007f1d0d85f32c in QApplicationPrivate::notify_helper (this=0x13c8030, receiver=0x1829100, e=0x7fff7702e790) at kernel/qapplication.cpp:4302
#26 0x00007f1d0d86580b in QApplication::notify (this=0x7fff7702ea90, receiver=0x1829100, e=0x7fff7702e790) at kernel/qapplication.cpp:4185
#27 0x00007f1d0f122836 in KApplication::notify (this=0x7fff7702ea90, receiver=0x1829100, event=0x7fff7702e790) at ../../kdeui/kernel/kapplication.cpp:302
#28 0x00007f1d0e73a15c in QCoreApplication::notifyInternal (this=0x7fff7702ea90, receiver=0x1829100, event=0x7fff7702e790) at kernel/qcoreapplication.cpp:726
#29 0x00007f1d0e766ed2 in QCoreApplication::sendEvent (this=0x13c4880) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#30 QTimerInfoList::activateTimers (this=0x13c4880) at kernel/qeventdispatcher_unix.cpp:603
#31 0x00007f1d0e763a48 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#32 idleTimerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#33 0x00007f1d0717a6c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#34 0x00007f1d0717e538 in ?? () from /lib/libglib-2.0.so.0
#35 0x00007f1d0717e6ec in g_main_context_iteration () from /lib/libglib-2.0.so.0
#36 0x00007f1d0e763713 in QEventDispatcherGlib::processEvents (this=0x1399630, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#37 0x00007f1d0d90f14e in QGuiEventDispatcherGlib::processEvents (this=0x40, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#38 0x00007f1d0e738a82 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#39 0x00007f1d0e738e5c in QEventLoop::exec (this=0x7fff7702ea30, flags=) at kernel/qeventloop.cpp:201
#40 0x00007f1d0e73daeb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#41 0x00000000004096dd in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../akregator/src/main.cpp:103

Reported using DrKonqi
Comment 1 Christophe Marin 2010-09-14 22:37:38 UTC

*** This bug has been marked as a duplicate of bug 116482 ***