Bug 247779 - Crash on scrolling after file deletion
Summary: Crash on scrolling after file deletion
Status: RESOLVED DUPLICATE of bug 237064
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: openSUSE Linux
: NOR crash
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-13 21:39 UTC by Martin
Modified: 2010-08-16 21:28 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin 2010-08-13 21:39:29 UTC
Application: dolphin (1.4)
KDE Platform Version: 4.4.4 (KDE 4.4.4) "release 2"
Qt Version: 4.6.3
Operating System: Linux 2.6.34-12-desktop x86_64
Distribution: "openSUSE 11.3 (x86_64)"

-- Information about the crash:
Expanded and closed a folder while in Details view mode.
Then deleted a selection of files
As the view was being re-built I scrolled down -> Crash

 -- Backtrace:
Application: Dolphin (dolphin), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f9fc7977760 (LWP 9321))]

Thread 3 (Thread 0x7f9fb61a9710 (LWP 9349)):
[KCrash Handler]
#5  0x00007f9fc3692bb0 in getenv () from /lib64/libc.so.6
#6  0x00007f9fc36eff66 in tzset_internal () from /lib64/libc.so.6
#7  0x00007f9fc36f0240 in tzset () from /lib64/libc.so.6
#8  0x00007f9fc49bdd2f in QTime::currentTime () at tools/qdatetime.cpp:1851
#9  0x00007f9fc49bde99 in QTime::start (this=0x7f9fb61a82d0) at tools/qdatetime.cpp:2021
#10 0x00007f9fc13973c5 in QAbstractSocket::waitForReadyRead (this=0x7f9fb004d070, msecs=600000) at socket/qabstractsocket.cpp:1823
#11 0x00007f9fc1ac85d3 in Soprano::Client::ClientConnection::iteratorNext (this=0x6bc920, id=1360781786) at /usr/src/debug/soprano-2.4.2/client/clientconnection.cpp:516
#12 0x00007f9fc1acc0bb in Soprano::Client::ClientQueryResultIteratorBackend::next (this=0x7f9fb004f150) at /usr/src/debug/soprano-2.4.2/client/clientqueryresultiteratorbackend.cpp:46
#13 0x00007f9fc670a18e in Soprano::Iterator<Soprano::BindingSet>::next (this=0x7f9fb61a84b0) at /usr/include/soprano/iterator.h:239
#14 0x00007f9fc66fc878 in Nepomuk::ResourceData::load (this=0x7f9fb0003c70) at /usr/src/debug/kdelibs-4.4.4/nepomuk/core/resourcedata.cpp:420
#15 0x00007f9fc66fd088 in Nepomuk::ResourceData::property (this=0x7f9fb0003c70, uri=...) at /usr/src/debug/kdelibs-4.4.4/nepomuk/core/resourcedata.cpp:271
#16 0x00007f9fc66fd122 in Nepomuk::Resource::property (this=<value optimized out>, uri=<value optimized out>) at /usr/src/debug/kdelibs-4.4.4/nepomuk/core/resource.cpp:280
#17 0x00007f9fc66ffc84 in Nepomuk::Resource::label (this=<value optimized out>) at /usr/src/debug/kdelibs-4.4.4/nepomuk/core/resource.cpp:782
#18 0x00007f9fc67003c0 in Nepomuk::Resource::genericLabel (this=0x7f9fb004d130) at /usr/src/debug/kdelibs-4.4.4/nepomuk/core/resource.cpp:358
#19 0x0000000000456a33 in _start ()

Thread 2 (Thread 0x7f9faadd3710 (LWP 9353)):
#0  0x00007f9fc08b7709 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f9fb4d03951 in metronom_sync_loop () from /usr/lib64/libxine.so.1
#2  0x00007f9fc08b2a4f in start_thread () from /lib64/libpthread.so.0
#3  0x00007f9fc372e82d in clone () from /lib64/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f9fc7977760 (LWP 9321)):
#0  0x00007f9fc373bafe in __lll_lock_wait_private () from /lib64/libc.so.6
#1  0x00007f9fc36f04a5 in _L_lock_2007 () from /lib64/libc.so.6
#2  0x00007f9fc36f02d7 in __tz_convert () from /lib64/libc.so.6
#3  0x00007f9fb4d1d19f in scratch_printf () from /usr/lib64/libxine.so.1
#4  0x00007f9fb4cff323 in xine_log () from /usr/lib64/libxine.so.1
#5  0x00007f9fb4d08eca in _register_plugins_internal () from /usr/lib64/libxine.so.1
#6  0x00007f9fb4f6211e in Phonon::Xine::XineEngineData::XineEngineData (this=0xdfc590) at /usr/src/debug/phonon-4.4.2/xine/xineengine.cpp:59
#7  0x00007f9fb4f62205 in Phonon::Xine::XineEngine::create (this=0xd97b08) at /usr/src/debug/phonon-4.4.2/xine/xineengine.cpp:83
#8  0x00007f9fb4f77872 in Phonon::Xine::Backend::Backend (this=0xd97ac0, parent=<value optimized out>) at /usr/src/debug/phonon-4.4.2/xine/backend.cpp:80
#9  0x00007f9fb4f77e2b in qt_plugin_instance () at /usr/src/debug/phonon-4.4.2/xine/backend.cpp:51
#10 0x00007f9fb579f6c2 in ?? () from /usr/lib64/kde4/plugins/phonon_platform/kde.so
#11 0x00007f9fb57a043b in ?? () from /usr/lib64/kde4/plugins/phonon_platform/kde.so
#12 0x00007f9fc696d036 in Phonon::FactoryPrivate::createBackend (this=0xa9dc60) at /usr/src/debug/phonon-4.4.2/phonon/factory.cpp:119
#13 0x00007f9fc696d76f in Phonon::Factory::backend (createWhenNull=<value optimized out>) at /usr/src/debug/phonon-4.4.2/phonon/factory.cpp:438
#14 0x00007f9fc6967919 in Phonon::BackendCapabilities::isMimeTypeAvailable (mimeType=...) at /usr/src/debug/phonon-4.4.2/phonon/backendcapabilities.cpp:66
#15 0x0000000000439d9f in _start ()

This bug may be a duplicate of or related to bug 237064.

Possible duplicates by query: bug 241922, bug 241917, bug 241916, bug 241912, bug 240623.

Reported using DrKonqi
Comment 1 Peter Penz 2010-08-16 21:28:37 UTC

*** This bug has been marked as a duplicate of bug 237064 ***