Bug 247656 - Full-screen game flickering when notification (Plasma, Amarok, ...) is shown
Summary: Full-screen game flickering when notification (Plasma, Amarok, ...) is shown
Status: RESOLVED DUPLICATE of bug 177495
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-13 16:03 UTC by Ralf Jung
Modified: 2010-08-13 21:59 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ralf Jung 2010-08-13 16:03:36 UTC
Version:           unspecified (using KDE 4.4.2) 
OS:                Linux

When I'm running a full-screen game in wine and some application running in background shows a notification (for example the Plasma Desktop, or the Amarok OSD), the game flickers for a short time, and I can see the desktop. This is of course heavily disrupting the gameflow, especially when quick reaction is required.

Reproducible: Always




It does not matter whether composite is enabled or disabled, the problem stays the same.
Comment 1 Martin Flöser 2010-08-13 17:39:47 UTC

*** This bug has been marked as a duplicate of bug 177495 ***
Comment 2 Ralf Jung 2010-08-13 18:54:56 UTC
If I read that other bug correctly, it is about compositing - however, as I wrote above, the issue I described happens both with composite off an on. Are you sure this is a duplicate?
Comment 3 Martin Flöser 2010-08-13 19:10:02 UTC
> If I read that other bug correctly, it is about compositing - however, as I
> wrote above, the issue I described happens both with composite off an on.
> Are you sure this is a duplicate?
yes and no. For the composited case it's the duplicate (same pattern and I 
must admit that I did not read through the whole report due to the fact that 
it is a common issue). For the non-composited case it cannot be a kwin bug, 
but has to be driver/Xorg as in that case those are responsible for it. So in 
summary the duplicate is correct.
Comment 4 Thomas Lübking 2010-08-13 19:33:31 UTC
(In reply to comment #3)
> > If I read that other bug correctly, it is about compositing - however, as I
> For the non-composited case it cannot be a kwin bug,
maybe - kwin's showing of popups etc. above active FS windows, hits the NETWM stacking recommendation (which may or may not make sense)

However if not compositing i just get popups (native amarok osd) over wine FS windows (tried jedi outcast), but i do not see the desktop

@ralf:
please check whether this is exclusive to plasma popups by unchecking "use system notifications" in amaroks osd settings
Comment 5 Ralf Jung 2010-08-13 19:46:29 UTC
Definitely not exclusive, I do use the native Amarok OSD and it triggers the same issue.
The game I noticed this in is Trackmania United Forever (there's a free version, too, called Nations Forever, with the same engine and probably the same issue).

My laptop has an AMD Radeon 3200 HD and I am using the binary drivers as shipped with Kubuntu 10.04.
Comment 6 Thomas Lübking 2010-08-13 21:22:55 UTC
Ok, the non composited case is in your driver or wine version (but rather driver) then.
Tried TMNF and there's no such incident with the nvidia css driver.

Does any of the free drivers (radeon/hd) provide HW GL acceleration for you?
Comment 7 Ralf Jung 2010-08-13 21:59:31 UTC
Oh, that's bad news, but thanks for testing! Wine version is 1.3 here.
The behaviour looks the same for composited and non-composited - weird that it's caused by fundamentally different issues, as it seems.

> Does any of the free drivers (radeon/hd) provide HW GL acceleration for you?
Unfortunately, not - at least not those shipped with Ubuntu. The game only starts with the proprietary one.