Bug 247410 - Always blurred display with OpenStreetMap
Summary: Always blurred display with OpenStreetMap
Status: RESOLVED DUPLICATE of bug 199259
Alias: None
Product: marble
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR wishlist (vote)
Target Milestone: 0.8 (KDE 4.3)
Assignee: marble-bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-11 19:56 UTC by Alexey Charkov
Modified: 2013-10-20 08:02 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot illustrating the problem (918.86 KB, image/png)
2010-08-11 19:56 UTC, Alexey Charkov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Charkov 2010-08-11 19:56:10 UTC
Created attachment 50024 [details]
Screenshot illustrating the problem

Version:           unspecified (using KDE 4.5.0) 
OS:                Linux

Even when using the Mercator projection for OpenStreetMap (which should not result in any geometric transformation of tiles), Marble displays a blurred map as if the tiles were geometrically transformed or resampled due to zoom level mismatches. An attached screenshot demonstrates the web-based Mapnik rendering side-by-side with Marble's rendering at a comparable zoom level.

Reproducible: Always

Steps to Reproduce:
Select Openstreetmap display with Mercator projection in Marble, compare the rendering to a similar zoom/area rendered by Mapnik at openstreetmap.org

Actual Results:  
Marble's rendering is consistently more blurred than the original Mapnik tiles.

Expected Results:  
Marble should try its best to display raster tiles pixel-exactly where possible (maybe by snapping to the optimal zoom levels).

OS: Linux (x86_64) release 2.6.35-gentoo-alchark-u3s
Compiler: x86_64-pc-linux-gnu-gcc
Comment 1 Dennis Nienhüser 2010-08-11 23:08:04 UTC
Yes, I totally agree. We're still looking for volunteers to improve the situation :-)

*** This bug has been marked as a duplicate of bug 199259 ***