Bug 247316 - Plasma themes to include placeholders
Summary: Plasma themes to include placeholders
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: compositing (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR wishlist with 1 vote (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 263889 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-08-11 01:57 UTC by KDE Brainstorm Submissions
Modified: 2011-04-28 13:44 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.7.0


Attachments
Highlight Window Mockup (62.19 KB, image/png)
2010-08-11 01:57 UTC, KDE Brainstorm Submissions
Details
Window Snap Mockup (34.67 KB, image/png)
2010-08-11 01:58 UTC, KDE Brainstorm Submissions
Details
Window Resizing Mockup (29.47 KB, image/png)
2010-08-11 01:59 UTC, KDE Brainstorm Submissions
Details

Note You need to log in before you can comment on or make changes to this bug.
Description KDE Brainstorm Submissions 2010-08-11 01:57:36 UTC
Created attachment 49987 [details]
Highlight Window Mockup

Version:           unspecified (using Devel) 
OS:                Linux

Many features of Kwin, such as "Highlight Window", "Window Snapping" and when resizing (without showing content) currently use several methods to show where windows are, or where they could be.

This proposition is to create a mostly transparent "placeholder" defined by plasma themes that can show where windows are, where they could be, or how large they might become in a unified, elegant manner. Plasma themes without a specific "placeholder" graphic might fall back to a regular plasmoid container.

Please see the attachments for mockups.


This feature request was originally submitted through KDE Brainstorm, and has been submitted to Bugzilla due to popular demand. Original idea: http://forum.kde.org/brainstorm.php?mode=idea&i=84605

Reproducible: Didn't try
Comment 1 KDE Brainstorm Submissions 2010-08-11 01:58:49 UTC
Created attachment 49988 [details]
Window Snap Mockup
Comment 2 KDE Brainstorm Submissions 2010-08-11 01:59:11 UTC
Created attachment 49989 [details]
Window Resizing Mockup
Comment 3 Martin Flöser 2011-01-21 17:26:57 UTC
*** Bug 263889 has been marked as a duplicate of this bug. ***
Comment 4 Martin Flöser 2011-04-28 13:44:07 UTC
Used the wrong email address for push, so the commit hook did not add it:


Git commit f90b88bb1a494a2f5dcc70dc4f43e9f762358d0d by Martin Gräßlin.
Committed on 28/04/2011 at 13:47.
Pushed by graesslin into branch 'master'.

Outline effect to replace rendering of the outline

It just uses the selection of the EffectFrame for the outline.
FEATURE: 247316
FIXED-IN: 4.7.0

M  +1    -0    kwin/effects/CMakeLists.txt     
A  +12   -0    kwin/effects/outline/CMakeLists.txt         [License: UNKNOWN]  *
A  +78   -0    kwin/effects/outline/outline.cpp         [License: GPL (v2)]
A  +17   -0    kwin/effects/outline/outline.desktop         [License: UNKNOWN]  *
A  +51   -0    kwin/effects/outline/outline.h         [License: GPL (v2)]

The files marked with a * at the end have a non valid license. Please read: http://techbase.kde.org/Policies/Licensing_Policy and use the headers which are listed at that page.


http://commits.kde.org/kde-workspace/f90b88bb1a494a2f5dcc70dc4f43e9f762358d0d