Bug 246102 - The "Additional Information" and "Panel" submenus under View are empty
Summary: The "Additional Information" and "Panel" submenus under View are empty
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Mandriva RPMs Linux
: NOR normal
Target Milestone: ---
Assignee: Peter Penz
: 248727 251555 (view as bug list)
Depends on:
Reported: 2010-07-29 02:02 UTC by JR
Modified: 2011-12-18 13:35 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.8.0

Screencast showing the empty submenus (194.09 KB, video/ogg)
2010-07-29 02:02 UTC, JR
my old dolphinuirc (5.48 KB, application/x-trash)
2010-08-17 11:27 UTC, p92

Note You need to log in before you can comment on or make changes to this bug.
Description JR 2010-07-29 02:02:41 UTC
Created attachment 49605 [details]
Screencast showing the empty submenus

Version:           unspecified (using KDE 4.4.92) 
OS:                Linux

Kubuntu lucid running KDE 4.5rc2. Dolphin package version 4:4.4.92-0ubuntu1~lucid1~ppa2.

I accidentally closed the Places panel, and when I tried to enable it again the menu seems to malfunction.

Reproducible: Always

Steps to Reproduce:
1. In Dolphin, open the View menu
2. Move mouse down to the "Additional Information" or "Panel" submenu entries

Actual Results:  
3. Submenus are empty, a small ~5x5 pixel box is displayed where its upper left corner should be.

Expected Results:  
3. Submenu contents, allowing me to toggle which panels should be displayed, etc.

I've tried deleting dolphinrc which restored my Places panel, but the submenus remain empty. I have not tried it on another user login yet.

See attachment for a quick videoclip. At that quality you can't see the little box that appears instead of the menus, but it's there.
Comment 1 Anselmo L. S. Melo (anselmolsm) 2010-08-01 16:51:37 UTC
Can't reproduce here, running:

KDE 4.5.62 (KDE 4.6 >= 20100729) - compiled from svn trunk r1157874
openSUSE 11.3
Comment 2 FiNeX 2010-08-01 22:11:20 UTC
Could this bug be related to bug #235896 ?
Comment 3 Jaime Torres 2010-08-02 12:46:44 UTC
I've seen something similar with other programs that use plug-ins (digikam in my case) when there is an automatic update and the main program is still opened.
Could this be your case?
Comment 4 JR 2010-08-02 16:11:31 UTC
(In reply to comment #3)

I'm not sure I completely follow, but the bug persists after a complete reboot, and reinstallation of the dolphin package (for the sake of posterity).

I tried creating a new user, and when logged in as it I don't get the bug. Without looking at the code, what user-specific ~/.kde/share/config/* settings can alter the contents of those two submenus?

Even after enabling debug output for Dolphin in kdebugdialog, nothing of particular interest is output to the terminal.

Is there anything else I can do to troubleshoot?
Comment 5 Jaime Torres 2010-08-02 18:47:19 UTC
The path I follow when very strange things happen (then I fill a bug report):
without using any KDE program for that user, (for example, with a su - user), I do:
mv /tmp/kde-<user> /tmp/kde-<user>.old
mv /tmp/ksocket-<user> /tmp/ksocket-<user>.old
mv /var/tmp/kdecache-<user> /var/tmp/kdecache-<user>.old
(They should be recreated from scratch)

If this does not fixes the problem, another slow way:
I try to run the program under valgrind (in this case: valgrind dolphin --nofork) and see if the program keeps doing strange things. dolphin will run very slow and will use twice or more memory.
Comment 6 p92 2010-08-17 11:22:03 UTC

I had the same problem which I investigated a little and solved it by removing .kde/share/apps/dolphin/dolphinui.rc

I don't know when this file is created, because after running dolphin without it and having so recovered the view->panels submenus, I closed dolphin and this dolphinui.rc file was not recreated.
Comment 7 p92 2010-08-17 11:27:14 UTC
Created attachment 50647 [details]
my old dolphinuirc

My current level is kubuntu lucid with kde 4.5.0 from kubuntu backport ppa
Comment 8 Janet 2010-09-15 21:41:06 UTC
I can confirm this on sidux/aptosid/Debian Sid & Kubuntu with KDE 4.5.1, blank submenus Additional Information & Panels in Dolphin's View menu.

It can be solved by removing dolphinui.rc as proposed (dolphinui.rc gets recreated when you modify e.g. the toolbar of dolphin).

Now I have the submenus back but part of the View menu is now in English, not in German anymore. As soon as I copy the backupped dolphinui.rc back into place the View menu is German again but the mentioned submenus are blank again too.
The following menu entries of the View menu turn to English: View Mode, Sort By, Additional Information and Panels. Most of the content of the Sort By submenu also turns to English as does the Additional Information submenu.
Comment 9 Szczepan Hołyszewski 2010-09-22 15:29:10 UTC
I had yet another combination of symptoms: the menu entries mentioned by Janet are in English, AND the Places and Additional information submenus are empty.

Both symptoms are fixed by removing dolphinui.rc.
Comment 10 Frank Reininghaus 2010-09-26 00:25:26 UTC
*** Bug 251555 has been marked as a duplicate of this bug. ***
Comment 11 Marcus Gama 2010-10-17 13:55:11 UTC
I tried all proposed solutions above with no success (remove .kde/share/apps/dolphin/dolphinui.rc and delete or move the tmp folders). My system is a Mandriva 2010.1 with KDE 4.5.2. At my computer, the menu entries mentioned by   Szczepan are in English (Panels and Additional information) AND Sort by. Very strange.
Comment 12 Michał D. (Emdek) 2010-10-17 14:13:27 UTC
(In reply to comment #11)
> I tried all proposed solutions above with no success

Exactly the same issue on Mandriva 2011 (cooker), on KDE trunk (4.5.71).
Additionally new user account with default settings has the same problem.
Comment 13 Anselmo L. S. Melo (anselmolsm) 2010-10-17 15:17:29 UTC
This bug is curious... It looks like a missing plugin as mentioned in #3, but it is not a plugin. In #2 I said I could not reproduce. I've just built my whole KDE from today's trunk and menus are ok. I also created a new user to test with a fresh config file, everything ok.

@Emdek, you said you're running KDE trunk 4.5.71. Is it packaged or do you build it from sources? Even though, it doesn't make much sense, I don't see where a packaging issue would cause this bug...

openSUSE 11.3
KDE built from trunk sources - r1186611 (4.5.72 - 4.6 >= 20101012)
Qt 4.7.0 (openSUSE packages)
Comment 14 Michał D. (Emdek) 2010-10-17 15:22:39 UTC
(In reply to comment #13)
> @Emdek, you said you're running KDE trunk 4.5.71. Is it packaged or do you
> build it from sources?

It's from packages. These were updated at least one time since I've found this bug but each time it behaves the same.
As far as I remember it worked fine with packages for 4.5.0 (soon after it's release Mandriva cooker switched to trunk again).
Comment 15 Peter Paulsen 2010-10-25 03:13:31 UTC
I only have this problem with an existing user when I updated an existing dolphin. This does not happen on a fresh install or with a fresh "dolphin-unknowing" user.

Here in the old dolphinui.rc was a part that described the missing menus, in german. Deleting that part brought the menus back for the new dolphin version.

IMHO dolphin should have been aware on first start after the update that it's dolphinui.rc is out-of-date and should have adjusted it. I have seen similar on e.g. kjots, which got new additional toolbars in some version but I only realized it when I saw a fresh install some months later. It was not possible to activate the new toolbars in the updated application because kjots didn't adjust it's ui configuration file in the user's home. So this maybe is a more general problem.
Comment 16 Peter Penz 2011-01-30 20:41:27 UTC
*** Bug 248727 has been marked as a duplicate of this bug. ***
Comment 17 p92 2011-01-31 11:08:54 UTC
still true in kde sc 4.6.0 ?
Comment 18 Michał D. (Emdek) 2011-12-04 09:26:58 UTC
Seems to finally work. :-)
Kubuntu 11.10 32 bit, KDE 4.7.2.