Bug 245664 - ~/.fonts.conf creates every time I try to change fonts settings and systemsettings can't work without access to this file.
Summary: ~/.fonts.conf creates every time I try to change fonts settings and systemset...
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Unclassified
Component: kcm_fonts (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR major with 105 votes (vote)
Target Milestone: ---
Assignee: rik
URL:
Keywords:
: 298474 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-07-24 18:05 UTC by Anton S. Lobashev
Modified: 2015-10-15 16:39 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Anton S. Lobashev 2010-07-24 18:05:51 UTC
Version:           unspecified (using KDE 4.4.5) 
OS:                Linux

All my fonts configuration like AA, hinting, etc. are stored in /etc/fonts/, there is no .fonts.conf file in my home directory and «System Settings» is used as parameter of «Use anti-aliasing» but when I want to change only my fonts (not even AA parameters) with systemsettings, it creates this file with settings different with system's.

If i set 000 access to .fonts.conf to avoid writing wrong configuration and open «Appearence», systemsettings thinks long and then crashes without any message.

Reproducible: Always



Expected Results:  
systemsettings should really use system configuration, not its own.

This bug also reproducable at Debian unstable with KDE 4.4.5.
Comment 1 a.chidlow 2010-08-01 08:19:55 UTC
I can confirm this is happening for me as well, on Arch Linux running KDE 4.4.
Simply going into System Settings -> Appearance overwrites ~/.fonts.conf, even if I don't change anything at all.
Additionally, if ~/.fonts.conf is owned by root, with permissions set to 444, it gets replaced by one owned by me.
Comment 2 crafty.ua 2010-11-02 14:41:16 UTC
Still happening on Gentoo with KDE 4.5.2
Comment 3 Alexander Slonovsky 2010-11-02 16:00:43 UTC
*** This bug has been confirmed by popular vote. ***
Comment 4 Daniel Eklöf 2011-10-02 11:35:28 UTC
FYI, there's a patch posted in bug 105797 that fixes the issue for me.
Comment 5 Christoph Feck 2012-04-20 10:45:44 UTC
*** Bug 298474 has been marked as a duplicate of this bug. ***
Comment 6 Albert Astals Cid 2015-09-26 10:48:19 UTC
This doesn't seem to be happening to me using Plasma 5, could you try to reproduce it there?
Comment 7 Anton S. Lobashev 2015-09-26 16:45:47 UTC
Not reproducible here as well. Closing as fixed.