Bug 245538 - bluetooth kio don't work when it's started without a bt device
Summary: bluetooth kio don't work when it's started without a bt device
Status: RESOLVED FIXED
Alias: None
Product: solid
Classification: Unclassified
Component: bluetooth-kio-bt (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Alex Fiestas
URL:
Keywords:
: 263754 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-07-23 14:04 UTC by Vitor Boschi da Silva
Modified: 2011-07-17 01:29 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vitor Boschi da Silva 2010-07-23 14:04:41 UTC
Version:           unspecified (using Devel) 
OS:                Linux

If you open the address bluetooth:// in dolphin without the bluetooth device attached, it displays an empty folder as expected, but if you then attaches the device (without closing dolphin) and try to refresh the view, it still doesn't search for devices.
If you do the oposite (open bluetooth:// with the device attached, then remove it and tries to refresh), the kio dies and the message "The process for the bluetooth protocol died unexpectedly", while it will be friendlier if it displayed something in the lines of "No bluetooth device found".
I guess the kio is only checking for the presence of the adapter on start.

Reproducible: Always
Comment 1 Alex Fiestas 2011-01-20 15:06:32 UTC
*** Bug 263754 has been marked as a duplicate of this bug. ***
Comment 2 Alex Fiestas 2011-07-17 01:29:24 UTC
This has been finally fixed in:
525d8c36061e5ded80605e075158fa075e2b0737

To be released in BlueDevil 1.2

Thanks for the bug!