Bug 245533 - Error in WhatsThisHelp of Tag Guesser Configuration dialog (no button called Suggest in the gui)
Summary: Error in WhatsThisHelp of Tag Guesser Configuration dialog (no button called ...
Status: RESOLVED FIXED
Alias: None
Product: juk
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Scott Wheeler
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-23 13:23 UTC by Burkhard Lück
Modified: 2011-08-21 20:12 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.7.1


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Burkhard Lück 2010-07-23 13:23:45 UTC
Version:           unspecified (using Devel) 
OS:                Linux

Tag Guesser Configuration dialog has this WhatsThisHelp:

#. i18n: file: tagguesserconfigdlgwidget.ui:29
#. i18n: ectx: property (whatsThis), widget (QTreeView, lvSchemes)
#: rc.cpp:204
#, no-c-format
msgid ""
"Here you can see the currently configured file name schemes which the "
"\"Suggest\" button in the tag editor uses to extract tag information from a "
"file name. Each string may contain one of the following placeholders:<ul>\n"

But the catalog does not habe a string "Suggest" and there is not button with this string in the gui.

Bug is in recent trunk + 4.5 compiled from sources

Reproducible: Always
Comment 1 Raphael Kubo da Costa 2011-06-17 00:12:11 UTC
This seems to have been the case since 2003...

r214220 added the "Suggest" button, r216312 removed it from the code. Right now, I'd replace "Suggest button" with "Guess Tag Information from File Name menu option" (or something like that) in the text.

Burkhard, can we still do that in time for 4.7 or should we wait for the string freeze to be lifted and aim at 4.8?
Comment 2 Burkhard Lück 2011-06-17 12:01:12 UTC
(In reply to comment #1)
> 
> Burkhard, can we still do that in time for 4.7 or should we wait for the
> string freeze to be lifted and aim at 4.8?

Please wait until 4.7.0 is out (we have to take care for the small translation teams fighting hard to meet the translation release critera to get included), then commit to master, ask for approval on kde-i18n-doc@kde.org (no doubt you'll get it) and backport for 4.7.1.

Thanks for taking care of this
Comment 3 Jan Gerrit Marker 2011-08-10 10:29:04 UTC
SVN commit 1246190 by jangmarker:

Correct WhatsThisToolip's text of the guesser configuration
dialog to reflect the UI.

CCBUG: 245533

 M  +1 -1      tagguesserconfigdlgwidget.ui  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1246190
Comment 4 Raphael Kubo da Costa 2011-08-10 11:05:28 UTC
Jan,

Please don't forget to commit this to the 4.7 branch as well and mail the i18n team as described.
Comment 5 Jan Gerrit Marker 2011-08-10 15:33:29 UTC
Okay, I sent an e-mail to the mailinglist and asked for approval. If I get it I'll commit the patch and close this bug report.

Thanks for pointing it out.
Comment 6 Burkhard Lück 2011-08-19 06:10:00 UTC
bug is fixed in trunk+4.7, but still not resolved.
Any reason or just an oversight?
Comment 7 Jan Gerrit Marker 2011-08-21 18:55:38 UTC
I didn't fix it in the 4.7 branch and I don't see a commit which fixes it.

I'd commit the fix to the 4.7 branch but the only answer I got from the i18n mailing list is from the German team.
Comment 8 Burkhard Lück 2011-08-21 19:10:11 UTC
You overlooked the OK from DA + HU see http://lists.kde.org/?l=kde-i18n-doc&m=131299019010001&w=2 and you did not get a NO.

So you are allowed to break the string freeze, please commit asap.

Thanks
Comment 9 Jan Gerrit Marker 2011-08-21 20:09:10 UTC
SVN commit 1248724 by jangmarker:

Backporting commit r1246190.

Correct WhatsThisToolTip's text of the guesser configuration
dialog to reflect the UI.

BUG: 245533
Fixed-In: 4.7.1


 M  +1 -1      tagguesserconfigdlgwidget.ui  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1248724
Comment 10 Jan Gerrit Marker 2011-08-21 20:12:40 UTC
Thank you, Burkhard for pushing me. The fix is in the 4.7 branch.

Sorry that I overlooked the emails, sometimes my spamfilter filters them.