Bug 245198 - KDE does not know how to shut down or switch user when gdm3 is managing displays
Summary: KDE does not know how to shut down or switch user when gdm3 is managing displays
Status: RESOLVED DUPLICATE of bug 186198
Alias: None
Product: ksmserver
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Lubos Lunak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-20 05:24 UTC by Frode Hatlevik
Modified: 2010-10-05 23:14 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Frode Hatlevik 2010-07-20 05:24:31 UTC
Version:           unspecified (using KDE 4.4.4) 
OS:                Linux

I have gdm3 managing displays on my Debian testing (i386) system.

If kscreensaver has locked the screen there is no option to switch user.

The "Switch user" option on the K menu only locks my display, and does not start a new session with a gdm3 greeter.

There is no option to turn off or reboot from the K menu.

All of theese are functional when kdm manages displays for me.

There appears to be a patch for this in Fedora. A bug repport in Debian BTS refers to this patch. I am reporting upstream.

Please see Debian bug #581841 for a reference.
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=581841

Regards
;)Frode

Reproducible: Always

Steps to Reproduce:
Let gdm3 manage displays. Try to switch user form K menu, lock screen with kscreeensaver and switch user, shut down system or reboot from K menu.

Actual Results:  
Unable to start new gdm3 greeter, shut down or reboot.

Expected Results:  
Should integrate into gdm3 the same way as it does with kdm.
Comment 1 Fathi Boudra 2010-07-22 08:02:23 UTC
ossi, could you take a look to the Fedora patch (see Debian bug report) ?
Comment 2 Oswald Buddenhagen 2010-08-01 00:03:04 UTC

*** This bug has been marked as a duplicate of bug 186198 ***
Comment 3 Frode Hatlevik 2010-08-01 10:50:54 UTC
This bug is not a duplicate of bug #186198
https://bugs.kde.org/show_bug.cgi?id=186198

My bug report is against gdm3 integration. Bug #186198 is against gdm2 integration.

gdm2 integrates nicely with KDE 4 on my Debian Squeeze/Sid. gdm3 does not.

There exists a patch towards KDE for Debian.
http://bugs.debian.org/cgi-bin/bugreport.cgi?msg=12;filename=0001-Use-ConsoleKit-fur-shutdown-with-gdm3.patch;att=1;bug=581841

Please, can you examine further?

Regards
;)Frode
Comment 4 Oswald Buddenhagen 2010-08-01 15:58:29 UTC
the numerical suffix in the debian package name is only there to have two separate packages for the interface-incompatible gdm versions (both configuration and remote control). the gdm3 package version is 2.30, as opposed to 2.20 for the old gdm package - which is exactly in line with what i have written in the other report. i suggest you do some slightly more thorough research before revising a maintainer's action next time.

*** This bug has been marked as a duplicate of bug 186198 ***
Comment 5 Frode Hatlevik 2010-08-02 13:49:09 UTC
I am sorry that I did not do my homework. Please forgive me.

Regards
;)Frode
Comment 6 Andrew Manson 2010-10-05 23:00:50 UTC
This bug is marked as resolved, I assume also because it has been marked as a duplicate. This is not a duplicate of bug #186198 as that bug has been specifically reported against solaris. I experience this bug (exactly as it is described here) on Ubuntu 10.04. 

Also. Can I do anything to help move this bug along? (I am a developer)
Comment 7 Oswald Buddenhagen 2010-10-05 23:14:34 UTC
(In reply to comment #6)
> Also. Can I do anything to help move this bug along? (I am a developer)
>
once you accept that this *is* a duplicate, you can start following the instructions from one of the other duplicates.