Bug 244977 - freecell solver incorrectly marks winnability
Summary: freecell solver incorrectly marks winnability
Status: RESOLVED DUPLICATE of bug 230354
Alias: None
Product: kpat
Classification: Applications
Component: solver (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Stephan Kulow
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-17 20:11 UTC by Dan Keshet
Modified: 2010-07-17 20:18 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
save game of messed up freecell game (2.94 KB, application/octet-stream)
2010-07-17 20:11 UTC, Dan Keshet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Keshet 2010-07-17 20:11:37 UTC
Created attachment 49266 [details]
save game of messed up freecell game

Version:           unspecified (using KDE 4.4.3) 
OS:                Linux

Solver says game unwinnable, make a move then it says its winnable.

Reproducible: Always

Steps to Reproduce:
Move the stack on the far right (in the example file) to the stack on the far left.

Actual Results:  
solver remains in the same state.

Expected Results:  
Solver now says the game is winnable.
Comment 1 Parker Coates 2010-07-17 20:18:26 UTC
Thanks for the report and for including a saved game. It seems very likely that this is the same issue as described in bug 230354, so I'm going to mark it as a duplicate.

*** This bug has been marked as a duplicate of bug 230354 ***