Bug 244967 - Cookies support on rss plugin
Summary: Cookies support on rss plugin
Status: RESOLVED FIXED
Alias: None
Product: ktorrent
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: openSUSE RPMs Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Joris Guisson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-17 18:26 UTC by Cherkasov Anton
Modified: 2011-04-08 16:56 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cherkasov Anton 2010-07-17 18:26:43 UTC
Version:           unspecified (using Devel) 
OS:                Linux

Now rss plugin support URL of feeds like www.example.org/rss/feed.xml
But some trackers require to add cookies information to URL for user authentication.
For example: www.example.org/rss/feed.xml:COOKIE:uid=xxxx;pass=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
This URL is correct in mTorrent, but incorrect in KTorrent.

Reproducible: Always




My OS: openSUSE 11.3, KDE version 4.4.5, KTorrent version 4.0.2
Comment 1 Joris Guisson 2010-07-18 19:02:32 UTC
Do you know of any sites I could test this with ?
Comment 2 Cherkasov Anton 2010-07-18 19:24:25 UTC
Of course.
For example http://lostfilm.TV http://novafilm.tv
Comment 3 Cherkasov Anton 2010-07-18 19:33:25 UTC
RSS: http://lostfilm.tv/rssdd.xml  http://novafilm.tv/rss/rssd.xml
But you must be a registered user for downloading. Registration is free.
Comment 4 Joris Guisson 2010-07-18 19:39:44 UTC
My knowledge of Russian is non existent, so English sites would be better.
Comment 5 Joris Guisson 2010-07-19 13:06:39 UTC
SVN commit 1151691 by guisson:

Add support for cookies in syndication plugin 

BUG: 244967

 M  +1 -0      ChangeLog  
 M  +29 -4     plugins/syndication/feed.cpp  
 M  +10 -2     plugins/syndication/feed.h  
 M  +1 -1      plugins/syndication/feedlist.cpp  
 M  +27 -4     plugins/syndication/feedretriever.cpp  
 M  +11 -1     plugins/syndication/feedretriever.h  
 M  +21 -0     plugins/syndication/feedwidget.cpp  
 M  +1 -0      plugins/syndication/feedwidget.h  
 M  +12 -5     plugins/syndication/feedwidget.ui  
 M  +15 -3     plugins/syndication/syndicationactivity.cpp  
 M  +1 -1      plugins/syndication/syndicationactivity.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1151691
Comment 6 Yura 2011-03-30 13:30:36 UTC
Ktorrent 4.1. This don't work for me on lostfilm.tv. I use url http://www.lostfilm.tv/rssdd.xml:COOKIE:uid=xxxxxxx;pass=xxxxxxxxxxxxxxxxxxxxxxxxxx;usess=xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
Сould it because of what has become lostfilm use the usess?
Comment 7 Joris Guisson 2011-03-30 20:01:09 UTC
I checked with wireshark, the cookie is sent. Everything after :COOKIE: is sent as cookie to in the http request.

Maybe you made a typo in the cookie itself ?
Comment 8 Yura 2011-04-02 05:19:39 UTC
>Maybe you made a typo in the cookie itself ?
I don't think so. I use copy past and have tried many times.
Parameters "pess" and "uid" i took from google chrome (look at the screenshot http://dl.dropbox.com/u/3161146/ktorrent/1.png)
Parametr usess i took from my profile settings on Lostfilm (look at the screenshot http://dl.dropbox.com/u/3161146/ktorrent/2.png)
It's right?
Comment 9 WiseLord 2011-04-08 16:56:04 UTC
Problem comes from fact that lostfilm.tv use additional protection from unautorized users. It needs three cookies from torrent client: "uid", "pass" and "usess". First and second we can take from internet browser (konqueror), and ktorrent uses thees cookies too. But "usess" cookie doens't pass to browser, it can be taken only from user profile and manually given to torrent client. So lostfilm.tv user neets to logout from kde and put "usess" cookie to ~/.kde4/share/apps/kcookiejar/cookies file manually. So ktorrent will use it next time.

I don't think that other sites use such protection, but it is a good idea to give to ktorrent possibility to use additional cookies instead of ~/.kde4/share/apps/kcookiejar/cookies file.