Bug 244712 - Palapeli crashes whenever I click on a puzzle
Summary: Palapeli crashes whenever I click on a puzzle
Status: RESOLVED DUPLICATE of bug 243492
Alias: None
Product: palapeli
Classification: Applications
Component: general (show other bugs)
Version: 1.1
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Stefan Majewsky
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-15 10:29 UTC by Blackpaw
Modified: 2010-07-16 16:59 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
gdb stack trace for crash (2.92 KB, text/plain)
2010-07-16 14:09 UTC, Blackpaw
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Blackpaw 2010-07-15 10:29:15 UTC
Version:           1.1 (KDE SC 4.5)
OS:                Linux

When ever I select one of the std  puzzles in Palapeli it crashes with a segmentation fault, there crash wizard does not appear.

   "Segmentation fault (core dumped)"

On startup I see the following on the konsole

"palapeli 
registerWindow Invalid WindowMenu.Registrar! 
QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No such file or directory
QFileSystemWatcher: failed to add paths: /home/lindsay/.config/ibus/bus
Bus::open: Can not get ibus-daemon's address. 
IBusInputContext::createInputContext: no connection to ibus-daemon 
palapeli(2076)/kdecore (KConfigSkeleton) KCoreConfigSkeleton::writeConfig:"


Reproducible: Always

Steps to Reproduce:
Start Palapeli
Click on a puzzle

Actual Results:  
Palapeli crashes with a segmentation fault

Expected Results:  
The puzzle game should start

OS: Linux (x86_64) release 2.6.35-8-generic
Compiler: cc

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu maverick (development branch)
Release:        10.10
Codename:       maverick


kde4-config --version
Qt: 4.7.0
KDE Development Platform: 4.4.92 (KDE 4.4.92 (KDE 4.5 RC2))
kde4-config: 1.0
Comment 1 Johannes Obermayr 2010-07-15 15:18:54 UTC
If drkonqi does not start you can try (konsole):

gdb palapeli  (load palapeli in gdb)
 run          (starts palapeli and you must let it crash)
 bt           (creates and shows backtrace [Type <return> to continue, if gdb shows])
 q            (quit gdb)
 Quit any? y

Please post the output between [(gdb) bt] and [(gdb) q] as an attachment (text/plain).
Comment 2 Stefan Majewsky 2010-07-15 16:29:36 UTC
If you're using Qt 4.7, this is most likely bug 243492.
Comment 3 Blackpaw 2010-07-16 14:09:06 UTC
Created attachment 49217 [details]
gdb stack trace for crash
Comment 4 Blackpaw 2010-07-16 14:10:44 UTC
Added a gdb trace as requested.

Does look like https://bugs.kde.org/show_bug.cgi?id=243492

If I start palapeli with the CDE style ("palapeli -style CDE") it works fine.


Thanks,
Comment 5 Stefan Majewsky 2010-07-16 16:59:04 UTC

*** This bug has been marked as a duplicate of bug 243492 ***