Bug 243849 - action not ran when screen unlocked
Summary: action not ran when screen unlocked
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Unclassified
Component: kcm_notify (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Olivier Goffart
URL:
Keywords:
: 249087 251825 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-07-07 14:12 UTC by Nick Malakhov
Modified: 2011-04-13 10:19 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.6.3


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Malakhov 2010-07-07 14:12:19 UTC
Version:           unspecified (using KDE 4.4.4) 
OS:                Linux

I added "Run command" to events "Screen locked" and "Screen unlocked" in system settings. Command was envoked when I press Ctrl+Alt+L and lock screen, but when I unlock screen command not run.

Reproducible: Always

Steps to Reproduce:
1. systemsettings -> Notifications -> The KDE Screen Saver
2. Add "run command" or even "play a sound" setting
3. Lock the screen. Sound plays.
4. Unlock the screen. Sount doesn't play

Actual Results:  
Command doesn't run on screen unlock

Expected Results:  
actually, my script's execution
Comment 1 Benni Hill 2011-02-04 21:09:49 UTC
I can confirm this on KDE 4.6.
Comment 2 Lamarque V. Souza 2011-04-09 09:57:11 UTC
*** Bug 251825 has been marked as a duplicate of this bug. ***
Comment 3 Lamarque V. Souza 2011-04-09 09:57:48 UTC
*** Bug 249087 has been marked as a duplicate of this bug. ***
Comment 4 Lamarque V. Souza 2011-04-13 10:19:19 UTC
Git commit d5e14a0cdbd99cb80682e473912fd82f9ba6e40c by Lamarque V. Souza.
Committed on 13/04/2011 at 10:23.
Pushed by lvsouza into branch 'KDE/4.6'.

Using static method KNotification::event() does not work here, creating a
KNotification object does.

BUG: 243849
FIXED-IN: 4.6.3

M  +4    -2    krunner/lock/lockprocess.cc     

http://commits.kde.org/kde-workspace/d5e14a0cdbd99cb80682e473912fd82f9ba6e40c
Comment 5 Lamarque V. Souza 2011-04-13 10:19:19 UTC
Git commit 52ca2fd57f9f9aa5b30b0a9da0e66787bcaf0cc7 by Lamarque V. Souza.
Committed on 13/04/2011 at 10:23.
Pushed by lvsouza into branch 'master'.

Using static method KNotification::event() does not work here, creating a
KNotification object does.

BUG: 243849
FIXED-IN: 4.6.3

M  +4    -2    krunner/lock/lockprocess.cc     

http://commits.kde.org/kde-workspace/52ca2fd57f9f9aa5b30b0a9da0e66787bcaf0cc7