Bug 243540 - kcolorchooser - crashes when using the colorpicker tool
Summary: kcolorchooser - crashes when using the colorpicker tool
Status: RESOLVED FIXED
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kdeui (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
: 243067 245329 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-07-04 00:51 UTC by Elias Probst
Modified: 2011-02-27 17:38 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Elias Probst 2010-07-04 00:51:10 UTC
Version:           unspecified (using Devel) 
OS:                Linux



Reproducible: Always

Steps to Reproduce:
Since upgrading to KDE 4.5 RC1 (previously: 4.4.4) the colorpicker tool of kcolorchooser doesn't work anymore.

As soon as one clicks a color which should be picked, kcolorchooser just disappears and doesn't even launch Dr. Konqi.

Instead, only this terminal output is shown:

elias@e6500 ~ % kcolorchooser 
KCrash: Application 'kcolorchooser' crashing...
KCrash: Attempting to start /usr/lib64/kde4/libexec/drkonqi from kdeinit
zsh: alarm      kcolorchooser

As kcolorchooser isn't registered at bugs.kde.org I had to file this bug as 'unknown'.
Comment 1 Lubos Lunak 2010-07-29 16:32:20 UTC
SVN commit 1156691 by lunakl:

Make sure the iterator goes out of scope before possibly deleting its list.
BUG: 243540
CCMAIL: Matthew Woehlke <mw_triad@users.sourceforge.net>



 M  +3 -2      kapplication.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1156691
Comment 2 Lubos Lunak 2010-07-29 16:33:04 UTC
SVN commit 1156692 by lunakl:

Make sure the iterator goes out of scope before possibly deleting its list.
BUG: 243540



 M  +3 -2      kapplication.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1156692
Comment 3 George Kiagiadakis 2010-08-19 23:18:33 UTC
*** Bug 243067 has been marked as a duplicate of this bug. ***
Comment 4 Oswald Buddenhagen 2011-02-27 17:38:25 UTC
*** Bug 245329 has been marked as a duplicate of this bug. ***