Bug 243447 - Bookmark Editor crashed after hitting Sort Alphabetically
Summary: Bookmark Editor crashed after hitting Sort Alphabetically
Status: RESOLVED WORKSFORME
Alias: None
Product: keditbookmarks
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
: 254460 352350 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-07-02 15:55 UTC by Leonardo La Malfa
Modified: 2018-11-30 03:47 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (8.56 KB, text/plain)
2010-08-25 12:17 UTC, Leonardo La Malfa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Leonardo La Malfa 2010-07-02 15:55:22 UTC
Application: keditbookmarks (4.4.5 (KDE 4.4.5))
KDE Platform Version: 4.4.5 (KDE 4.4.5)
Qt Version: 4.6.3
Operating System: Linux 2.6.32-23-generic i686
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
I opened Bookmark Editor, and created two folders within an existing one, but wanted them to be shown alphabetically. So I clicked on Sort Alphabetically, but this caused the editor to crash. It was nice to see Rekonq unaffected and still available. I tried to reproduce this, but had no luck.

 -- Backtrace:
Application: Bookmark Editor (keditbookmarks), signal: Segmentation fault
[Current thread is 1 (Thread 0xb77b69f0 (LWP 2463))]

Thread 2 (Thread 0xb5270b70 (LWP 2464)):
#0  0x0023c422 in __kernel_vsyscall ()
#1  0x002fcb86 in poll () from /lib/tls/i686/cmov/libc.so.6
#2  0x07d7d4eb in IA__g_poll (fds=0x8dab078, nfds=1, timeout=-1) at /build/buildd/glib2.0-2.24.1/glib/gpoll.c:127
#3  0x07d700ac in g_main_context_poll (context=0x8daace0, block=<value optimized out>, dispatch=1, self=0x8dab050) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2904
#4  g_main_context_iterate (context=0x8daace0, block=<value optimized out>, dispatch=1, self=0x8dab050) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2586
#5  0x07d704b8 in IA__g_main_context_iteration (context=0x8daace0, may_block=1) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2654
#6  0x01135e6f in QEventDispatcherGlib::processEvents (this=0x8d9ff38, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#7  0x01108759 in QEventLoop::processEvents (this=0xb5270290, flags=) at kernel/qeventloop.cpp:149
#8  0x01108baa in QEventLoop::exec (this=0xb5270290, flags=...) at kernel/qeventloop.cpp:201
#9  0x01009fc9 in QThread::exec (this=0x8da8f78) at thread/qthread.cpp:487
#10 0x010e81db in QInotifyFileSystemWatcherEngine::run (this=0x8da8f78) at io/qfilesystemwatcher_inotify.cpp:248
#11 0x0100c97e in QThreadPrivate::start (arg=0x8da8f78) at thread/qthread_unix.cpp:248
#12 0x0020196e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#13 0x0030aa4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb77b69f0 (LWP 2463)):
[KCrash Handler]
#6  QListData::end (this=0x54, __in_chrg=<value optimized out>) at /usr/include/qt4/QtCore/qlist.h:94
#7  QList<TreeItem*>::end (this=0x54, __in_chrg=<value optimized out>) at /usr/include/qt4/QtCore/qlist.h:252
#8  qDeleteAll<QList<TreeItem*> > (this=0x54, __in_chrg=<value optimized out>) at /usr/include/qt4/QtCore/qalgorithms.h:330
#9  ~TreeItem (this=0x54, __in_chrg=<value optimized out>) at ../../../apps/keditbookmarks/treeitem.cpp:30
#10 0x0094fa06 in qDeleteAll<QList<TreeItem*>::const_iterator> (this=0x8ff9d68, __in_chrg=<value optimized out>) at /usr/include/qt4/QtCore/qalgorithms.h:322
#11 qDeleteAll<QList<TreeItem*> > (this=0x8ff9d68, __in_chrg=<value optimized out>) at /usr/include/qt4/QtCore/qalgorithms.h:330
#12 ~TreeItem (this=0x8ff9d68, __in_chrg=<value optimized out>) at ../../../apps/keditbookmarks/treeitem.cpp:30
#13 0x0094fb86 in TreeItem::deleteChildren (this=0x8fd1688, first=10, last=10) at ../../../apps/keditbookmarks/treeitem.cpp:81
#14 0x00937b3b in ~KBookmarkModelRemoveSentry (this=0x8fe4790) at ../../../apps/keditbookmarks/commands.cpp:74
#15 CreateCommand::undo (this=0x8fe4790) at ../../../apps/keditbookmarks/commands.cpp:205
#16 0x00939a7b in DeleteCommand::redo (this=0x9098eb8) at ../../../apps/keditbookmarks/commands.cpp:359
#17 0x0748e933 in QUndoCommand::redo (this=0x8d97048) at util/qundostack.cpp:208
#18 0x00939d4c in DeleteCommand::redo (this=0x9099d28) at ../../../apps/keditbookmarks/commands.cpp:350
#19 0x0748e933 in QUndoCommand::redo (this=0x8ef2488) at util/qundostack.cpp:208
#20 0x00939d4c in DeleteCommand::redo (this=0x9055bd0) at ../../../apps/keditbookmarks/commands.cpp:350
#21 0x009378b2 in MoveCommand::redo (this=0x8f3c120) at ../../../apps/keditbookmarks/commands.cpp:416
#22 0x009388f1 in SortCommand::moveAfter (this=0x9061200, moveMe=..., afterMe=...) at ../../../apps/keditbookmarks/commands.cpp:499
#23 0x00938e9e in kInsertionSort<SortItem, SortByName, QString, SortCommand> (this=0x9061200) at ../../../apps/keditbookmarks/kinsertionsort.h:53
#24 SortCommand::redo (this=0x9061200) at ../../../apps/keditbookmarks/commands.cpp:480
#25 0x07490325 in QUndoStack::push (this=0x8897890, cmd=0x9061200) at util/qundostack.cpp:541
#26 0x00930053 in CmdHistory::addCommand (this=0x8897888, cmd=0x9061200) at ../../../apps/keditbookmarks/commandhistory.cpp:88
#27 0x00932875 in ActionsImpl::slotSort (this=0x888c448) at ../../../apps/keditbookmarks/actionsimpl.cpp:506
#28 0x009332f0 in ActionsImpl::qt_metacall (this=0x888c448, _c=QMetaObject::InvokeMetaMethod, _id=13, _a=0xbf8e7968) at ./actionsimpl.moc:131
#29 0x0110f47a in QMetaObject::metacall (object=0x888c448, cl=QMetaObject::ReadProperty, idx=17, argv=0xbf8e7968) at kernel/qmetaobject.cpp:237
#30 0x0111dfbb in QMetaObject::activate (sender=0x889ed80, m=0x76a8cf8, local_signal_index=1, argv=0xbf8e7968) at kernel/qobject.cpp:3295
#31 0x06d77589 in QAction::triggered (this=0x889ed80, _t1=false) at .moc/release-shared/moc_qaction.cpp:263
#32 0x06d7977c in QAction::activate (this=0x889ed80, event=QAction::Trigger) at kernel/qaction.cpp:1255
#33 0x0721ebdf in QMenuPrivate::activateCausedStack (this=0x88e1020, causedStack=..., action=0x889ed80, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:1002
#34 0x07224f3b in QMenuPrivate::activateAction (this=0x88e1020, action=0x889ed80, action_e=QAction::Trigger, self=<value optimized out>) at widgets/qmenu.cpp:1094
#35 0x07225f87 in QMenu::mouseReleaseEvent (this=0x88e1000, e=0xbf8e8200) at widgets/qmenu.cpp:2312
#36 0x00ec4745 in KMenu::mouseReleaseEvent (this=0x88e1000, e=0xbf8e8200) at ../../kdeui/widgets/kmenu.cpp:471
#37 0x06ddc158 in QWidget::event (this=0x88e1000, event=0xbf8e8200) at kernel/qwidget.cpp:8044
#38 0x0722758c in QMenu::event (this=0x88e1000, e=0xbf8e8200) at widgets/qmenu.cpp:2421
#39 0x06d7de8c in QApplicationPrivate::notify_helper (this=0x8838ba0, receiver=0x88e1000, e=0xbf8e8200) at kernel/qapplication.cpp:4302
#40 0x06d853a7 in QApplication::notify (this=0xbf8e8be4, receiver=0x88e1000, e=0xbf8e8200) at kernel/qapplication.cpp:3867
#41 0x00dce40a in KApplication::notify (this=0xbf8e8be4, receiver=0x88e1000, event=0xbf8e8200) at ../../kdeui/kernel/kapplication.cpp:302
#42 0x0110a13b in QCoreApplication::notifyInternal (this=0xbf8e8be4, receiver=0x88e1000, event=0xbf8e8200) at kernel/qcoreapplication.cpp:726
#43 0x06d84302 in QCoreApplication::sendEvent (receiver=0x88e1000, event=0xbf8e8200, alienWidget=0x0, nativeWidget=0x88e1000, buttonDown=0x76c4058, lastMouseReceiver=..., spontaneous=true)
    at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#44 QApplicationPrivate::sendMouseEvent (receiver=0x88e1000, event=0xbf8e8200, alienWidget=0x0, nativeWidget=0x88e1000, buttonDown=0x76c4058, lastMouseReceiver=..., spontaneous=true)
    at kernel/qapplication.cpp:2967
#45 0x06e1029f in QETWidget::translateMouseEvent (this=0x88e1000, event=0xbf8e871c) at kernel/qapplication_x11.cpp:4314
#46 0x06e0f1e1 in QApplication::x11ProcessEvent (this=0xbf8e8be4, event=0xbf8e871c) at kernel/qapplication_x11.cpp:3391
#47 0x06e3e2ea in x11EventSourceDispatch (s=0x883bb68, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#48 0x07d6c5e5 in g_main_dispatch (context=0x883ac90) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:1960
#49 IA__g_main_context_dispatch (context=0x883ac90) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2513
#50 0x07d702d8 in g_main_context_iterate (context=0x883ac90, block=<value optimized out>, dispatch=1, self=0x88386e8) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2591
#51 0x07d704b8 in IA__g_main_context_iteration (context=0x883ac90, may_block=1) at /build/buildd/glib2.0-2.24.1/glib/gmain.c:2654
#52 0x01135e35 in QEventDispatcherGlib::processEvents (this=0x8823b60, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#53 0x06e3de15 in QGuiEventDispatcherGlib::processEvents (this=0x8823b60, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#54 0x01108759 in QEventLoop::processEvents (this=0xbf8e8a14, flags=) at kernel/qeventloop.cpp:149
#55 0x01108baa in QEventLoop::exec (this=0xbf8e8a14, flags=...) at kernel/qeventloop.cpp:201
#56 0x0110de3f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#57 0x06d7df27 in QApplication::exec () at kernel/qapplication.cpp:3581
#58 0x0092a9c9 in kdemain (argc=5, argv=0xbf8e8f54) at ../../../apps/keditbookmarks/main.cpp:204
#59 0x0804860b in main (argc=5, argv=0xbf8e8f54) at keditbookmarks_dummy.cpp:3

Reported using DrKonqi
Comment 1 Leonardo La Malfa 2010-08-25 12:17:04 UTC
Created attachment 50923 [details]
New crash information added by DrKonqi

keditbookmarks (4.5.00 (KDE 4.5.0)) on KDE Platform 4.5.00 (KDE 4.5.0) using Qt 4.7.0

- What I was doing when the application crashed:

I opened Bookmark Editor, chose a recently created folder, and pressed Sort Alphabetically and then Recursive Sort. The latter caused the crash. This keeps happening on KDE 4.5.

-- Backtrace (Reduced):
#7  QListData::end (this=0x74, __in_chrg=<value optimized out>) at /usr/include/qt4/QtCore/qlist.h:98
#8  QList<TreeItem*>::end (this=0x74, __in_chrg=<value optimized out>) at /usr/include/qt4/QtCore/qlist.h:258
#9  qDeleteAll<QList<TreeItem*> > (this=0x74, __in_chrg=<value optimized out>) at /usr/include/qt4/QtCore/qalgorithms.h:330
#10 ~TreeItem (this=0x74, __in_chrg=<value optimized out>) at ../../../../apps/keditbookmarks/kbookmarkmodel/treeitem.cpp:29
#11 0x004c633e in TreeItem::deleteChildren (this=0x94bfd80, first=0, last=0) at ../../../../apps/keditbookmarks/kbookmarkmodel/treeitem.cpp:80
Comment 2 Tommi Tervo 2010-10-17 15:49:43 UTC
*** Bug 254460 has been marked as a duplicate of this bug. ***
Comment 3 Christoph Feck 2015-09-27 21:14:47 UTC
*** Bug 352350 has been marked as a duplicate of this bug. ***
Comment 4 Andrew Crouthamel 2018-10-31 04:06:00 UTC
Dear Bug Submitter,

This bug has been stagnant for a long time. Could you help us out and re-test if the bug is valid in the latest version? I am setting the status to NEEDSINFO pending your response, please change the Status back to REPORTED when you respond.

Thank you for helping us make KDE software even better for everyone!
Comment 5 Bug Janitor Service 2018-11-15 10:33:34 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 6 Bug Janitor Service 2018-11-30 03:47:30 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!