Bug 243443 - Kile does not correctly wrap comment lines
Summary: Kile does not correctly wrap comment lines
Status: RESOLVED DUPLICATE of bug 105373
Alias: None
Product: kate
Classification: Unclassified
Component: part (show other bugs)
Version: 0.2
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-07-02 15:12 UTC by Thomas Damgaard
Modified: 2010-07-04 23:24 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Damgaard 2010-07-02 15:12:29 UTC
Version:           2.0.85 (using Devel) 
OS:                Linux

This is case of Kile not handling comments and line wrapping correctly.

When you have enabled static word wrapping and write a long comment, Kile wraps the line, but forgets to add '% ' in front of the wrapped line.



Reproducible: Always

Steps to Reproduce:
1: Settings > Editor > Editing > Enabled static word wrap, wrap words at 80
characters.
2: Press Ctrl+D to start a comment.
3: Begin typing words so that the line reaches 80 chars and is wrapped.
4: Notice that the second line does not start with '% '.


Actual Results:  
Second line is not commented.

Expected Results:  
Second line should also be a comment.

I use KDE 4.4.5 from PPA with Kubuntu 10.04.
Comment 1 Michel Ludwig 2010-07-03 19:56:29 UTC
This one is for KatePart. Forwarding...
Comment 2 Dominik Haumann 2010-07-04 23:24:34 UTC

*** This bug has been marked as a duplicate of bug 105373 ***