Bug 242885 - Akregator doesn't terminate if clicked on kwin button
Summary: Akregator doesn't terminate if clicked on kwin button
Status: RESOLVED UNMAINTAINED
Alias: None
Product: akregator
Classification: Applications
Component: general (show other bugs)
Version: 1.6.2
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-26 17:17 UTC by Majki
Modified: 2017-01-07 21:25 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Majki 2010-06-26 17:17:43 UTC
Version:           1.6.2
OS:                Linux

If I close akregator using "close" button on kwin decoration, window closes, but process stays in the background. When I try to run it again, it fails to run. Closing through menu works ok.

Reproducible: Always

Steps to Reproduce:
1. Run akregator.
2. Close using button.
3. Try to run akregator.
4. Open system monitor/top/htop and kill it manualy to get akregator working again.

Actual Results:  
Aakregator work again, if killed as process.

Expected Results:  
If akregator is clicked to close, it should close, including process in background.

I'm using KDEmod on Arch Linux.
Comment 1 Björn Hendriks 2012-05-30 10:21:03 UTC
I can confirm this with Akregator 1.6.6 on KDE 4.7.4 on an up-to-date Debian Testing (3.2.0-2-amd64 #1 SMP Sat May 12 23:08:28 UTC 2012 x86_64 GNU/Linux).

I like to extent the expectations, because I'm used to have Akregator running in background to get notifications of new messages and see the number of unread messages on the task bar.

As far as I can see, currently, the only way to make Akregator run in background is the close button of the window decoration. (BTW, the message box containing the screen shot with the marked task bar icon is really cool! I still haven't deactivated the message box so I can enjoy it every time.)

Instead of using (abusing?) the close button for sending Akregator to the background I'd prefer a toolbar icon and a configurable keyboard shortcut.
Comment 2 Christophe Giboudeaux 2012-05-30 10:28:59 UTC
note: This is the expected behaviour for applications using a tray icon
Comment 3 Björn Hendriks 2012-05-30 10:39:35 UTC
(In reply to comment #2)
> note: This is the expected behaviour for applications using a tray icon

OK, that's fine with me. But, I still would like to have a keyboard shortcut for this, because CTRL-Q completely quits Akregator. Or did I overlook it?
Comment 4 Maarten De Meyer 2014-01-16 13:56:21 UTC
(In reply to comment #3)
> OK, that's fine with me. But, I still would like to have a keyboard shortcut
> for this, because CTRL-Q completely quits Akregator. Or did I overlook it?

You want a shortcut to close the Akregator window?
Alt+F4 should do the trick.
Comment 5 Denis Kurz 2016-09-24 19:38:17 UTC
This bug has only been reported for versions before 4.14, which have been unsupported for at least two years now. Can anyone tell if this bug still present?

If noone confirms this bug for a Framework-based version of akregator (version 5.0 or later, as part of KDE Applications 15.08 or later), it gets closed in about three months.
Comment 6 Denis Kurz 2017-01-07 21:25:49 UTC
Just as announced in my last comment, I close this bug. If you encounter it again in a recent version (at least 5.0 aka 15.08), please open a new one unless it already exists. Thank you for all your input.