Bug 242676 - Ark doesn't support password for RAR archive
Summary: Ark doesn't support password for RAR archive
Status: RESOLVED DUPLICATE of bug 35371
Alias: None
Product: ark
Classification: Applications
Component: general (show other bugs)
Version: 2.12
Platform: Compiled Sources Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Harald Hvaal
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-24 13:00 UTC by Aaron Lewis
Modified: 2010-06-25 16:37 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aaron Lewis 2010-06-24 13:00:33 UTC
Version:           2.12 (using KDE 4.4.4) 
OS:                Linux

Ark doesn't support password for RAR archive

It hangs when handling encrypted RAR archives

Reproducible: Always

Steps to Reproduce:
To encrypt a file and archive with RAR:
rar a -hp file.rar files

Actual Results:  

Ark hangs , no response at all

Expected Results:  
At least should tell me it's not supported or popup a dialog asking for credentials.

OS: Linux (i686) release 2.6.31-tuxonice-r11
Compiler: i686-pc-linux-gnu-gcc
Comment 1 Aaron Lewis 2010-06-24 13:04:12 UTC
Well , file-roller (Gnome Desktop) has a good support , havn't tried 7-zip yet , they are all open-source.
Comment 2 Aaron Lewis 2010-06-24 16:48:53 UTC
I'm sorry for not making it clear.

Often i encrypt RAR archives with header protection , so that you won't be able to see the contents , the filenames in case , before you type in the correct password.

rar a -hp file.rar file

-hp option is used to encrypt header together.
Comment 3 Raphael Kubo da Costa 2010-06-25 16:37:32 UTC

*** This bug has been marked as a duplicate of bug 35371 ***