Bug 242647 - merging contacts
Summary: merging contacts
Status: RESOLVED FIXED
Alias: None
Product: kaddressbook
Classification: Applications
Component: general (show other bugs)
Version: 5.5.3
Platform: Ubuntu Linux
: NOR wishlist with 188 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 278780 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-06-24 00:17 UTC by Jan
Modified: 2018-02-24 21:28 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan 2010-06-24 00:17:22 UTC
Version:           unspecified (using KDE 4.4.4) 
OS:                Linux

a very helpfull function would be to be able to merge two or more contacts. having multiple sources of contacts and groups/lists and deleting one contact after copying the informations, the contact will be missing in some groups, as the one who was part of it was deleted.
So merging the contacts and updating the groups would make it much easier to manage your contatcs.

Reproducible: Didn't try
Comment 1 Steffen Michalek 2010-06-26 22:54:51 UTC
Merging the information rather than copy/insert by hand would be really helpful!
(I have several contact lists put together - and hundreds of duplicates or different information about the same contact.)

This feature was implemented in a former version of kaddressbook, wasn't it?
Comment 2 Jan 2010-06-26 23:00:28 UTC
Yes, as far as i know this was a feature of kAdressbook at the 3.5 realeases
Comment 3 bendj 2010-06-28 06:04:18 UTC
just curious -- shouldn't this be considered a regression, rather than a wishlist item?
Comment 4 sphakka 2010-11-21 12:43:25 UTC
Please, add this feature! Have a look at how GMail does, and... make it better ;-) 
I'd like to be able to select the fields on which the comparison is made -- GMail doesn't allow this, and the results are often horribly fuzzy.

On the same line, a "find [and merge] duplicates" feature would be great.

Cheers,
  ^s
Comment 5 Benjamin Eikel 2010-12-14 08:30:07 UTC
This seems to be related to Bug 241386.
Comment 6 Benjamin Eikel 2010-12-14 08:30:59 UTC
*** This bug has been confirmed by popular vote. ***
Comment 7 Christophe Giboudeaux 2011-10-15 10:27:39 UTC
*** Bug 278780 has been marked as a duplicate of this bug. ***
Comment 8 Dennis Schridde 2012-08-28 19:13:32 UTC
This feature is still missing in KDE 4.9.
Comment 9 Laurent Montel 2013-11-16 13:50:25 UTC
Git commit 10b6d9802a6ba63dd962390285c35bc68c9f6d02 by Montel Laurent.
Committed on 16/11/2013 at 13:49.
Pushed by mlaurent into branch 'master'.

Continue to implement merge contacts
Related: bug 241386, bug 325186

M  +7    -1    kaddressbook/CMakeLists.txt
R  +0    -0    kaddressbook/merge/mergecontacts.cpp [from: kaddressbook/mergecontacts.cpp - 100% similarity]
C  +0    -0    kaddressbook/merge/mergecontacts.h [from: kaddressbook/mergecontacts.h - 100% similarity]
A  +52   -0    kaddressbook/merge/mergecontactsdialog.cpp     [License: GPL (v2)]
C  +13   -8    kaddressbook/merge/mergecontactsdialog.h [from: kaddressbook/mergecontacts.h - 071% similarity]
A  +52   -0    kaddressbook/merge/searchduplicatecontactdialog.cpp     [License: GPL (v2)]
R  +12   -8    kaddressbook/merge/searchduplicatecontactdialog.h [from: kaddressbook/mergecontacts.h - 067% similarity]

http://commits.kde.org/kdepim/10b6d9802a6ba63dd962390285c35bc68c9f6d02
Comment 10 Laurent Montel 2015-02-16 12:56:07 UTC
Git commit 2f0f1aafb9b4f84751fd838c9177c4fc2748e307 by Montel Laurent.
Committed on 16/02/2015 at 12:23.
Pushed by mlaurent into branch 'KDE/4.14'.

Fix Bug 325186 - There is no way to merge contacts
Related: bug 325186, bug 241386

M  +22   -0    kaddressbook/merge/manualmerge/mergecontactsdialog.cpp
M  +6    -1    kaddressbook/merge/manualmerge/mergecontactsdialog.h
M  +19   -38   kaddressbook/merge/manualmerge/mergecontactwidget.cpp
M  +6    -1    kaddressbook/merge/manualmerge/mergecontactwidget.h
M  +2    -1    kaddressbook/merge/tests/mergecontactsdialogtest.cpp

http://commits.kde.org/kdepim/2f0f1aafb9b4f84751fd838c9177c4fc2748e307
Comment 11 Hans-Peter Jansen 2015-02-16 14:58:05 UTC
These are GREAT news! Let's see, how that works out..
Comment 12 Robert Bonnett 2018-02-24 21:28:57 UTC
kaddressbook keeps merging my various addressbooks into one combined addressbook