Bug 242308 - Kontact process still running after application is closed
Summary: Kontact process still running after application is closed
Status: RESOLVED DUPLICATE of bug 222878
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.4.3
Platform: Ubuntu Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-21 00:03 UTC by Leonardo La Malfa
Modified: 2011-07-14 12:43 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leonardo La Malfa 2010-06-21 00:03:22 UTC
Version:           4.4.3 (using KDE 4.4.4) 
OS:                Linux

Recently, I've taken to checking System Monitor more often, and have noticed that, after a day use, the process named "kontact" is present in the list of running programs although I've just closed it. Nothing changes if I wait a couple of minutes, or until I shut down. If I right-click the process and choose "Show Application Window" nothing happens. If I click on Kontact in the main menu, cursor bounces for a while, there's some activity in the task bar,  but ultimately it fails to start. So it's not like the app is really running, although it behaves as if trying to open another instance of the same application. I have to manually kill the process, if I want to restart Kontact.

This is reproducible everyday, after hours and hours of use. After a whole day, it eats up to 150 MB of RAM, and may be problematic if the process just sits there uselessly and unnoticed. However, I've tried to start the programme, use it for shorter periods, then quit it, and the process exits properly.

Reproducible: Sometimes




OS: Linux (i686) release 2.6.32-22-generic
Compiler: cc
Comment 1 Michal Klich 2010-08-15 21:48:57 UTC
I confirm, kontact does not close propely, process is still running.

Qt: 4.6.3
KDE: 4.4.5 (KDE 4.4.5)
Kontact: 4.4.5
Comment 2 Jan 2010-11-17 08:57:59 UTC
I can confirm this too.
KDE 4.5.3 using Kubuntu 10.10 PPA
Comment 3 Jan 2011-01-27 18:25:21 UTC
still exists in 4.6 using Kubuntu PPA Backports

Starting Kontact after quitting, didn't killed the process manually, you get an crash at startup with the following backtrace:


Application: Kontact (kontact), signal: Segmentation fault
[Current thread is 1 (Thread 0x7ffa8327e780 (LWP 21967))]

Thread 3 (Thread 0x7ffa632e8700 (LWP 22051)):
#0  0x00007ffa89b87203 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007ffa8b5fc240 in ?? () from /opt/lib/libmediaclient.so
#2  0x00007ffa8b5fca1d in poll () from /opt/lib/libmediaclient.so
#3  0x0000003ae5044009 in ?? () from /lib/libglib-2.0.so.0
#4  0x0000003ae504445c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#5  0x0000003ae85951e6 in QEventDispatcherGlib::processEvents (this=0x2e816f0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:417
#6  0x0000003ae8567a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#7  0x0000003ae8567dec in QEventLoop::exec (this=0x7ffa632e7d90, flags=) at kernel/qeventloop.cpp:201
#8  0x0000003ae84722fd in QThread::exec (this=<value optimized out>) at thread/qthread.cpp:490
#9  0x0000003ae85475f8 in QInotifyFileSystemWatcherEngine::run (this=0x2e80c80) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x0000003ae847527e in QThreadPrivate::start (arg=0x2e80c80) at thread/qthread_unix.cpp:266
#11 0x00007ffa89896971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#12 0x00007ffa89b9392d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7ffa61340700 (LWP 24144)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:212
#1  0x00007ffa67db90d1 in ?? () from /usr/lib/libxine.so.1
#2  0x00007ffa89896971 in start_thread (arg=<value optimized out>) at pthread_create.c:304
#3  0x00007ffa89b9392d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#4  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ffa8327e780 (LWP 21967)):
[KCrash Handler]
#6  Kontact::MainWindow::activateInitialPluginModule (this=0x1074220) at ../../../kontact/src/mainwindow.cpp:289
#7  0x00000000004043f2 in KontactApp::newInstance (this=0x7fff46c8bd60) at ../../../kontact/src/main.cpp:149
#8  0x00007ffa8a58f2b2 in KUniqueApplicationAdaptor::newInstance (this=0x1096460, asn_id=<value optimized out>, args=...) at ../../kdeui/kernel/kuniqueapplication.cpp:436
#9  0x00007ffa8a58f916 in KUniqueApplicationAdaptor::qt_metacall (this=0x1096460, _c=QMetaObject::InvokeMetaMethod, _id=20592816, _a=0x7fff46c8af00) at ./kuniqueapplication_p.moc:81
#10 0x0000003ae96230ee in QDBusConnectionPrivate::deliverCall (this=<value optimized out>, object=<value optimized out>, msg=<value optimized out>, metaTypes=..., slotIdx=<value optimized out>) at qdbusintegrator.cpp:919
#11 0x0000003ae96243cb in QDBusConnectionPrivate::activateCall (this=<value optimized out>, object=0x1096460, flags=337, msg=...) at qdbusintegrator.cpp:829
#12 0x0000003ae9624e65 in QDBusConnectionPrivate::activateObject (this=<value optimized out>, node=<value optimized out>, msg=..., pathStartPos=<value optimized out>) at qdbusintegrator.cpp:1379
#13 0x0000003ae9625108 in QDBusActivateObjectEvent::placeMetaCall (this=0x61ed1c0) at qdbusintegrator.cpp:1493
#14 0x0000003ae857abde in QObject::event (this=0x7fff46c8bd60, e=0x1074220) at kernel/qobject.cpp:1219
#15 0x0000003ae9bbb186 in QApplication::event (this=0x7fff46c8bd60, e=0x61ed1c0) at kernel/qapplication.cpp:2439
#16 0x0000003ae9bb7fdc in QApplicationPrivate::notify_helper (this=0xf3b5c0, receiver=0x7fff46c8bd60, e=0x61ed1c0) at kernel/qapplication.cpp:4396
#17 0x0000003ae9bbdaed in QApplication::notify (this=0x7fff46c8bd60, receiver=0x7fff46c8bd60, e=0x61ed1c0) at kernel/qapplication.cpp:4277
#18 0x00007ffa8a587a36 in KApplication::notify (this=0x7fff46c8bd60, receiver=0x7fff46c8bd60, event=0x61ed1c0) at ../../kdeui/kernel/kapplication.cpp:311
#19 0x0000003ae8568cdc in QCoreApplication::notifyInternal (this=0x7fff46c8bd60, receiver=0x7fff46c8bd60, event=0x61ed1c0) at kernel/qcoreapplication.cpp:732
#20 0x0000003ae856bc22 in sendEvent (receiver=0x0, event_type=<value optimized out>, data=0xf09380) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#21 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=<value optimized out>, data=0xf09380) at kernel/qcoreapplication.cpp:1373
#22 0x0000003ae8595653 in sendPostedEvents (s=0xf3dd40) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#23 postEventSourceDispatch (s=0xf3dd40) at kernel/qeventdispatcher_glib.cpp:277
#24 0x0000003ae5040342 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#25 0x0000003ae50442a8 in ?? () from /lib/libglib-2.0.so.0
#26 0x0000003ae504445c in g_main_context_iteration () from /lib/libglib-2.0.so.0
#27 0x0000003ae8595193 in QEventDispatcherGlib::processEvents (this=0xf08e90, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:415
#28 0x0000003ae9c6aa4e in QGuiEventDispatcherGlib::processEvents (this=0x1074220, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#29 0x0000003ae8567a02 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#30 0x0000003ae8567dec in QEventLoop::exec (this=0x7fff46c8bca0, flags=) at kernel/qeventloop.cpp:201
#31 0x0000003ae856bebb in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1009
#32 0x0000000000403b4e in main (argc=<value optimized out>, argv=<value optimized out>) at ../../../kontact/src/main.cpp:224
Comment 4 Jan 2011-01-27 18:27:54 UTC
seems to be related to #156292
Comment 5 Christophe Marin 2011-07-14 12:43:42 UTC

*** This bug has been marked as a duplicate of bug 222878 ***