Bug 242005 - Akonadi crashes during logging
Summary: Akonadi crashes during logging
Status: RESOLVED DUPLICATE of bug 240981
Alias: None
Product: Akonadi
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Volker Krause
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-17 16:03 UTC by Ladislav Nesnera
Modified: 2010-08-06 15:17 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
kbuildsycoca4 --noincremental.log (63.12 KB, text/plain)
2010-07-11 09:41 UTC, Ladislav Nesnera
Details
akonadictl star.log (9.88 KB, text/plain)
2010-07-11 09:43 UTC, Ladislav Nesnera
Details
crash log (4.58 KB, application/octet-stream)
2010-08-05 13:17 UTC, Ladislav Nesnera
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ladislav Nesnera 2010-06-17 16:03:50 UTC
Application: akonadi_nepomuk_calendar_feeder (0.1)
KDE Platform Version: 4.4.4 (KDE 4.4.4)
Qt Version: 4.6.3
Operating System: Linux 2.6.32-22-generic x86_64
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
Simply log into the KDE session (for the stupid Crash Handler - seems to be testing the string length)


 -- Backtrace:
Application: Akonadi Agent (akonadi_nepomuk_calendar_feeder), signal: Segmentation fault
[KCrash Handler]
#5  0x00007f702c3baf60 in KMimeType::mimeType (_name=..., options=KMimeType::ResolveAliases) at ../../kdecore/services/kmimetype.cpp:159
#6  0x00007f702bfb70aa in Akonadi::PluginRegistry::findBestMatch(QString const&) () from /usr/lib/libakonadi-kde.so.4
#7  0x00007f702bfb26b7 in Akonadi::ItemSerializer::pluginForMimeType (mimetype=...) at ../../akonadi/itemserializer.cpp:330
#8  0x00007f702bfb3204 in Akonadi::ItemSerializer::deserialize (item=..., label=..., data=..., version=0) at ../../akonadi/itemserializer.cpp:237
#9  0x00007f702bfb3864 in Akonadi::ItemSerializer::deserialize (item=..., label=..., data=..., version=0, external=<value optimized out>) at ../../akonadi/itemserializer.cpp:229
#10 0x00007f702bfd82be in Akonadi::ProtocolHelper::parseItemFetchResult (lineTokens=<value optimized out>, item=<value optimized out>) at ../../akonadi/protocolhelper.cpp:352
#11 0x00007f702bfaa95f in Akonadi::ItemFetchJob::doHandleResponse (this=<value optimized out>, tag=<value optimized out>, data=...) at ../../akonadi/itemfetchjob.cpp:173
#12 0x00007f702bfc022e in Akonadi::JobPrivate::handleResponse (this=<value optimized out>, tag=..., data=...) at ../../akonadi/job.cpp:72
#13 0x00007f702bfeddd8 in Akonadi::SessionPrivate::dataReceived (this=0x1fb1b40) at ../../akonadi/session.cpp:121
#14 0x00007f702bfee605 in Akonadi::Session::qt_metacall (this=0x2011a40, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7ffff8d43050) at ./session.moc:87
#15 0x00007f702bbb9036 in QMetaObject::activate (sender=0x1fa5850, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x1) at kernel/qobject.cpp:3295
#16 0x00007f702bc041c8 in QIODevice::qt_metacall (this=0x1fa5850, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7ffff8d43190) at .moc/release-shared/moc_qiodevice.cpp:77
#17 0x00007f7027aec580 in QLocalSocket::qt_metacall (this=0x7ffff8d42740, _c=636762864, _id=-120313520, _a=0x1) at .moc/release-shared/moc_qlocalsocket.cpp:81
#18 0x00007f702bbb9036 in QMetaObject::activate (sender=0x1fbdf50, m=<value optimized out>, local_signal_index=<value optimized out>, argv=0x1) at kernel/qobject.cpp:3295
#19 0x00007f7027ae552f in QAbstractSocketPrivate::canReadNotification (this=0x2019780) at socket/qabstractsocket.cpp:639
#20 0x00007f7027ad45e1 in QReadNotifier::event (this=<value optimized out>, e=0x7f7025f43af0) at socket/qnativesocketengine.cpp:1097
#21 0x00007f7028e34c0c in QApplicationPrivate::notify_helper (this=0x1f45e80, receiver=0x1fe6570, e=0x7ffff8d43740) at kernel/qapplication.cpp:4302
#22 0x00007f7028e3b0eb in QApplication::notify (this=0x7ffff8d43a20, receiver=0x1fe6570, e=0x7ffff8d43740) at kernel/qapplication.cpp:4185
#23 0x00007f702c950606 in KApplication::notify (this=0x7ffff8d43a20, receiver=0x1fe6570, event=0x7ffff8d43740) at ../../kdeui/kernel/kapplication.cpp:302
#24 0x00007f702bba5d9c in QCoreApplication::notifyInternal (this=0x7ffff8d43a20, receiver=0x1fe6570, event=0x7ffff8d43740) at kernel/qcoreapplication.cpp:726
#25 0x00007f702bbcf76a in QCoreApplication::sendEvent (source=0x1f499b0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#26 socketNotifierSourceDispatch (source=0x1f499b0) at kernel/qeventdispatcher_glib.cpp:110
#27 0x00007f7025f848c2 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#28 0x00007f7025f88748 in ?? () from /lib/libglib-2.0.so.0
#29 0x00007f7025f888fc in g_main_context_iteration () from /lib/libglib-2.0.so.0
#30 0x00007f702bbcf3b3 in QEventDispatcherGlib::processEvents (this=0x1f2d3b0, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#31 0x00007f7028ee518e in QGuiEventDispatcherGlib::processEvents (this=0x7ffff8d42740, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#32 0x00007f702bba46c2 in QEventLoop::processEvents (this=<value optimized out>, flags=) at kernel/qeventloop.cpp:149
#33 0x00007f702bba4a9c in QEventLoop::exec (this=0x7ffff8d439a0, flags=) at kernel/qeventloop.cpp:201
#34 0x00007f702bba973b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1003
#35 0x00007f702bf296a6 in Akonadi::AgentBase::init (r=0x1fe3b20) at ../../akonadi/agentbase.cpp:496
#36 0x00000000004083c8 in _start ()

Reported using DrKonqi
Comment 1 Tobias Koenig 2010-06-24 11:33:25 UTC
Hej,

does it help to stop akonadi, run 'kbuildsycoca4 --noincremental' and restart akonadi again?

Ciao,
Tobias
Comment 2 Ladislav Nesnera 2010-07-11 09:41:22 UTC
Created attachment 48765 [details]
kbuildsycoca4 --noincremental.log

Thanks for advice. At this moment I don't know whether the problem is resolved. I only attach console statements ;?)
Comment 3 Ladislav Nesnera 2010-07-11 09:43:49 UTC
Created attachment 48766 [details]
akonadictl star.log
Comment 4 Ladislav Nesnera 2010-08-02 11:30:54 UTC
As seems Tobisa's suggestion works. I don't met with Aconadi crash since I do that
Comment 5 Ladislav Nesnera 2010-08-05 13:17:34 UTC
Created attachment 49834 [details]
crash log

Oh no! Again :-(
Comment 6 Tobias Koenig 2010-08-06 15:17:19 UTC

*** This bug has been marked as a duplicate of bug 240981 ***