Bug 241913 - deleting a removable device triggered a device notifier crash
Summary: deleting a removable device triggered a device notifier crash
Status: RESOLVED WAITINGFORINFO
Alias: None
Product: solid
Classification: Unclassified
Component: libsolid-frontend (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Alex Fiestas
URL:
Keywords:
: 293621 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-06-16 15:48 UTC by Mark T. Kennedy
Modified: 2013-02-24 13:52 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark T. Kennedy 2010-06-16 15:48:29 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.4.3 (KDE 4.4.3)
Qt Version: 4.6.2
Operating System: Linux 2.6.33.5-112.fc13.x86_64 x86_64
Distribution: "Fedora release 13 (Goddard)"

-- Information about the crash:
after deleting a removable device entry, the device notifier crashed.

 -- Backtrace:
Application: Plasma Workspace (plasma-desktop), signal: Segmentation fault
82	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7fe139f1a860 (LWP 2693))]

Thread 4 (Thread 0x7fe11ca21710 (LWP 2695)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00000031ce423cce in PR_WaitCondVar (cvar=0x287c1f0, timeout=4294967295) at ../../../mozilla/nsprpub/pr/src/pthreads/ptsynch.c:417
#2  0x00007fe11cd1b4fc in ?? () from /usr/lib64/xulrunner-1.9.2/libmozjs.so
#3  0x00000031ce429843 in _pt_root (arg=0x287a3f0) at ../../../mozilla/nsprpub/pr/src/pthreads/ptthread.c:228
#4  0x00000031bb007761 in start_thread (arg=0x7fe11ca21710) at pthread_create.c:301
#5  0x00000031ba4e14dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 3 (Thread 0x7fe11c020710 (LWP 2696)):
#0  0x00000031ba4a6add in nanosleep () at ../sysdeps/unix/syscall-template.S:82
#1  0x00000031ba4a6950 in __sleep (seconds=0) at ../sysdeps/unix/sysv/linux/sleep.c:138
#2  0x00007fe11d3ae41d in ?? () from /usr/lib64/google-gadgets/modules/smjs-script-runtime.so
#3  0x00000031bb007761 in start_thread (arg=0x7fe11c020710) at pthread_create.c:301
#4  0x00000031ba4e14dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7fe1111b5710 (LWP 2740)):
#0  0x00000031ba4d7de3 in __poll (fds=<value optimized out>, nfds=<value optimized out>, timeout=<value optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x000000396b02cc0f in poll_func (ufds=0x7fe0fc0008c0, nfds=2, timeout=-1, userdata=0x353de00) at pulse/thread-mainloop.c:75
#2  0x000000396b01cae6 in pa_mainloop_poll (m=0x353e170) at pulse/mainloop.c:879
#3  0x000000396b01dec9 in pa_mainloop_iterate (m=0x353e170, block=<value optimized out>, retval=0x0) at pulse/mainloop.c:961
#4  0x000000396b01df80 in pa_mainloop_run (m=0x353e170, retval=0x0) at pulse/mainloop.c:979
#5  0x000000396b02ca0b in thread (userdata=0x353e130) at pulse/thread-mainloop.c:94
#6  0x0000003963a38878 in internal_thread_func (userdata=0x353e2f0) at pulsecore/thread-posix.c:72
#7  0x00000031bb007761 in start_thread (arg=0x7fe1111b5710) at pthread_create.c:301
#8  0x00000031ba4e14dd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7fe139f1a860 (LWP 2693)):
[KCrash Handler]
#5  0x00000031c5cb03e6 in ucstrcmp (a=0x294821a, alen=78, b=0x20, blen=32) at tools/qstring.cpp:176
#6  0x00000031c5cb0689 in QString::operator< (this=<value optimized out>, other=<value optimized out>) at tools/qstring.cpp:2124
#7  0x000000345942ae0b in qMapLessThanKey<QString> (this=0x2923cd0, udi=...) at /usr/include/QtCore/qmap.h:107
#8  findNode (this=0x2923cd0, udi=...) at /usr/include/QtCore/qmap.h:462
#9  contains (this=0x2923cd0, udi=...) at /usr/include/QtCore/qmap.h:530
#10 Solid::DeviceManagerPrivate::findRegisteredDevice (this=0x2923cd0, udi=...) at /usr/src/debug/kdelibs-4.4.3/solid/solid/devicemanager.cpp:209
#11 0x0000003459428883 in Solid::Device::Device (this=0x7fffb520e100, udi=...) at /usr/src/debug/kdelibs-4.4.3/solid/solid/device.cpp:74
#12 0x00007fe10b990fa5 in ?? () from /usr/lib64/kde4/kcm_device_automounter.so
#13 0x00000031ca2cb356 in data (this=<value optimized out>, event=0x7fffb520f1c0, view=0x3b220a0, option=<value optimized out>, index=<value optimized out>)
    at ../../src/corelib/kernel/qabstractitemmodel.h:398
#14 QAbstractItemDelegate::helpEvent (this=<value optimized out>, event=0x7fffb520f1c0, view=0x3b220a0, option=<value optimized out>, index=<value optimized out>)
    at itemviews/qabstractitemdelegate.cpp:358
#15 0x00000031ca3e65de in QAbstractItemDelegate::qt_metacall (this=0x3b5ed50, _c=QMetaObject::InvokeMetaMethod, _id=4, _a=0x7fffb520e310) at .moc/release-shared/moc_qabstractitemdelegate.cpp:89
#16 0x00000031ca323230 in QStyledItemDelegate::qt_metacall (this=0x3b5ed50, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffb520e310)
    at .moc/release-shared/moc_qstyleditemdelegate.cpp:68
#17 0x00000031c5d5fb36 in QMetaMethod::invoke (this=0x7fffb520e5c0, object=0x3b5ed50, connectionType=Qt::DirectConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=
    ..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1533
#18 0x00000031c5d601e6 in QMetaObject::invokeMethod (obj=0x3b5ed50, member=<value optimized out>, type=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=
    ..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1113
#19 0x00000031ca285eb4 in invokeMethod (this=<value optimized out>, event=<value optimized out>) at ../../src/corelib/kernel/qobjectdefs.h:381
#20 QAbstractItemView::viewportEvent (this=<value optimized out>, event=<value optimized out>) at itemviews/qabstractitemview.cpp:1597
#21 0x00000031ca2c05d2 in QTreeView::viewportEvent (this=0x3b220a0, event=0x7fffb520f1c0) at itemviews/qtreeview.cpp:1248
#22 0x00000031c5d570f7 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<value optimized out>, receiver=0x29e30a0, event=0x7fffb520f1c0) at kernel/qcoreapplication.cpp:819
#23 0x00000031c9daa9dc in QApplicationPrivate::notify_helper (this=0x1f6d270, receiver=0x29e30a0, e=0x7fffb520f1c0) at kernel/qapplication.cpp:4296
#24 0x00000031c9db132c in QApplication::notify (this=<value optimized out>, receiver=0x29e30a0, e=0x7fffb520f1c0) at kernel/qapplication.cpp:4004
#25 0x000000345a406da6 in KApplication::notify (this=0x1f5a230, receiver=0x29e30a0, event=0x7fffb520f1c0) at /usr/src/debug/kdelibs-4.4.3/kdeui/kernel/kapplication.cpp:302
#26 0x00000031c5d57cdc in QCoreApplication::notifyInternal (this=0x1f5a230, receiver=0x29e30a0, event=0x7fffb520f1c0) at kernel/qcoreapplication.cpp:704
#27 0x00000031c9dad1e4 in QApplication::event (this=0x1f5a230, e=0x7fffb520f7c0) at kernel/qapplication.cpp:2344
#28 0x00000031c9daaa0c in QApplicationPrivate::notify_helper (this=0x1f6d270, receiver=0x1f5a230, e=0x7fffb520f7c0) at kernel/qapplication.cpp:4300
#29 0x00000031c9db09db in QApplication::notify (this=<value optimized out>, receiver=0x1f5a230, e=0x7fffb520f7c0) at kernel/qapplication.cpp:4183
#30 0x000000345a406da6 in KApplication::notify (this=0x1f5a230, receiver=0x1f5a230, event=0x7fffb520f7c0) at /usr/src/debug/kdelibs-4.4.3/kdeui/kernel/kapplication.cpp:302
#31 0x00000031c5d57cdc in QCoreApplication::notifyInternal (this=0x1f5a230, receiver=0x1f5a230, event=0x7fffb520f7c0) at kernel/qcoreapplication.cpp:704
#32 0x00000031c5d804a2 in sendEvent (this=0x1f70a20) at kernel/qcoreapplication.h:215
#33 QTimerInfoList::activateTimers (this=0x1f70a20) at kernel/qeventdispatcher_unix.cpp:603
#34 0x00000031c5d7d938 in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:184
#35 idleTimerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:231
#36 0x00000031bc43bd02 in g_main_dispatch (context=0x1f6f920) at gmain.c:1960
#37 IA__g_main_context_dispatch (context=0x1f6f920) at gmain.c:2513
#38 0x00000031bc43fae8 in g_main_context_iterate (context=0x1f6f920, block=1, dispatch=1, self=<value optimized out>) at gmain.c:2591
#39 0x00000031bc43fc9c in IA__g_main_context_iteration (context=0x1f6f920, may_block=1) at gmain.c:2654
#40 0x00000031c5d7d603 in QEventDispatcherGlib::processEvents (this=0x1f41f80, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:412
#41 0x00000031c9e499de in QGuiEventDispatcherGlib::processEvents (this=<value optimized out>, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:204
#42 0x00000031c5d56722 in QEventLoop::processEvents (this=<value optimized out>, flags=...) at kernel/qeventloop.cpp:149
#43 0x00000031c5d569ec in QEventLoop::exec (this=0x7fffb520fa60, flags=...) at kernel/qeventloop.cpp:201
#44 0x00000031c5d58cd9 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#45 0x00007fe13ae99eb2 in kdemain (argc=1, argv=0x7fffb520fdf8) at /usr/src/debug/kdebase-workspace-4.4.3/plasma/desktop/shell/main.cpp:112
#46 0x00000031ba41ec5d in __libc_start_main (main=0x4008f0 <main(int, char**)>, argc=1, ubp_av=0x7fffb520fdf8, init=<value optimized out>, fini=<value optimized out>, 
    rtld_fini=<value optimized out>, stack_end=0x7fffb520fde8) at libc-start.c:226
#47 0x0000000000400829 in _start ()

Reported using DrKonqi
Comment 1 Jekyll Wu 2012-02-08 14:49:31 UTC
*** Bug 293621 has been marked as a duplicate of this bug. ***
Comment 2 Alex Fiestas 2012-04-22 01:21:26 UTC
What do you mean with:
removable device entry ?

Did you edit your device partition table or remove a place from the PlacesView?

Have you been able to reproduce this bug recently?

thanks !
Comment 3 Alex Fiestas 2013-02-24 13:52:52 UTC
Closing this bug since it's been 10 months until feedback was requested.

We are suffering from crashes like this and we have all the intention to finally fix this issue but to do so we need feedback since no developer can reproduce the crash.

Please, if you find the time to provide feedback and the bug is still reproducible for you (we have fixed some similar crashes in the last month) please please, re-open the bug.

Thanks for reporting !