Bug 241743 - Give an option to show timelines in reverse (¿natural?) order
Summary: Give an option to show timelines in reverse (¿natural?) order
Status: RESOLVED FIXED
Alias: None
Product: choqok
Classification: Unclassified
Component: general (show other bugs)
Version: 0.9.55 (1.0 Beta1)
Platform: Debian unstable Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Mehrdad Momeny
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-14 17:01 UTC by Lisandro Damián Nicanor Pérez Meyer
Modified: 2010-10-22 20:48 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Add option to display entries in natural order (5.19 KB, patch)
2010-06-25 17:10 UTC, Fede Heinz
Details
Untested version of the patch for SVN (5.11 KB, patch)
2010-06-25 17:15 UTC, Fede Heinz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lisandro Damián Nicanor Pérez Meyer 2010-06-14 17:01:23 UTC
Version:           0.9.55 (1.0 Beta1) (using KDE 4.4.3) 
OS:                Linux

Some people (including myself) believe that the natural order of listing things is older thing in the top, newer above (like, for example, comments on blogs).

It would be very nice to have an option to allow this in choqok.

Reproducible: Always




OS: Linux (x86_64) release 2.6.32-5-amd64
Compiler: cc
Comment 1 Fede Heinz 2010-06-25 17:10:11 UTC
Created attachment 48319 [details]
Add option to display entries in natural order

This patch adds the desired feature to version 0.9.55a. I know this is rather old, but attempting to satisfy the build requirements for the latest version from SVN would have been a lot of grief.
Comment 2 Fede Heinz 2010-06-25 17:15:14 UTC
Created attachment 48320 [details]
Untested version of the patch for SVN

This version of the patch applieas cleanly to the latest SVN, but I have been unable to test it due ti unsatisfied build dependencies on my system.
Comment 3 Lisandro Damián Nicanor Pérez Meyer 2010-06-26 02:50:35 UTC
I tried to compile choqok from svn to test this patch, but it fails to compile even on a clean (patchless) svn checkout due to a QOauth missing function.
Comment 4 Lisandro Damián Nicanor Pérez Meyer 2010-06-26 03:24:32 UTC
OK, it needed QOauth from git master. I could patch it, compile it and run chokoq from trunk, but can't get an account created (although I have for previous versions). 

Clearly that's why it's a trunk ;-)
Comment 5 Fede Heinz 2010-10-22 15:11:33 UTC
Is there anything holding adoption of this patch? Can I do anything to help get it into trunk?
Comment 6 Mehrdad Momeny 2010-10-22 16:30:53 UTC
SVN commit 1188521 by momeny:

FEATURE:241743 an option to show timelines in reverse order

 M  +7 -0      choqok/config/appearance/appearanceconfig_base.ui  
 M  +3 -0      libchoqok/choqokappearancesettings.kcfg  
 M  +26 -11    libchoqok/ui/timelinewidget.cpp  
 M  +4 -0      libchoqok/ui/timelinewidget.h  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1188521
Comment 7 Fede Heinz 2010-10-22 20:48:27 UTC
Gee, thanks!