Bug 241574 - Memory leaks after browsing 7…8 18Mpx images
Summary: Memory leaks after browsing 7…8 18Mpx images
Status: RESOLVED DUPLICATE of bug 296401
Alias: None
Product: gwenview
Classification: Applications
Component: general (show other bugs)
Version: 2.4
Platform: Archlinux Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-12 19:47 UTC by Michał
Modified: 2012-12-02 00:23 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michał 2010-06-12 19:47:46 UTC
Version:           2.4 (using KDE 4.4.3) 
OS:                Linux



Reproducible: Always

Steps to Reproduce:
Run Gwenview in folder with many 18Mpx or so images. Pick up one image and scroll to next using mouse wheel.

Actual Results:  
After seeing 7…8 images top says Gwenview has allocated 21% of available memory on a system with 2G RAM and 1.5G swap, which means 400MB of RAM.

Expected Results:  
Gwenview allocated about 18*3 or 18*4 MB for 18Mpx image and a couple of MB for code, shared libs, etc.
Comment 1 Michał 2010-06-12 19:53:16 UTC
Update on steps to reproduce (don't know how to edit bug):
On each image press middle button to see image in 1:1 and then again to go back to fit to screen.
Comment 2 Marco Gusy 2010-10-15 09:15:50 UTC
Happens to me too, just viewing images in fullscreen mode totally hangs the machine with crazy disk usage.
This is a severe bug because crashes the whole system.

amd64 2.6.33.6 kernel
Comment 3 Benni Hill 2012-03-22 19:40:11 UTC
Could you try my patch in bug 296401 if this problem still occurs for you?
Comment 4 Benni Hill 2012-12-02 00:23:16 UTC

*** This bug has been marked as a duplicate of bug 296401 ***