Bug 241275 - plasma freezes and takes a lot cpu when one opens the systray config and the widgets are locked
Summary: plasma freezes and takes a lot cpu when one opens the systray config and the ...
Status: RESOLVED DUPLICATE of bug 213068
Alias: None
Product: plasma4
Classification: Plasma
Component: widget-systemtray (show other bugs)
Version: unspecified
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-10 10:07 UTC by Christian Trippe
Modified: 2010-06-10 13:40 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Trippe 2010-06-10 10:07:21 UTC
Version:           unspecified (using Devel) 
OS:                Linux

Have your widgets locked and open the systray config. Then I cannot change anything and plasma uses ~70 % of my cpu.
I also cannot change windows via the taskbar.

This does not happen if the widgets are unlocked.

Using
Qt: 4.6.2
KDE: 4.4.85 (KDE 4.4.85 (KDE 4.5 Beta2)) "release 3"

Reproducible: Always




OS: Linux (i686) release 2.6.34-8-default
Compiler: gcc
Comment 1 Marco Martin 2010-06-10 11:10:35 UTC
doesn't seem reproducible with trunk here.
what do you have in the systray?
Comment 2 Christian Trippe 2010-06-10 11:23:29 UTC
(In reply to comment #1)
> doesn't seem reproducible with trunk here.
> what do you have in the systray?

visible:
kmail
klipper
knetworkmanager
kmix
synaptiks
battery-plasmoid

hidden:
device-notifier
krandrtray
kwallet
korganizer
kget

+ two strange entries where I do not know where they come from or how to delete them
org.kde.StatusNotifierItem-2774-1/StatusNotifierItem
org.kde.StatusNotifierItem-2817-1/StatusNotifierItem
Comment 3 Beat Wolf 2010-06-10 13:40:36 UTC

*** This bug has been marked as a duplicate of bug 213068 ***