Bug 241227 - konqueror file manager: home directory should show regular folders first and then hidden folders
Summary: konqueror file manager: home directory should show regular folders first and ...
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: Unlisted Binaries Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords:
: 278397 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-06-09 20:29 UTC by vatbier
Modified: 2021-08-05 14:19 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 21.08


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vatbier 2010-06-09 20:29:04 UTC
Version:           4.4.0 (using KDE 4.4.3) 
OS:                Linux

I've always set my konqueror file manager to show hidden files and folders.
The annoying thing is that my home directory is shown first with hidden folders and then the regular folders like Desktop, Documents, Downloads, etc.
Better is that the regular folders appear first as they are entered much more. Now I always have to scroll down the long list past the hidden folders to look for the regular folders.
Gnome Nautilus does this right with regular folders first. 
Please fix this.

Reproducible: Always
Comment 1 FiNeX 2010-08-15 22:20:48 UTC
I like to have the hidden file displayed first. Moreover someone else could like the bash-way (the "." is not considered while ordering).

So adding an option for choosing how order the hidden files looks like a bit exaggerate :-) :-) :-) :-)
Comment 2 ancow 2010-09-07 19:08:34 UTC
There already is an option to switch between "proper" sorting and natural order sorting. Why not do this properly with a choice between several styles (bash, mc, ...) and some fine-tuning options?
Alternatively, there already is an option to display directories first (View -> Sort By), an option to display hidden directories/files after visible ones would be right at home there...

(For the record, I like the current order, too.)
Comment 3 Janet 2010-11-01 16:26:02 UTC
I prefer the current sorting with the hidden files first. But options (. not considered, hidden files after visible ones) would be an acceptable alternative for everyone I guess.
Comment 4 Jekyll Wu 2011-12-14 18:17:11 UTC
*** Bug 278397 has been marked as a duplicate of this bug. ***
Comment 5 Jeroen van Meeuwen (Kolab Systems) 2012-08-24 16:21:28 UTC
Resetting assignee to default as per bug #305719
Comment 6 Justin Zobel 2021-03-09 02:19:03 UTC
Thank you for the bug report.

As this report hasn't seen any changes in 5 years or more, we ask if you can please confirm that the issue still persists.

If this bug is no longer persisting or relevant please change the status to resolved.
Comment 7 Bug Janitor Service 2021-04-27 05:55:44 UTC
A possibly relevant merge request was started @ https://invent.kde.org/system/dolphin/-/merge_requests/203
Comment 8 Méven Car 2021-05-10 07:38:42 UTC
Git commit 996e430b62075c5b69571f141456dbe5f2956679 by Méven Car, on behalf of Gastón Haro.
Committed on 10/05/2021 at 06:13.
Pushed by meven into branch 'master'.

Show hidden files and folders last

Hidden files and folders are always displayed after
not hidden files.

Revision: https://phabricator.kde.org/D29115

M  +9    -0    src/kitemviews/kfileitemmodel.cpp
M  +57   -5    src/tests/kfileitemmodeltest.cpp

https://invent.kde.org/system/dolphin/commit/996e430b62075c5b69571f141456dbe5f2956679
Comment 9 lnxusr 2021-05-15 07:35:47 UTC
This should be a setting that can be disabled.  I do not want the hidden files and folders to be show after the unhidden ones.
Comment 10 Chris Holland 2021-08-05 14:19:15 UTC
Git commit 50149d6abb8a0a978db3c6afb5238bc42a4a89c8 by Zren (Chris Holland), on behalf of Gaston Haro.
Committed on 05/08/2021 at 12:55.
Pushed by cholland into branch 'release/21.08'.

Configurable Show hidden files and folders last toggle

Revision: https://phabricator.kde.org/D29115

M  +22   -6    src/kitemviews/kfileitemmodel.cpp
M  +7    -0    src/kitemviews/kfileitemmodel.h
M  +5    -0    src/settings/dolphin_directoryviewpropertysettings.kcfg
M  +14   -0    src/settings/viewpropertiesdialog.cpp
M  +2    -0    src/settings/viewpropertiesdialog.h
M  +29   -0    src/views/dolphinview.cpp
M  +15   -0    src/views/dolphinview.h
M  +19   -0    src/views/dolphinviewactionhandler.cpp
M  +10   -0    src/views/dolphinviewactionhandler.h
M  +14   -0    src/views/viewproperties.cpp
M  +3    -0    src/views/viewproperties.h

https://invent.kde.org/system/dolphin/commit/50149d6abb8a0a978db3c6afb5238bc42a4a89c8