Bug 241152 - support to disable the tray icon
Summary: support to disable the tray icon
Status: RESOLVED FIXED
Alias: None
Product: choqok
Classification: Applications
Component: general (show other bugs)
Version: SVN
Platform: Unlisted Binaries Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Mehrdad Momeny
URL:
Keywords:
: 262884 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-06-09 00:16 UTC by mario tuling
Modified: 2014-06-02 09:44 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 1.5


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mario tuling 2010-06-09 00:16:33 UTC
Version:           latest svn snapshot (using Devel) 
OS:                Linux

it would be very nice if the choqok tray icon could be disabled.
i generally doesnt use it and i have some things in tray already.
thanks!

Reproducible: Didn't try
Comment 1 Aqeel Zafar 2010-11-01 12:36:47 UTC
It would be great if an option can be added to show system tray icon only when there are new messages, like kmail and few other applications do.
Comment 2 Mehrdad Momeny 2011-01-12 15:39:59 UTC
*** Bug 262884 has been marked as a duplicate of this bug. ***
Comment 3 Juha Siltala 2011-04-19 11:29:04 UTC
When the message indicator is in use, the tray icon is clearly redundant. IMO it might as well be disabled by default, with an option to turn it on for those without the indicator (or those who just love icons :) )
Comment 4 Andrea Scarpino 2014-06-01 15:36:59 UTC
Patch provided: https://git.reviewboard.kde.org/r/118455/
Comment 5 Andrea Scarpino 2014-06-02 09:20:35 UTC
Git commit a1c5f16211c84b0bd391389f490c716b645b3b8c by Andrea Scarpino.
Committed on 01/06/2014 at 15:32.
Pushed by scarpino into branch 'master'.

Add option to disable system tray

REVIEW:118455

M  +30   -18   choqok/config/behavior/behaviorconfig_general.ui
M  +64   -32   choqok/mainwindow.cpp
M  +4    -0    choqok/mainwindow.h
M  +3    -0    libchoqok/choqokbehaviorsettings.kcfg

http://commits.kde.org/choqok/a1c5f16211c84b0bd391389f490c716b645b3b8c