Bug 241080 - cannot use right click menu for renaming files
Summary: cannot use right click menu for renaming files
Status: RESOLVED DUPLICATE of bug 182353
Alias: None
Product: dolphin
Classification: Applications
Component: general (show other bugs)
Version: 16.12.2
Platform: PiSi Linux Linux
: NOR minor with 20 votes (vote)
Target Milestone: ---
Assignee: Peter Penz
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-08 09:18 UTC by Talha
Modified: 2010-06-08 11:15 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Talha 2010-06-08 09:18:28 UTC
Version:           unspecified (using Devel) 
OS:                Linux

For renaming various files, can you make it possible (again) to right click on the selected text and do copy, paste etc? Currently, when I right click on the file name in editing mode, it returns back to normal mode. 

For copying and pasting while renaming files, the ctrl+c and ctrl+v keys are of course available but the right click approach is also nice to have. It used to work in KDE 3 series and has always been available in Windows and probably most file managers out there. This has been causing me annoyance since the beginning of KDE 4.0.

Reproducible: Always

Steps to Reproduce:
Right click on the file name in edit text mode for renaming.

Actual Results:  
Dolphin exits text editing mode for file renaming.

Expected Results:  
The behavior in kde3 series, windows and probably all file managers is to see the right click menu where the user can cut or copy a part of the file name so that it can subsequently be pasted to another file name.
Comment 1 Frank Reininghaus 2010-06-08 11:15:58 UTC
Thanks for the bug report! This issue has been reported already.

*** This bug has been marked as a duplicate of bug 182353 ***