Bug 240957 - digikam crash
Summary: digikam crash
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Metadata-Engine (show other bugs)
Version: 1.2.0
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-06 23:01 UTC by Marian-N. ION
Modified: 2020-08-29 20:45 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 7.1.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marian-N. ION 2010-06-06 23:01:51 UTC
Application: digikam (1.2.0)
KDE Platform Version: 4.4.3 (KDE 4.4.3)
Qt Version: 4.6.2
Operating System: Linux 2.6.33.5-112.fc13.i686 i686
Distribution: "Fedora release 13 (Goddard)"

-- Information about the crash:
Gnome's file manager asked me what application I would like to use once the camera's SD was inserted in the card reader inserted in the USB port.
If I selected "digikam" then I got the crash; it works OK for gphoto.

The crash can be reproduced every time.

 -- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
[Current thread is 1 (Thread 0xb76ea7b0 (LWP 23776))]

Thread 2 (Thread 0xb6113b70 (LWP 23829)):
[KCrash Handler]
#6  Exiv2::ValueType<unsigned short>::toLong (this=0xb564ae88, n=0) at value.hpp:1548
#7  0x03f23bf5 in Exiv2::Exifdatum::toLong (this=<value optimized out>, n=<value optimized out>) at exif.cpp:407
#8  0x007086d7 in KExiv2Iface::KExiv2::getImageOrientation (this=0xb6112ebc) at /usr/src/debug/kdegraphics-4.4.3/libs/libkexiv2/libkexiv2/kexiv2image.cpp:275
#9  0x00fbf721 in Digikam::DMetadata::getMetadataField (this=0xb6112ebc, field=Digikam::MetadataInfo::Orientation) at /usr/src/debug/digikam-1.2.0/libs/dmetadata/dmetadata.cpp:1163
#10 0x00fc156f in Digikam::DMetadata::getMetadataFields (this=0xb6112ebc, fields=...) at /usr/src/debug/digikam-1.2.0/libs/dmetadata/dmetadata.cpp:1362
#11 0x001abfd9 in Digikam::ImageScanner::scanImageInformation (this=0xb6112eb4) at /usr/src/debug/digikam-1.2.0/libs/database/imagescanner.cpp:275
#12 0x001b0128 in Digikam::ImageScanner::scanFile (this=0xb6112eb4, mode=Digikam::ImageScanner::NewScan) at /usr/src/debug/digikam-1.2.0/libs/database/imagescanner.cpp:237
#13 0x001b033e in Digikam::ImageScanner::newFile (this=0xb6112eb4, albumId=266) at /usr/src/debug/digikam-1.2.0/libs/database/imagescanner.cpp:101
#14 0x0015ffb6 in Digikam::CollectionScanner::scanNewFile (this=0xb6113230, info=..., albumId=266) at /usr/src/debug/digikam-1.2.0/libs/database/collectionscanner.cpp:756
#15 0x001615d4 in Digikam::CollectionScanner::scanAlbum (this=0xb6113230, location=..., album=...) at /usr/src/debug/digikam-1.2.0/libs/database/collectionscanner.cpp:665
#16 0x0016145a in Digikam::CollectionScanner::scanAlbum (this=0xb6113230, location=..., album=...) at /usr/src/debug/digikam-1.2.0/libs/database/collectionscanner.cpp:683
#17 0x00162279 in Digikam::CollectionScanner::scanAlbumRoot (this=0xb6113230, location=...) at /usr/src/debug/digikam-1.2.0/libs/database/collectionscanner.cpp:479
#18 0x001625af in Digikam::CollectionScanner::completeScan (this=0xb6113230) at /usr/src/debug/digikam-1.2.0/libs/database/collectionscanner.cpp:250
#19 0x082c145e in Digikam::ScanController::run (this=0x9d963a0) at /usr/src/debug/digikam-1.2.0/digikam/scancontroller.cpp:541
#20 0x04fabfef in QThreadPrivate::start (arg=0x9d963a0) at thread/qthread_unix.cpp:248
#21 0x00a4b919 in start_thread (arg=0xb6113b70) at pthread_create.c:301
#22 0x00b90e5e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:133

Thread 1 (Thread 0xb76ea7b0 (LWP 23776)):
#0  0x00e02416 in __kernel_vsyscall ()
#1  0x00a4f23c in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:169
#2  0x04face8f in wait (this=0x9d8d454, mutex=0x9d8d440, time=4294967295) at thread/qwaitcondition_unix.cpp:87
#3  QWaitCondition::wait (this=0x9d8d454, mutex=0x9d8d440, time=4294967295) at thread/qwaitcondition_unix.cpp:159
#4  0x04fac089 in QThread::wait (this=0x9d963a0, time=4294967295) at thread/qthread_unix.cpp:619
#5  0x082c1784 in Digikam::ScanController::shutDown (this=0x9d963a0) at /usr/src/debug/digikam-1.2.0/digikam/scancontroller.cpp:290
#6  0x082c2fd2 in Digikam::ScanController::~ScanController (this=0x9d963a0, __in_chrg=<value optimized out>) at /usr/src/debug/digikam-1.2.0/digikam/scancontroller.cpp:273
#7  0x082c31bb in ~ScanControllerCreator () at /usr/src/debug/digikam-1.2.0/digikam/scancontroller.cpp:221
#8  destroy () at /usr/src/debug/digikam-1.2.0/digikam/scancontroller.cpp:222
#9  0x00ae148f in __run_exit_handlers (status=1) at exit.c:78
#10 exit (status=1) at exit.c:100
#11 0x021afa0c in qt_xio_errhandler () at kernel/qapplication_x11.cpp:739
#12 0x067eaa6b in KApplication::xioErrhandler (this=0xbfe79c18, dpy=0x9cd9648) at /usr/src/debug/kdelibs-4.4.3/kdeui/kernel/kapplication.cpp:408
#13 0x067eaaa7 in kde_xio_errhandler (dpy=0x9cd9648) at /usr/src/debug/kdelibs-4.4.3/kdeui/kernel/kapplication.cpp:125
#14 0x0954fa57 in _XIOError (dpy=0x9cd9648) at XlibInt.c:3138
#15 0x09557a43 in process_responses (dpy=<value optimized out>, wait_for_first_event=0, current_error=0x0, current_request=0) at xcb_io.c:247
#16 0x095583e7 in _XEventsQueued (dpy=0x9cd9648, mode=2) at xcb_io.c:263
#17 0x095409fb in XEventsQueued (dpy=0x9cd9648, mode=2) at Pending.c:44
#18 0x021ea6ef in x11EventSourcePrepare (s=0x9cc9140, timeout=0xbfe7987c) at kernel/qguieventdispatcher_glib.cpp:79
#19 0x00d37a6a in IA__g_main_context_prepare (context=<value optimized out>, priority=0xbfe798fc) at gmain.c:2280
#20 0x00d37e81 in g_main_context_iterate (context=0x9cc8290, block=1, dispatch=1, self=0x9c9b690) at gmain.c:2571
#21 0x00d38449 in IA__g_main_context_iteration (context=0x9cc8290, may_block=1) at gmain.c:2654
#22 0x050ca6ef in QEventDispatcherGlib::processEvents (this=0x9cc5f20, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#23 0x021ea556 in QGuiEventDispatcherGlib::processEvents (this=0x9cc5f20, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#24 0x050a0c1a in QEventLoop::processEvents (this=0x9d96078, flags=...) at kernel/qeventloop.cpp:149
#25 0x050a0f5a in QEventLoop::exec (this=0x9d96078, flags=...) at kernel/qeventloop.cpp:201
#26 0x082c23ed in Digikam::ScanController::completeCollectionScan (this=0x9d963a0, splash=0x9ee5030) at /usr/src/debug/digikam-1.2.0/digikam/scancontroller.cpp:378
#27 0x08279022 in Digikam::DigikamApp::DigikamApp (this=0x9dae7c0, __in_chrg=<value optimized out>, __vtt_parm=<value optimized out>) at /usr/src/debug/digikam-1.2.0/digikam/digikamapp.cpp:189
#28 0x0834611a in main (argc=3, argv=0xbfe7a064) at /usr/src/debug/digikam-1.2.0/digikam/main.cpp:170

Reported using DrKonqi
Comment 1 caulier.gilles 2010-06-07 00:31:06 UTC
Exiv2 issue. Please update this library to last 0.20.0 and try again.

Gilles Caulier
Comment 2 Johannes Wienke 2010-08-10 09:43:50 UTC
Merging with a more recent bug reports that includes more information.

*** This bug has been marked as a duplicate of bug 246675 ***
Comment 3 caulier.gilles 2020-08-29 20:45:06 UTC
Fixed with #246675