Bug 240752 - Plasma KDE 4.4.4 crash dopo "Annulla: copia"
Summary: Plasma KDE 4.4.4 crash dopo "Annulla: copia"
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 253887 255257 256207 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-06-04 19:23 UTC by Death Jax
Modified: 2011-12-06 13:12 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (5.59 KB, text/plain)
2011-05-19 02:10 UTC, Gustavo Gingins
Details
New crash information added by DrKonqi (6.56 KB, text/plain)
2011-06-23 17:28 UTC, Edward Oubrayrie
Details
New crash information added by DrKonqi (6.08 KB, text/plain)
2011-10-11 04:40 UTC, Vladimir Dergachev
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Death Jax 2010-06-04 19:23:32 UTC
Application: plasma-desktop (0.3)
KDE Platform Version: 4.4.4 (KDE 4.4.4)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-22-generic i686
Distribution: Ubuntu 10.04 LTS

-- Information about the crash:
Ho creato 1 file di testo, poi due copie con nomi diversi dello stesso. Ho poi spostato da terminale i 3 files in una cartella e facendo sul desktop "tasto dx del mouse -> Annulla: copia" mi ha segnalato di eliminare uno dei 3 files creati in precedenza, io ho accettato ma subito è stato visualizzato un errore che mi avvisava che il file non esisteva, da questo momento in poi il gestore delle notifiche ha iniziato ad elaborare qualcosa (però non ne visualizzava nessuna informazione, ma visualizzava solo che stava procesando 0/1 qualcosa) e quando dopo un pò cerco di terminarlo stoppandolo (con il pulsante tipo "stop" presente sul gestore) va in crash tutto l'ambiente Plasma, riavviandosi poco dopo.

 -- Backtrace:
Application: Spazio di lavoro di Plasma (kdeinit4), signal: Segmentation fault
[Current thread is 1 (Thread 0xb78baaa0 (LWP 1508))]

Thread 2 (Thread 0xab807b70 (LWP 1517)):
#0  0x064e6e16 in clock_gettime () from /lib/tls/i686/cmov/librt.so.1
#1  0x04bd16fb in qt_gettime () at kernel/qcore_unix.cpp:111
#2  0x04bd6825 in QTimerInfoList::updateCurrentTime (this=0x9dab684) at kernel/qeventdispatcher_unix.cpp:340
#3  0x04bd686a in QTimerInfoList::timerWait (this=0x9dab684, tm=...) at kernel/qeventdispatcher_unix.cpp:443
#4  0x04bd4818 in timerSourcePrepareHelper (src=<value optimized out>, timeout=0xab8070cc) at kernel/qeventdispatcher_glib.cpp:136
#5  0x04bd48a5 in timerSourcePrepare (source=0x0, timeout=0x64eaff4) at kernel/qeventdispatcher_glib.cpp:169
#6  0x094e5aca in g_main_context_prepare () from /lib/libglib-2.0.so.0
#7  0x094e5ee9 in ?? () from /lib/libglib-2.0.so.0
#8  0x094e64b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#9  0x04bd460f in QEventDispatcherGlib::processEvents (this=0x9f85978, flags=...) at kernel/qeventdispatcher_glib.cpp:414
#10 0x04ba7059 in QEventLoop::processEvents (this=0xab807290, flags=) at kernel/qeventloop.cpp:149
#11 0x04ba74aa in QEventLoop::exec (this=0xab807290, flags=...) at kernel/qeventloop.cpp:201
#12 0x04aa35a8 in QThread::exec (this=0x9f81a48) at thread/qthread.cpp:487
#13 0x04b86c1b in QInotifyFileSystemWatcherEngine::run (this=0x9f81a48) at io/qfilesystemwatcher_inotify.cpp:248
#14 0x04aa632e in QThreadPrivate::start (arg=0x9f81a48) at thread/qthread_unix.cpp:248
#15 0x0011596e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
#16 0x01639a4e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb78baaa0 (LWP 1508)):
[KCrash Handler]
#6  0x00000004 in ?? ()
#7  0x0058c592 in KJob::kill (this=0x9fe0e30, verbosity=KJob::EmitResult) at ../../kdecore/jobs/kjob.cpp:106
#8  0x00e5df97 in KUiServerJobTracker::Private::_k_killJob (this=0xa4aa930) at ../../kdeui/jobs/kuiserverjobtracker.cpp:58
#9  0x00e5e009 in KUiServerJobTracker::qt_metacall (this=0xa5b15f8, _c=QMetaObject::InvokeMetaMethod, _id=25, _a=0xbfa2ff4c) at ./kuiserverjobtracker.moc:100
#10 0x04badc9a in QMetaObject::metacall (object=0xa5b15f8, cl=14, idx=25, argv=0xbfa2ff4c) at kernel/qmetaobject.cpp:237
#11 0x04bbc3d5 in QMetaObject::activate (sender=0xa47a5e0, m=0x1032484, local_signal_index=0, argv=0x0) at kernel/qobject.cpp:3293
#12 0x00fdefc7 in OrgKdeJobViewInterface::cancelRequested (this=0xa47a5e0) at jobviewiface.moc:119
#13 0x00fdf3c3 in OrgKdeJobViewInterface::qt_metacall (this=0xa47a5e0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfa3020c) at jobviewiface.moc:96
#14 0x0023fb34 in QDBusConnectionPrivate::deliverCall (this=0x9c85e40, object=0xa47a5e0, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:904
#15 0x0024aea7 in QDBusCallDeliveryEvent::placeMetaCall (this=0xa8c1098, object=0xa47a5e0) at qdbusintegrator_p.h:101
#16 0x04bb93fe in QObject::event (this=0xa47a5e0, e=0xa8c1098) at kernel/qobject.cpp:1248
#17 0x018f84dc in QApplicationPrivate::notify_helper (this=0x9c8b300, receiver=0xa47a5e0, e=0xa8c1098) at kernel/qapplication.cpp:4300
#18 0x018ff05e in QApplication::notify (this=0x9c85170, receiver=0xa47a5e0, e=0xa8c1098) at kernel/qapplication.cpp:3704
#19 0x00e62ffa in KApplication::notify (this=0x9c85170, receiver=0xa47a5e0, event=0xa8c1098) at ../../kdeui/kernel/kapplication.cpp:302
#20 0x04ba8a3b in QCoreApplication::notifyInternal (this=0x9c85170, receiver=0xa47a5e0, event=0xa8c1098) at kernel/qcoreapplication.cpp:704
#21 0x04bab473 in QCoreApplication::sendEvent (receiver=0x0, event_type=0, data=0x9c3c550) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:215
#22 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x9c3c550) at kernel/qcoreapplication.cpp:1345
#23 0x04bab5dd in QCoreApplication::sendPostedEvents (receiver=0x0, event_type=0) at kernel/qcoreapplication.cpp:1238
#24 0x04bd4adf in QCoreApplication::sendPostedEvents (s=0x9c8d310) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:220
#25 postEventSourceDispatch (s=0x9c8d310) at kernel/qeventdispatcher_glib.cpp:276
#26 0x094e25e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#27 0x094e62d8 in ?? () from /lib/libglib-2.0.so.0
#28 0x094e64b8 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#29 0x04bd45d5 in QEventDispatcherGlib::processEvents (this=0x9c8afd0, flags=...) at kernel/qeventdispatcher_glib.cpp:412
#30 0x019b8135 in QGuiEventDispatcherGlib::processEvents (this=0x9c8afd0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#31 0x04ba7059 in QEventLoop::processEvents (this=0xbfa30a34, flags=) at kernel/qeventloop.cpp:149
#32 0x04ba74aa in QEventLoop::exec (this=0xbfa30a34, flags=...) at kernel/qeventloop.cpp:201
#33 0x04bab69f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:981
#34 0x018f8577 in QApplication::exec () at kernel/qapplication.cpp:3579
#35 0x059a005e in kdemain (argc=1, argv=0x9c78100) at ../../../../plasma/desktop/shell/main.cpp:112
#36 0x0804e133 in launch (argc=<value optimized out>, _name=<value optimized out>, args=<value optimized out>, cwd=0x0, envc=0, envs=0x9c53370 "", reset_env=false, tty=0x0, avoid_loops=false, 
    startup_id_str=0x8051465 "0") at ../../kinit/kinit.cpp:717
#37 0x0804ec6d in handle_launcher_request (sock=<value optimized out>, who=<value optimized out>) at ../../kinit/kinit.cpp:1209
#38 0x0804f190 in handle_requests (waitForPid=<value optimized out>) at ../../kinit/kinit.cpp:1402
#39 0x0804fe4f in main (argc=4, argv=0xbfa314e4, envp=0xbfa314f8) at ../../kinit/kinit.cpp:1845

This bug may be a duplicate of or related to bug 168427, bug 211277.

Possible duplicates by query: bug 219627, bug 211277.

Reported using DrKonqi
Comment 1 Aaron J. Seigo 2010-06-04 21:46:15 UTC
SVN commit 1134645 by aseigo:

with async dbus calls it's plausible for really fast jobs (e.g. failures on local files) to beat the round trip of the dbus call, leaving us with a dangling pointer, which leads to crashes and other bad events.
BUG:240752,211277


 M  +13 -1     kuiserverjobtracker.cpp  


WebSVN link: http://websvn.kde.org/?view=rev&revision=1134645
Comment 2 Beat Wolf 2010-11-06 14:56:05 UTC
*** Bug 253887 has been marked as a duplicate of this bug. ***
Comment 3 Beat Wolf 2010-11-06 14:56:10 UTC
*** Bug 255257 has been marked as a duplicate of this bug. ***
Comment 4 Beat Wolf 2010-11-06 14:56:14 UTC
*** Bug 256207 has been marked as a duplicate of this bug. ***
Comment 5 Beat Wolf 2010-11-06 14:56:52 UTC
reopening bug after duplicates against 4.5.3 where found.
Comment 6 Dario Andres 2010-11-20 23:06:21 UTC
[Comment from a bug triager]
Bug 192547 includes reliable steps in order to reproduce the same crash in Dolphin, that may be useful to track down the issue in the KUIServerJobTracker code
Comment 7 Gustavo Gingins 2011-05-19 02:10:42 UTC
Created attachment 60137 [details]
New crash information added by DrKonqi

konqueror (4.6.1 (4.6.1)) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.0

- What I was doing when the application crashed:
I tried to undo a remove file operation which threw me an error, and the notification area showed that the command was being executed (but no progress made), so I pressed the stop button on it and konqueror crashed.

-- Backtrace (Reduced):
#8  0xb69e6282 in KJob::kill (this=0x9880930, verbosity=KJob::EmitResult) at ../../kdecore/jobs/kjob.cpp:106
#9  0xb6d75c57 in KUiServerJobTracker::Private::_k_killJob (this=0x984fa40) at ../../kdeui/jobs/kuiserverjobtracker.cpp:59
#10 0xb6d75cc9 in KUiServerJobTracker::qt_metacall (this=0x97bd748, _c=QMetaObject::InvokeMetaMethod, _id=25, _a=0xbf8b032c) at ./kuiserverjobtracker.moc:100
[...]
#13 0xb6f06dc7 in OrgKdeJobViewV2Interface::cancelRequested (this=0x97a6f28) at jobviewifacev2.moc:122
#14 0xb6f073ab in OrgKdeJobViewV2Interface::qt_metacall (this=0x97a6f28, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbf8b061c) at jobviewifacev2.moc:98
Comment 8 Edward Oubrayrie 2011-06-23 17:28:18 UTC
Created attachment 61280 [details]
New crash information added by DrKonqi

dolphin (1.6.1) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

Same for me, crashed when canceling a buggy (i.e. no progress made) file operation in the systray

-- Backtrace (Reduced):
#7  0x00007f6fe43c4db1 in KJob::kill (this=0x2c9af30, verbosity=KJob::EmitResult) at ../../kdecore/jobs/kjob.cpp:106
#8  0x00007f6fe5631cb9 in KUiServerJobTracker::Private::_k_killJob (this=0x1db83f0) at ../../kdeui/jobs/kuiserverjobtracker.cpp:59
#9  0x00007f6fe5631d0d in KUiServerJobTracker::qt_metacall (this=0x2205640, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffff677c90) at ./kuiserverjobtracker.moc:100
[...]
#11 0x00007f6fe5774ca0 in OrgKdeJobViewV2Interface::qt_metacall (this=0x1d9fec0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fffff678170) at jobviewifacev2.moc:98
#12 0x00007f6fe3ba69fa in QDBusConnectionPrivate::deliverCall (this=0x1942080, object=0x1d9fec0, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:942
Comment 9 Vladimir Dergachev 2011-10-11 04:40:37 UTC
Created attachment 64401 [details]
New crash information added by DrKonqi

dolphin (1.6.1) on KDE Platform 4.6.2 (4.6.2) using Qt 4.7.2

- What I was doing when the application crashed:
There was a copy process stuck in the background, I clicked to cancel and the crash message poped up.

-- Backtrace (Reduced):
#6  KJob::kill (this=0x31a86e0, verbosity=KJob::EmitResult) at ../../kdecore/jobs/kjob.cpp:106
#7  0x00007f11282bfcb9 in KUiServerJobTracker::Private::_k_killJob (this=0x203ca00) at ../../kdeui/jobs/kuiserverjobtracker.cpp:59
#8  0x00007f11282bfd0d in KUiServerJobTracker::qt_metacall (this=0x20dd970, _c=QMetaObject::InvokeMetaMethod, _id=<value optimized out>, _a=0x7fffa688b640) at ./kuiserverjobtracker.moc:100
[...]
#10 0x00007f1128402ca0 in OrgKdeJobViewV2Interface::qt_metacall (this=0x2fbf4d0, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0x7fffa688bb20) at jobviewifacev2.moc:98
#11 0x00007f11268309fa in QDBusConnectionPrivate::deliverCall (this=0x14fb150, object=0x2fbf4d0, msg=..., metaTypes=..., slotIdx=5) at qdbusintegrator.cpp:942
Comment 10 Aaron J. Seigo 2011-12-06 13:12:24 UTC
Git commit ab085075aa3db0a9f385db13943f0973113a1928 by Aaron Seigo.
Committed on 06/12/2011 at 14:10.
Pushed by aseigo into branch 'KDE/4.7'.

if a job is just deleted without a result being set or calling kill, finished is never emited, leaving dangling pointers in the job tracker

BUG:240752

M  +6    -0    kdecore/jobs/kjob.cpp

http://commits.kde.org/kdelibs/ab085075aa3db0a9f385db13943f0973113a1928