Bug 240535 - kde.org "support" section doesnt stay on the right on hover
Summary: kde.org "support" section doesnt stay on the right on hover
Status: RESOLVED WORKSFORME
Alias: None
Product: www.kde.org
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Unlisted Binaries Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kde-www mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-06-03 00:22 UTC by Oceanwatcher
Modified: 2010-11-14 01:04 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Frontpage showing menu problem (257.89 KB, image/png)
2010-06-03 00:22 UTC, Oceanwatcher
Details
kde.org shown with menu with 851px (271.35 KB, image/png)
2010-06-03 00:25 UTC, Oceanwatcher
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oceanwatcher 2010-06-03 00:22:33 UTC
Created attachment 47623 [details]
Frontpage showing menu problem

Version:           unspecified
OS:                Linux

Initially, the menu looks ok. But when I hover with the mouse to expand the menu, the whole support section drops down under the developer section.

This is most likely because of a lack of space horisontally.

Reproducible: Didn't try

Steps to Reproduce:
Load kde.org frontpage in Firefox 3.6.3
Hover mouse over Support menu

Actual Results:  
The whole sections drops under the developer section

Expected Results:  
Just a normal dropdown with the support section on the same level as other sections.

It should be fairly easy to fix this and there are probably several ways to do it.

I did a quick check with Firebug and you have a file

http://www.kde.org/media/includes/chihuahua/css.php

On line 63, there is a statement:

with: auto;

If you instead set

with: 851px;

the menu will display just fine instead of dropping down.

Another way might be reducing padding/margins on the individual elements in the menu so they get closer to each other. But with the current setup, 851 pixels is the minimum with needed to keep everything on the same level. If you try with 850 pixels, the support section drops down.

Any way you fix this, it should be done as it looks very bad and can cause a bit of confusion.
Comment 1 Oceanwatcher 2010-06-03 00:25:27 UTC
Created attachment 47624 [details]
kde.org shown with menu with 851px
Comment 2 Oceanwatcher 2010-06-03 00:26:45 UTC
Sorry - Reproducible: Always!
Comment 3 Jakob Lehmann 2010-06-06 20:54:18 UTC
Happens in rekonq too.
Comment 4 Oceanwatcher 2010-06-06 21:41:24 UTC
Google Chrome 5.0.375.70 beta - works fine. Menu shifts a little to the left, but all parts are correct in relations to each other.

Opera v. 10.53 build 6330 gives the reported problem with the menu.

Both are Linux versions of the browsers.
Comment 5 Ben Cooksley 2010-11-13 05:17:47 UTC
After the revamp to Plasma style submenus, this no longer seems to occur...
Comment 6 Oceanwatcher 2010-11-14 01:04:31 UTC
Yes, works for me too. Thank you for fixing it.