Bug 240142 - If I press Copy Here while attempting to Drag and drop of a file, the original is deleted,
Summary: If I press Copy Here while attempting to Drag and drop of a file, the origina...
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Usability-Drag&Drop (show other bugs)
Version: 1.4.0
Platform: Microsoft Windows Microsoft Windows
: NOR major (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-05-30 21:46 UTC by dicusar
Modified: 2017-08-01 12:36 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dicusar 2010-05-30 21:46:02 UTC
Version:           unspecified (using KDE 4.3.4) 
OS:                MS Windows

I tried to drag and drop a file from one of my directories to digikam space for
files. I am asked if I want to move the file, to copy the file, or cancel. If I
press Copy Here, the original file is deleted, this should not be normal

Reproducible: Always

Steps to Reproduce:
drag and drop file on digikam space where files are listed, press Copy Here in
the
menu


Actual Results:  
original file is deleted

Expected Results:  
original files should stay
Comment 1 caulier.gilles 2010-05-31 11:07:46 UTC
Same there : Which digiKam version you use ?

I think it's solved in 1.2.0

Gilles Caulier
Comment 2 Marcel Wiesweg 2010-05-31 14:59:17 UTC
I assume these three bugs 240139, 240140 and 240142 are MS Windows specific
Comment 3 caulier.gilles 2010-11-24 09:09:26 UTC
digiKam 1.6.0 is out:

http://www.digikam.org/drupal/node/550

Please update and check if this entry still valid.

Thanks in advance

Gilles Caulier
Comment 4 Julien Narboux 2010-12-27 17:45:07 UTC
*** Bug 261134 has been marked as a duplicate of this bug. ***
Comment 5 caulier.gilles 2011-07-03 14:21:19 UTC
Please try digiKam 2.0.0 RC just out for windows, and give us some feedback

Gilles Caulier
Comment 6 caulier.gilles 2015-07-03 05:58:08 UTC
New digiKam 4.11.0 is available.

https://www.digikam.org/node/740

Can you reproduce the problem with this release ?

Gilles Caulier
Comment 7 caulier.gilles 2015-07-06 07:39:55 UTC
digiKam 4.11.0 Windows installer is available for download :

http://download.kde.org/stable/digikam/digiKam-installer-4.11.0-win32.exe.mirrorlist
Comment 8 caulier.gilles 2016-05-28 18:24:16 UTC
With next digiKam 5.0.0, we will provide a fully cross-compiled version Windows under Linux where a lots of problems have been fixed.

https://www.flickr.com/photos/digikam/27033685570/in/dateposted-public/

The Windows installer is available here to test :

https://drive.google.com/open?id=0B7yq-xFihT0_SzhxVzF1RDhPbFE

Gilles Caulier